Re: [ovirt-users] hosted exchange failed to install

2017-11-14 Thread Rudi Ahlers
Thanx Alan.

On Tue, Nov 14, 2017 at 10:11 PM, Alan Griffiths 
wrote:

> Mount the Gluster volume and delete everything on it.  Should be a
> directory with a UUID name and a file called __DIRECT_IO_TEST__
>
> On 14 November 2017 at 18:54, Rudi Ahlers  wrote:
> > Hi
> >
> > Please be a bit more specific. What exactly do I need to delete? It's on
> > GlusterFS
> >
> > On Tue, Nov 14, 2017 at 7:47 PM, Alan Griffiths  >
> > wrote:
> >>
> >> Looks like you need to clean out your storage domain left over from
> >> the previous install attempt. What are you using, gluster, NFS?
> >>
> >> On 14 November 2017 at 14:35, Rudi Ahlers  wrote:
> >> > Hi,
> >> >
> >> > Can someone please help?
> >> >
> >> > I installed hosted exchange but specified the wrong interface, and
> thus
> >> > couldn't access it. So I removed it (yum install) and reinstalled it,
> >> > and
> >> > re-ran the deploy but got the following error:
> >> >
> >> >  Please confirm installation settings (Yes, No)[Yes]:
> >> > [ INFO  ] Stage: Transaction setup
> >> > [ INFO  ] Stage: Misc configuration
> >> > [ INFO  ] Stage: Package installation
> >> > [ INFO  ] Stage: Misc configuration
> >> > [ INFO  ] Configuring libvirt
> >> > [ INFO  ] Configuring VDSM
> >> > [WARNING] VDSM configuration file not found: creating a new
> >> > configuration
> >> > file
> >> > [ INFO  ] Starting vdsmd
> >> > [ INFO  ] Creating Storage Domain
> >> > [ ERROR ] Failed to execute stage 'Misc configuration': Storage domain
> >> > is
> >> > not empty - requires cleaning: (u'srv1:/engine',)
> >> > [ INFO  ] Yum Performing yum transaction rollback
> >> > [ INFO  ] Stage: Clean up
> >> > [ INFO  ] Generating answer file
> >> > '/var/lib/ovirt-hosted-engine-setup/answers/answers-
> 20171114162130.conf'
> >> > [ INFO  ] Stage: Pre-termination
> >> > [ INFO  ] Stage: Termination
> >> > [ ERROR ] Hosted Engine deployment failed: this system is not
> reliable,
> >> > please check the issue,fix and redeploy
> >> >   Log file is located at
> >> >
> >> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-
> setup-20171114161520-km3qok.log
> >> >
> >> >
> >> >
> >> > I am honestly not sure why it would think "this system is not
> reliable".
> >> > How
> >> > do I check what is actually wrong?
> >> >
> >> > The log file shows the same error:
> >> >
> >> >
> >> > tail -f
> >> >
> >> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-
> setup-20171114161520-km3qok.log
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
> >> > condition
> >> > False
> >> > 2017-11-14 16:21:30 INFO otopi.context context.runSequence:687 Stage:
> >> > Termination
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context.runSequence:691 STAGE
> >> > terminate
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128
> Stage
> >> > terminate METHOD otopi.plugins.gr_he_common.
> core.misc.Plugin._terminate
> >> > 2017-11-14 16:21:30 ERROR otopi.plugins.gr_he_common.core.misc
> >> > misc._terminate:178 Hosted Engine deployment failed: this system is
> not
> >> > reliable, please check the issue,fix and redeploy
> >> > 2017-11-14 16:21:30 DEBUG otopi.plugins.otopi.dialog.human
> >> > dialog.__logString:204 DIALOG:SEND Log file is located
> >> > at
> >> >
> >> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-
> setup-20171114161520-km3qok.log
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128
> Stage
> >> > terminate METHOD otopi.plugins.otopi.dialog.human.Plugin._terminate
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128
> Stage
> >> > terminate METHOD otopi.plugins.otopi.dialog.machine.Plugin._terminate
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
> >> > condition
> >> > False
> >> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128
> Stage
> >> > terminate METHOD otopi.plugins.otopi.core.log.Plugin._terminate
> >> >
> >> >
> >> > --
> >> > Kind Regards
> >> > Rudi Ahlers
> >> > Website: http://www.rudiahlers.co.za
> >> >
> >> > ___
> >> > Users mailing list
> >> > Users@ovirt.org
> >> > http://lists.ovirt.org/mailman/listinfo/users
> >> >
> >
> >
> >
> >
> > --
> > Kind Regards
> > Rudi Ahlers
> > Website: http://www.rudiahlers.co.za
>



-- 
Kind Regards
Rudi Ahlers
Website: http://www.rudiahlers.co.za
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] hosted exchange failed to install

2017-11-14 Thread Alan Griffiths
Mount the Gluster volume and delete everything on it.  Should be a
directory with a UUID name and a file called __DIRECT_IO_TEST__

On 14 November 2017 at 18:54, Rudi Ahlers  wrote:
> Hi
>
> Please be a bit more specific. What exactly do I need to delete? It's on
> GlusterFS
>
> On Tue, Nov 14, 2017 at 7:47 PM, Alan Griffiths 
> wrote:
>>
>> Looks like you need to clean out your storage domain left over from
>> the previous install attempt. What are you using, gluster, NFS?
>>
>> On 14 November 2017 at 14:35, Rudi Ahlers  wrote:
>> > Hi,
>> >
>> > Can someone please help?
>> >
>> > I installed hosted exchange but specified the wrong interface, and thus
>> > couldn't access it. So I removed it (yum install) and reinstalled it,
>> > and
>> > re-ran the deploy but got the following error:
>> >
>> >  Please confirm installation settings (Yes, No)[Yes]:
>> > [ INFO  ] Stage: Transaction setup
>> > [ INFO  ] Stage: Misc configuration
>> > [ INFO  ] Stage: Package installation
>> > [ INFO  ] Stage: Misc configuration
>> > [ INFO  ] Configuring libvirt
>> > [ INFO  ] Configuring VDSM
>> > [WARNING] VDSM configuration file not found: creating a new
>> > configuration
>> > file
>> > [ INFO  ] Starting vdsmd
>> > [ INFO  ] Creating Storage Domain
>> > [ ERROR ] Failed to execute stage 'Misc configuration': Storage domain
>> > is
>> > not empty - requires cleaning: (u'srv1:/engine',)
>> > [ INFO  ] Yum Performing yum transaction rollback
>> > [ INFO  ] Stage: Clean up
>> > [ INFO  ] Generating answer file
>> > '/var/lib/ovirt-hosted-engine-setup/answers/answers-20171114162130.conf'
>> > [ INFO  ] Stage: Pre-termination
>> > [ INFO  ] Stage: Termination
>> > [ ERROR ] Hosted Engine deployment failed: this system is not reliable,
>> > please check the issue,fix and redeploy
>> >   Log file is located at
>> >
>> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
>> >
>> >
>> >
>> > I am honestly not sure why it would think "this system is not reliable".
>> > How
>> > do I check what is actually wrong?
>> >
>> > The log file shows the same error:
>> >
>> >
>> > tail -f
>> >
>> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
>> > condition
>> > False
>> > 2017-11-14 16:21:30 INFO otopi.context context.runSequence:687 Stage:
>> > Termination
>> > 2017-11-14 16:21:30 DEBUG otopi.context context.runSequence:691 STAGE
>> > terminate
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
>> > terminate METHOD otopi.plugins.gr_he_common.core.misc.Plugin._terminate
>> > 2017-11-14 16:21:30 ERROR otopi.plugins.gr_he_common.core.misc
>> > misc._terminate:178 Hosted Engine deployment failed: this system is not
>> > reliable, please check the issue,fix and redeploy
>> > 2017-11-14 16:21:30 DEBUG otopi.plugins.otopi.dialog.human
>> > dialog.__logString:204 DIALOG:SEND Log file is located
>> > at
>> >
>> > /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
>> > terminate METHOD otopi.plugins.otopi.dialog.human.Plugin._terminate
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
>> > terminate METHOD otopi.plugins.otopi.dialog.machine.Plugin._terminate
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
>> > condition
>> > False
>> > 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
>> > terminate METHOD otopi.plugins.otopi.core.log.Plugin._terminate
>> >
>> >
>> > --
>> > Kind Regards
>> > Rudi Ahlers
>> > Website: http://www.rudiahlers.co.za
>> >
>> > ___
>> > Users mailing list
>> > Users@ovirt.org
>> > http://lists.ovirt.org/mailman/listinfo/users
>> >
>
>
>
>
> --
> Kind Regards
> Rudi Ahlers
> Website: http://www.rudiahlers.co.za
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] hosted exchange failed to install

2017-11-14 Thread Alan Griffiths
Looks like you need to clean out your storage domain left over from
the previous install attempt. What are you using, gluster, NFS?

On 14 November 2017 at 14:35, Rudi Ahlers  wrote:
> Hi,
>
> Can someone please help?
>
> I installed hosted exchange but specified the wrong interface, and thus
> couldn't access it. So I removed it (yum install) and reinstalled it, and
> re-ran the deploy but got the following error:
>
>  Please confirm installation settings (Yes, No)[Yes]:
> [ INFO  ] Stage: Transaction setup
> [ INFO  ] Stage: Misc configuration
> [ INFO  ] Stage: Package installation
> [ INFO  ] Stage: Misc configuration
> [ INFO  ] Configuring libvirt
> [ INFO  ] Configuring VDSM
> [WARNING] VDSM configuration file not found: creating a new configuration
> file
> [ INFO  ] Starting vdsmd
> [ INFO  ] Creating Storage Domain
> [ ERROR ] Failed to execute stage 'Misc configuration': Storage domain is
> not empty - requires cleaning: (u'srv1:/engine',)
> [ INFO  ] Yum Performing yum transaction rollback
> [ INFO  ] Stage: Clean up
> [ INFO  ] Generating answer file
> '/var/lib/ovirt-hosted-engine-setup/answers/answers-20171114162130.conf'
> [ INFO  ] Stage: Pre-termination
> [ INFO  ] Stage: Termination
> [ ERROR ] Hosted Engine deployment failed: this system is not reliable,
> please check the issue,fix and redeploy
>   Log file is located at
> /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
>
>
>
> I am honestly not sure why it would think "this system is not reliable". How
> do I check what is actually wrong?
>
> The log file shows the same error:
>
>
> tail -f
> /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134 condition
> False
> 2017-11-14 16:21:30 INFO otopi.context context.runSequence:687 Stage:
> Termination
> 2017-11-14 16:21:30 DEBUG otopi.context context.runSequence:691 STAGE
> terminate
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
> terminate METHOD otopi.plugins.gr_he_common.core.misc.Plugin._terminate
> 2017-11-14 16:21:30 ERROR otopi.plugins.gr_he_common.core.misc
> misc._terminate:178 Hosted Engine deployment failed: this system is not
> reliable, please check the issue,fix and redeploy
> 2017-11-14 16:21:30 DEBUG otopi.plugins.otopi.dialog.human
> dialog.__logString:204 DIALOG:SEND Log file is located at
> /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
> terminate METHOD otopi.plugins.otopi.dialog.human.Plugin._terminate
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
> terminate METHOD otopi.plugins.otopi.dialog.machine.Plugin._terminate
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134 condition
> False
> 2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
> terminate METHOD otopi.plugins.otopi.core.log.Plugin._terminate
>
>
> --
> Kind Regards
> Rudi Ahlers
> Website: http://www.rudiahlers.co.za
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] hosted exchange failed to install

2017-11-14 Thread Rudi Ahlers
Hi,

Can someone please help?

I installed hosted exchange but specified the wrong interface, and thus
couldn't access it. So I removed it (yum install) and reinstalled it, and
re-ran the deploy but got the following error:

 Please confirm installation settings (Yes, No)[Yes]:
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Configuring libvirt
[ INFO  ] Configuring VDSM
[WARNING] VDSM configuration file not found: creating a new configuration
file
[ INFO  ] Starting vdsmd
[ INFO  ] Creating Storage Domain
[ ERROR ] Failed to execute stage 'Misc configuration': Storage domain is
not empty - requires cleaning: (u'srv1:/engine',)
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file
'/var/lib/ovirt-hosted-engine-setup/answers/answers-20171114162130.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: this system is not reliable,
please check the issue,fix and redeploy
  Log file is located at
/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log



I am honestly not sure why it would think "this system is not reliable".
How do I check what is actually wrong?

The log file shows the same error:


tail -f
/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
condition False
2017-11-14 16:21:30 INFO otopi.context context.runSequence:687 Stage:
Termination
2017-11-14 16:21:30 DEBUG otopi.context context.runSequence:691 STAGE
terminate
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
terminate METHOD otopi.plugins.gr_he_common.core.misc.Plugin._terminate
2017-11-14 16:21:30 ERROR otopi.plugins.gr_he_common.core.misc
misc._terminate:178 Hosted Engine deployment failed: this system is not
reliable, please check the issue,fix and redeploy
2017-11-14 16:21:30 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:204 DIALOG:SEND Log file is located at
/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171114161520-km3qok.log
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
terminate METHOD otopi.plugins.otopi.dialog.human.Plugin._terminate
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
terminate METHOD otopi.plugins.otopi.dialog.machine.Plugin._terminate
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:134
condition False
2017-11-14 16:21:30 DEBUG otopi.context context._executeMethod:128 Stage
terminate METHOD otopi.plugins.otopi.core.log.Plugin._terminate


-- 
Kind Regards
Rudi Ahlers
Website: http://www.rudiahlers.co.za
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users