Re: [ovirt-users] Any Kind of Storage IO Limitation?

2018-03-05 Thread Yaniv Kaul
On Mon, Mar 5, 2018 at 1:25 PM, Thomas Fecke <thomas.fe...@eset.de> wrote:

> Hey Yaniv,
>
>
>
> thanks in advance
>
>
>
> ethtool eno2 | grep Speed
>
>
>
> always brings up 10.000. So i tought there is maybe a config File in ovirt
> that change it or something.
>
>
>
> Or will it use the OS information direct?
>

Correct. I assume you have not put any capping on the performance.


>
>
> Im not sure why the VM´s are getting slow. But when I run an Monitor tool
> to check the Bandwith it never excet 1000. Maybe he just don’t need more
> for the Copy Job
>

We'll need more details on the VM configuration. I assume you are using raw
(and not qcow2), using virtio or virtio-SCSI, enabled IO threads, etc.
What are you using the measure the performance?


>
>
> I have no explanation
>
>
>
> fact ist – when I deploy the same Template about 10-15 Times they are
> getting rly slow.
>

We'll need to understand how you deploy them.


>
>
> The RAM and CPU is morgen then 70% Free.
>
>
>
>
>
>
>
> Ill tried to Stress the Storage a bit.
>
>
>
> Opened nload and created some VM´s, created Templates, created Pools and
> and and
>
>
>
> An I was wrong:
>
>
>
> Max: 8.09 GBit/s
>

That's unlikely. What storage is providing you with 8GB/s?
That needs to be a very very very high end storage
Y.


>
>
> I can life with that. The Performance issues sees to be Gone for now.
> Maybe it was just the 4.2 Upgrade. I have no idea
>
>
>
> But everything seems to work fine. Sorry for wasting your tim e
>
>
>
>
>
>
>
>
>
> *From:* Yaniv Kaul [mailto:yk...@redhat.com]
> *Sent:* Montag, 5. März 2018 11:08
> *To:* Thomas Fecke <thomas.fe...@eset.de>
> *Cc:* users@ovirt.org
> *Subject:* Re: [ovirt-users] Any Kind of Storage IO Limitation?
>
>
>
>
>
>
>
> On Mon, Mar 5, 2018 at 8:24 AM, Thomas Fecke <thomas.fe...@eset.de> wrote:
>
> Hey Guys,
>
>
>
> I got a kind of strange Question:
>
>
>
> We got some Hypervisors connected to an x86 Storage ( NFS )
>
>
>
> The Machines are connected via 10 Gbit with that Storage. When I try to
> rsync some Files we reach almost the Maximum Bandwidth.
>
>
>
> But, when I copy some VM´s, Templates or do something Stroage related in
> Ovirt I just can reach 1000 M/bit.
>
>
>
> Is there any kind of “Config Limitation”?
>
>
>
> My biggest Problem:
>
>
>
> We work a lot with Templates. When I deploy 10 VM´s based on one Template
> the VM´s are getting very slow and the Storage seems to be the Problem
>
>
>
> Please verify all your hosts, and especially the SPM, are connected with
> 10g (and have negotiated with 10g and not 1g, etc.)
>
> Y.
>
>
>
>
>
> Thanks a lot
>
>
>
>
>
>
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Any Kind of Storage IO Limitation?

2018-03-05 Thread Thomas Fecke
Hey Yaniv,

thanks in advance

ethtool eno2 | grep Speed

always brings up 10.000. So i tought there is maybe a config File in ovirt that 
change it or something.

Or will it use the OS information direct?

Im not sure why the VM´s are getting slow. But when I run an Monitor tool to 
check the Bandwith it never excet 1000. Maybe he just don’t need more for the 
Copy Job

I have no explanation

fact ist – when I deploy the same Template about 10-15 Times they are getting 
rly slow.

The RAM and CPU is morgen then 70% Free.



Ill tried to Stress the Storage a bit.

Opened nload and created some VM´s, created Templates, created Pools and and and

An I was wrong:

Max: 8.09 GBit/s

I can life with that. The Performance issues sees to be Gone for now. Maybe it 
was just the 4.2 Upgrade. I have no idea

But everything seems to work fine. Sorry for wasting your tim e




From: Yaniv Kaul [mailto:yk...@redhat.com]
Sent: Montag, 5. März 2018 11:08
To: Thomas Fecke <thomas.fe...@eset.de>
Cc: users@ovirt.org
Subject: Re: [ovirt-users] Any Kind of Storage IO Limitation?



On Mon, Mar 5, 2018 at 8:24 AM, Thomas Fecke 
<thomas.fe...@eset.de<mailto:thomas.fe...@eset.de>> wrote:
Hey Guys,

I got a kind of strange Question:

We got some Hypervisors connected to an x86 Storage ( NFS )

The Machines are connected via 10 Gbit with that Storage. When I try to rsync 
some Files we reach almost the Maximum Bandwidth.

But, when I copy some VM´s, Templates or do something Stroage related in Ovirt 
I just can reach 1000 M/bit.

Is there any kind of “Config Limitation”?

My biggest Problem:

We work a lot with Templates. When I deploy 10 VM´s based on one Template the 
VM´s are getting very slow and the Storage seems to be the Problem

Please verify all your hosts, and especially the SPM, are connected with 10g 
(and have negotiated with 10g and not 1g, etc.)
Y.


Thanks a lot




___
Users mailing list
Users@ovirt.org<mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users