Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Nir Soffer
On Sun, Sep 18, 2016 at 2:03 PM, Roy Golan wrote: > Thanks Nir. He is using hosted engine which already uses vdscli > Right, this issue effects any program importing vdscli. Fixed in https://gerrit.ovirt.org/64100 > > On 18 September 2016 at 13:55, Nir Soffer

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Thanks Nir. He is using hosted engine which already uses vdscli On 18 September 2016 at 13:55, Nir Soffer wrote: > On Sun, Sep 18, 2016 at 10:51 AM, Roy Golan wrote: > >> Alexsey thank you. >> >> Irit, Danken please have a look at

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Nir Soffer
On Sun, Sep 18, 2016 at 10:51 AM, Roy Golan wrote: > Alexsey thank you. > > Irit, Danken please have a look at https://bugzilla.redhat.com/sh > ow_bug.cgi?id=1377069 > This is unfortunate regression in 4.0, should be fixed soon. In meantime this can be fixed by removing

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Alexsey thank you. Irit, Danken please have a look at https://bugzilla.redhat.com/ show_bug.cgi?id=1377069 On 18 September 2016 at 10:49, wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=1377069 > > 18.09.2016, 10:09, "Roy Golan" : > > On 18

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread aleksey . maksimov
https://bugzilla.redhat.com/show_bug.cgi?id=1377069 18.09.2016, 10:09, "Roy Golan" : > On 18 September 2016 at 09:48, wrote: >> Thanks Roy >> >> But if I'm going to redirect the output of the hosted-engine command to >> /dev/null, I can not identify

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
On 18 September 2016 at 10:09, Roy Golan wrote: > > > On 18 September 2016 at 09:48, wrote: > >> Thanks Roy >> >> >> But if I'm going to redirect the output of the hosted-engine command to >> /dev/null, I can not identify the possible problem of the

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
On 18 September 2016 at 09:48, wrote: > Thanks Roy > > > But if I'm going to redirect the output of the hosted-engine command to > /dev/null, I can not identify the possible problem of the command :( > That's only stderror. You should still see the standard input and

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread aleksey . maksimov
Thanks Roy But if I'm going to redirect the output of the hosted-engine command to /dev/null, I can not identify the possible problem of the command :( It may be possible exclude DeprecationWarning from the code in next version 4.0.4 :) ? 18.09.2016, 09:27, "Roy Golan" : >

Re: [ovirt-users] DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli

2016-09-18 Thread Roy Golan
Try to point stderr to /dev/null. For example this should work: ```bash vdsClient -s 0 list table 2> /dev/null ``` On 18 September 2016 at 08:59, wrote: > Hello oVirt guru`s ! > > Every time I call the commands: > > * hosted-engine --set-maintenance --mode=global > *