Re: [ovirt-users] Possibility to regenerate answer file on primary node

2015-01-08 Thread Christopher Young
Would anyone be able to provide me any insight here?  I can include any
logs if needed as I'm at a loss trying to get this 2nd hosted engine up and
running.

On Tue, Jan 6, 2015 at 7:37 PM, Christopher Young mexigaba...@gmail.com
wrote:

 For added information (a portion from the ovirt-hosted-setup log):

 --
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.core.titles.Plugin._vm_start
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144
 condition False
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vm.configurevm.Plugin._customization
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
 ENVIRONMENT DUMP - BEGIN
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 OVEHOSTED_VM/vmBoot=str:'disk'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
 ENVIRONMENT DUMP - END
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk.Plugin._customization
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144
 condition False
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu.Plugin._customization
 2015-01-06 19:18:23 DEBUG
 otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu
 cpu._getCompatibleCpuModels:68 Attempting to load the caps vdsm module
 2015-01-06 19:18:23 DEBUG
 otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu cpu._customization:137
 Compatible CPU models are: [u'model_Nehalem', u'model_Conroe',
 u'model_coreduo', u'model_core2duo', u'model_Penryn', u'model_Westmere',
 u'model_n270']
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND The following CPU types
 are supported by this host:
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND- model_Westmere:
 Intel Westmere Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND- model_Nehalem:
 Intel Nehalem Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND- model_Penryn: Intel
 Penryn Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND- model_Conroe: Intel
 Conroe Family
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:152 method
 exception
 Traceback (most recent call last):
   File /usr/lib/python2.7/site-packages/otopi/context.py, line 142, in
 _executeMethod
 method['method']()
   File
 /usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vdsmd/cpu.py,
 line 194, in _customization
 ohostedcons.VDSMEnv.VDSM_CPU
 RuntimeError: Invalid CPU type specified: None
 2015-01-06 19:18:23 ERROR otopi.context context._executeMethod:161 Failed
 to execute stage 'Environment customization': Invalid CPU type specified:
 None
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
 ENVIRONMENT DUMP - BEGIN
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 BASE/error=bool:'True'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 BASE/exceptionInfo=list:'[(type 'exceptions.RuntimeError',
 RuntimeError('Invalid CPU type specified: None',), traceback object at
 0x39782d8)]'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
 ENVIRONMENT DUMP - END
 2015-01-06 19:18:23 INFO otopi.context context.runSequence:417 Stage:
 Clean up
 2015-01-06 19:18:23 DEBUG otopi.context context.runSequence:421 STAGE
 cleanup
 --

 On Tue, Jan 6, 2015 at 7:26 PM, Christopher Young mexigaba...@gmail.com
 wrote:

 I believe that I'm stuck with trying to follow the deployment via the
 popular guide at:

 http://community.redhat.com/blog/2014/11/up-and-running-with-ovirt-3-5-part-two/

 I'm trying to get my second hosted-engine deployed and seem to keep
 running into errors with '--deploy' on the second node.

 ---
   --== NETWORK CONFIGURATION ==--

   Please indicate a pingable gateway IP address [x.x.x.x]:
   The following CPU types are supported by this host:
  - model_Westmere: Intel Westmere Family
  - model_Nehalem: Intel Nehalem Family
  - model_Penryn: Intel Penryn Family
  - model_Conroe: Intel Conroe Family
 [ ERROR ] Failed to execute stage 'Environment customization': Invalid
 CPU type specified: None

 ---
 It seems like the answer file that is copied from the first node is
 either not being copied or is incorrect.  In any case, I was wondering if
 there was a way to verify this as well as 

Re: [ovirt-users] Possibility to regenerate answer file on primary node

2015-01-08 Thread Simone Tiraboschi


- Original Message -
 From: Christopher Young mexigaba...@gmail.com
 To: users@ovirt.org
 Sent: Thursday, January 8, 2015 5:36:44 PM
 Subject: Re: [ovirt-users] Possibility to regenerate answer file on primary   
 node
 
 Would anyone be able to provide me any insight here? I can include any logs
 if needed as I'm at a loss trying to get this 2nd hosted engine up and
 running.
 
 On Tue, Jan 6, 2015 at 7:37 PM, Christopher Young  mexigaba...@gmail.com 
 wrote:
 
 
 
 For added information (a portion from the ovirt-hosted-setup log):
 
 --
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.core.titles.Plugin._vm_start
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144 condition
 False
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vm.configurevm.Plugin._customization
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
 ENVIRONMENT DUMP - BEGIN
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 OVEHOSTED_VM/vmBoot=str:'disk'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
 ENVIRONMENT DUMP - END
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk.Plugin._customization
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144 condition
 False
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
 customization METHOD
 otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu.Plugin._customization
 2015-01-06 19:18:23 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu
 cpu._getCompatibleCpuModels:68 Attempting to load the caps vdsm module
 2015-01-06 19:18:23 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu
 cpu._customization:137 Compatible CPU models are: [u'model_Nehalem',
 u'model_Conroe', u'model_coreduo', u'model_core2duo', u'model_Penryn',
 u'model_Westmere', u'model_n270']
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND The following CPU types are supported by
 this host:
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND - model_Westmere: Intel Westmere Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND - model_Nehalem: Intel Nehalem Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND - model_Penryn: Intel Penryn Family
 2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
 dialog.__logString:215 DIALOG:SEND - model_Conroe: Intel Conroe Family
 2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:152 method
 exception
 Traceback (most recent call last):
 File /usr/lib/python2.7/site-packages/otopi/context.py, line 142, in
 _executeMethod
 method['method']()
 File
 /usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vdsmd/cpu.py,
 line 194, in _customization
 ohostedcons.VDSMEnv.VDSM_CPU
 RuntimeError: Invalid CPU type specified: None
 2015-01-06 19:18:23 ERROR otopi.context context._executeMethod:161 Failed to
 execute stage 'Environment customization': Invalid CPU type specified: None
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
 ENVIRONMENT DUMP - BEGIN
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 BASE/error=bool:'True'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
 BASE/exceptionInfo=list:'[(type 'exceptions.RuntimeError',
 RuntimeError('Invalid CPU type specified: None',), traceback object at
 0x39782d8)]'
 2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
 ENVIRONMENT DUMP - END
 2015-01-06 19:18:23 INFO otopi.context context.runSequence:417 Stage: Clean
 up
 2015-01-06 19:18:23 DEBUG otopi.context context.runSequence:421 STAGE cleanup
 --
 
 On Tue, Jan 6, 2015 at 7:26 PM, Christopher Young  mexigaba...@gmail.com 
 wrote:
 
 
 
 I believe that I'm stuck with trying to follow the deployment via the popular
 guide at:
 http://community.redhat.com/blog/2014/11/up-and-running-with-ovirt-3-5-part-two/
 
 I'm trying to get my second hosted-engine deployed and seem to keep running
 into errors with '--deploy' on the second node.
 
 ---
 --== NETWORK CONFIGURATION ==--
 
 Please indicate a pingable gateway IP address [x.x.x.x]:
 The following CPU types are supported by this host:
 - model_Westmere: Intel Westmere Family
 - model_Nehalem: Intel Nehalem Family
 - model_Penryn: Intel Penryn Family
 - model_Conroe: Intel Conroe Family
 [ ERROR ] Failed to execute stage 'Environment customization': Invalid CPU
 type specified: None
 
 ---
 It seems like the answer file that is copied from the first node is either
 not being copied or is incorrect. In any case, I was wondering

Re: [ovirt-users] Possibility to regenerate answer file on primary node

2015-01-06 Thread Christopher Young
For added information (a portion from the ovirt-hosted-setup log):

--
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
customization METHOD
otopi.plugins.ovirt_hosted_engine_setup.core.titles.Plugin._vm_start
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144
condition False
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
customization METHOD
otopi.plugins.ovirt_hosted_engine_setup.vm.configurevm.Plugin._customization
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
ENVIRONMENT DUMP - BEGIN
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
OVEHOSTED_VM/vmBoot=str:'disk'
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
ENVIRONMENT DUMP - END
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
customization METHOD
otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk.Plugin._customization
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:144
condition False
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:138 Stage
customization METHOD
otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu.Plugin._customization
2015-01-06 19:18:23 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu
cpu._getCompatibleCpuModels:68 Attempting to load the caps vdsm module
2015-01-06 19:18:23 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vdsmd.cpu
cpu._customization:137 Compatible CPU models are: [u'model_Nehalem',
u'model_Conroe', u'model_coreduo', u'model_core2duo', u'model_Penryn',
u'model_Westmere', u'model_n270']
2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:215 DIALOG:SEND The following CPU types
are supported by this host:
2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:215 DIALOG:SEND- model_Westmere:
Intel Westmere Family
2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:215 DIALOG:SEND- model_Nehalem:
Intel Nehalem Family
2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:215 DIALOG:SEND- model_Penryn: Intel
Penryn Family
2015-01-06 19:18:23 DEBUG otopi.plugins.otopi.dialog.human
dialog.__logString:215 DIALOG:SEND- model_Conroe: Intel
Conroe Family
2015-01-06 19:18:23 DEBUG otopi.context context._executeMethod:152 method
exception
Traceback (most recent call last):
  File /usr/lib/python2.7/site-packages/otopi/context.py, line 142, in
_executeMethod
method['method']()
  File
/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vdsmd/cpu.py,
line 194, in _customization
ohostedcons.VDSMEnv.VDSM_CPU
RuntimeError: Invalid CPU type specified: None
2015-01-06 19:18:23 ERROR otopi.context context._executeMethod:161 Failed
to execute stage 'Environment customization': Invalid CPU type specified:
None
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:490
ENVIRONMENT DUMP - BEGIN
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
BASE/error=bool:'True'
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:500 ENV
BASE/exceptionInfo=list:'[(type 'exceptions.RuntimeError',
RuntimeError('Invalid CPU type specified: None',), traceback object at
0x39782d8)]'
2015-01-06 19:18:23 DEBUG otopi.context context.dumpEnvironment:504
ENVIRONMENT DUMP - END
2015-01-06 19:18:23 INFO otopi.context context.runSequence:417 Stage: Clean
up
2015-01-06 19:18:23 DEBUG otopi.context context.runSequence:421 STAGE
cleanup
--

On Tue, Jan 6, 2015 at 7:26 PM, Christopher Young mexigaba...@gmail.com
wrote:

 I believe that I'm stuck with trying to follow the deployment via the
 popular guide at:

 http://community.redhat.com/blog/2014/11/up-and-running-with-ovirt-3-5-part-two/

 I'm trying to get my second hosted-engine deployed and seem to keep
 running into errors with '--deploy' on the second node.

 ---
   --== NETWORK CONFIGURATION ==--

   Please indicate a pingable gateway IP address [x.x.x.x]:
   The following CPU types are supported by this host:
  - model_Westmere: Intel Westmere Family
  - model_Nehalem: Intel Nehalem Family
  - model_Penryn: Intel Penryn Family
  - model_Conroe: Intel Conroe Family
 [ ERROR ] Failed to execute stage 'Environment customization': Invalid CPU
 type specified: None

 ---
 It seems like the answer file that is copied from the first node is either
 not being copied or is incorrect.  In any case, I was wondering if there
 was a way to verify this as well as if there is a method for regenerating
 the answer file on the first node should it be missing (which I think that
 it might be).

 I apologize if this is pretty obvious stuff at this point as I feel like
 I'm missing something.  Any help would be greatly appreciated.

 Thanks,

 Chris