Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
I just tested adding a Centos 6.6 and Centos 7 host on a oVirt Cluster and
it is not possible:

Not possible to mix RHEL 6.x and 7.x hosts in one cluster. Tried adding
RHEL - 6 - 7.el6.centos.12.3 host to a cluster with RHEL - 7 -
1.1503.el7.centos.2.8 hosts.

Using the same data storage for multiple Clusters seems possible.

Thanks for all the help today,

Regards,
Paul

Op do 12 nov. 2015 om 10:52 schreef Paul Groeneweg | Pazion :

> Hmm, that would be a pity, then I also need a second shared storage.
>
> Anyone tested mixed el6 and el7 cluster on 3.5.5 or 3.6 ?
>
> Met vriendelijke groeten,
> Paul Groeneweg
>
>
> Op do 12 nov. 2015 om 10:48 schreef Gianluca Cecchi <
> gianluca.cec...@gmail.com>:
>
>> On Thu, Nov 12, 2015 at 10:44 AM, Gianluca Cecchi <
>> gianluca.cec...@gmail.com> wrote:
>>
>>> On Thu, Nov 12, 2015 at 10:40 AM, Paul Groeneweg | Pazion <
>>> p...@pazion.nl> wrote:
>>>
 OK, I understand, I would need to upgrade my Hosts to go to 3.6.

 I think I read somewhere I can't mix EL6 and EL7 hosts in the same
 cluster, is this true?


>>> You can have a mix of EL6 and EL7 hosts with 3.5 cluster compatibility
>>> in place.
>>> But you have to notice that you can do live migrations in direction EL6
>>> --> EL7 but not the reverse.
>>> SO you have to care about this for your migration strategy.
>>> Probably bettere to update at least two hosts to EL7 before beginning to
>>> place critical VMs on them.
>>> HIH,
>>> Gianluca
>>>
>>
>> Opsss, perhaps I'm wro and you have to create a different cluster in the
>> same datacenter and progressively migrate VMs from hosts in first cluster
>> to hosts in second cluster.
>> At least so it was in 3.5.1 did it change?
>>
>> See
>> http://lists.ovirt.org/pipermail/users/2015-May/032818.html
>> and bugzilla
>> https://bugzilla.redhat.com/show_bug.cgi?id=1150191
>>
> --
> Met vriendelijke groeten,
>
> Paul Groeneweg
> Pazion
> Webdevelopment  -  Hosting  -  Apps
>
> T +31 26 3020038
> M +31 614 277 577
> E  p...@pazion.nl
>
>  ***disclaimer***
> "This e-mail and any attachments thereto may contain information which is
> confidential and/or protected by intellectual property rights and are
> intended for the sole use of the recipient(s) named above. Any use of the
> information contained herein (including, but not limited to, total or
> partial reproduction, communication or distribution in any form) by persons
> other than the designated recipient(s) is prohibited. If you have received
> this e-mail in error, please notify the sender either by telephone or by
> e-mail and delete the material from any computer. Thank you for your
> cooperation."
>
-- 
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Gianluca Cecchi
On Thu, Nov 12, 2015 at 10:44 AM, Gianluca Cecchi  wrote:

> On Thu, Nov 12, 2015 at 10:40 AM, Paul Groeneweg | Pazion 
> wrote:
>
>> OK, I understand, I would need to upgrade my Hosts to go to 3.6.
>>
>> I think I read somewhere I can't mix EL6 and EL7 hosts in the same
>> cluster, is this true?
>>
>>
> You can have a mix of EL6 and EL7 hosts with 3.5 cluster compatibility in
> place.
> But you have to notice that you can do live migrations in direction EL6
> --> EL7 but not the reverse.
> SO you have to care about this for your migration strategy.
> Probably bettere to update at least two hosts to EL7 before beginning to
> place critical VMs on them.
> HIH,
> Gianluca
>

Opsss, perhaps I'm wro and you have to create a different cluster in the
same datacenter and progressively migrate VMs from hosts in first cluster
to hosts in second cluster.
At least so it was in 3.5.1 did it change?

See
http://lists.ovirt.org/pipermail/users/2015-May/032818.html
and bugzilla
https://bugzilla.redhat.com/show_bug.cgi?id=1150191
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
We have only a few hosts.
I will keep your advice in mind when reviewing migration plan.

Thanks for the quick answer!

Met vriendelijke groeten,
Paul Groeneweg


Op do 12 nov. 2015 om 10:44 schreef Gianluca Cecchi <
gianluca.cec...@gmail.com>:

> On Thu, Nov 12, 2015 at 10:40 AM, Paul Groeneweg | Pazion 
> wrote:
>
>> OK, I understand, I would need to upgrade my Hosts to go to 3.6.
>>
>> I think I read somewhere I can't mix EL6 and EL7 hosts in the same
>> cluster, is this true?
>>
>>
> You can have a mix of EL6 and EL7 hosts with 3.5 cluster compatibility in
> place.
> But you have to notice that you can do live migrations in direction EL6
> --> EL7 but not the reverse.
> SO you have to care about this for your migration strategy.
> Probably bettere to update at least two hosts to EL7 before beginning to
> place critical VMs on them.
> HIH,
> Gianluca
>
-- 
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Simone Tiraboschi
On Thu, Nov 12, 2015 at 9:03 AM, Paul Groeneweg | Pazion 
wrote:

> I have finished the upgrade to 3.6.
> I received a lot (every 3 seconds ) of the following messages in the
> logs after upgrading the hosts:
>
>  vdsm jsonrpc.JsonRpcServer ERROR Internal server error#012Traceback (most
> recent call last):#012  File
> "/usr/lib/python2.6/site-packages/yajsonrpc/__init__.py", line 501, in
> _serveRequest#012res = method(**params)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 291, in _dynamicMethod#012return
> self._fixupRet(className, methodName, ret)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 235, in _fixupRet#012
>  self._typeFixup('return', retType, result)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 215, in _typeFixup#012if k in
> item:#012TypeError: argument of type 'NoneType' is not iterable
>
> I restarted ovirt-ha-agent ovirt-ha-broker and vdsmd.
> After I rebooted all hosts ( migrating VMS from one to another ) the
> message finally disappeared.
>
> Then I tried to set compatibility Version to 3.6, but without luck. I have
> put hosted engine back in global maintenance, but I can't find out why it
> fails. The message says "Error while executing action: Cannot change
> Cluster Compatibility Version to higher version when there are active Hosts
> with lower version.
> -Please move Hosts with lower version to maintenance first."
>
> I have installed ovirt-release36 on hosted engine and hosts.
> I have updated hosted engine with engine-setup.
> I ran yum update on all hosts.
> What do I need to do to set compatibility version to 3.6?
>

Please check the software tab in the host panel for each of your host, if
the upgrade has been performed you should see something like 'VDSM
Version: vdsm-4.17.10.1-0.el7.centos', if vdsm is still at 4.16.z that host
is still on 3.5.


> And how can I enable repository for hosted engine? ( through WEB UI change
> is not saved ).
>
>
>
> Best Regards,
> Paul Groeneweg
>
> --
> Met vriendelijke groeten,
>
> Paul Groeneweg
> Pazion
> Webdevelopment  -  Hosting  -  Apps
>
> T +31 26 3020038
> M +31 614 277 577
> E  p...@pazion.nl
>
>  ***disclaimer***
> "This e-mail and any attachments thereto may contain information which is
> confidential and/or protected by intellectual property rights and are
> intended for the sole use of the recipient(s) named above. Any use of the
> information contained herein (including, but not limited to, total or
> partial reproduction, communication or distribution in any form) by persons
> other than the designated recipient(s) is prohibited. If you have received
> this e-mail in error, please notify the sender either by telephone or by
> e-mail and delete the material from any computer. Thank you for your
> cooperation."
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Gianluca Cecchi
On Thu, Nov 12, 2015 at 10:52 AM, Paul Groeneweg | Pazion 
wrote:

> Hmm, that would be a pity, then I also need a second shared storage.
>
> Anyone tested mixed el6 and el7 cluster on 3.5.5 or 3.6 ?
>
>
>
Actually you attach a storage domain to a Data Center object, not to a
Cluster object.
I hope that two different clusters inside the same datacenter can consume
the same storage domains concurrently, isn't it?

Gianluca
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
That looks like the issue...

I am running Centos 6 and I read
https://bugzilla.redhat.com/show_bug.cgi?id=1206231
Is it possible to build the packages form source or is my only option
upgrading to Centos7?

Can I have a mix of Centos 6 and 7 in my DC/Cluster? ( otherwise I need to
upgrade/migrate all VMS? )

Met vriendelijke groeten,
Paul Groeneweg


Op do 12 nov. 2015 om 09:38 schreef Simone Tiraboschi :

> On Thu, Nov 12, 2015 at 9:03 AM, Paul Groeneweg | Pazion 
> wrote:
>
>> I have finished the upgrade to 3.6.
>> I received a lot (every 3 seconds ) of the following messages in the
>> logs after upgrading the hosts:
>>
>>  vdsm jsonrpc.JsonRpcServer ERROR Internal server error#012Traceback
>> (most recent call last):#012  File
>> "/usr/lib/python2.6/site-packages/yajsonrpc/__init__.py", line 501, in
>> _serveRequest#012res = method(**params)#012  File
>> "/usr/share/vdsm/rpc/Bridge.py", line 291, in _dynamicMethod#012return
>> self._fixupRet(className, methodName, ret)#012  File
>> "/usr/share/vdsm/rpc/Bridge.py", line 235, in _fixupRet#012
>>  self._typeFixup('return', retType, result)#012  File
>> "/usr/share/vdsm/rpc/Bridge.py", line 215, in _typeFixup#012if k in
>> item:#012TypeError: argument of type 'NoneType' is not iterable
>>
>> I restarted ovirt-ha-agent ovirt-ha-broker and vdsmd.
>> After I rebooted all hosts ( migrating VMS from one to another ) the
>> message finally disappeared.
>>
>> Then I tried to set compatibility Version to 3.6, but without luck. I
>> have put hosted engine back in global maintenance, but I can't find out why
>> it fails. The message says "Error while executing action: Cannot change
>> Cluster Compatibility Version to higher version when there are active Hosts
>> with lower version.
>> -Please move Hosts with lower version to maintenance first."
>>
>> I have installed ovirt-release36 on hosted engine and hosts.
>> I have updated hosted engine with engine-setup.
>> I ran yum update on all hosts.
>> What do I need to do to set compatibility version to 3.6?
>>
>
> Please check the software tab in the host panel for each of your host, if
> the upgrade has been performed you should see something like 'VDSM
> Version: vdsm-4.17.10.1-0.el7.centos', if vdsm is still at 4.16.z that host
> is still on 3.5.
>
>
>> And how can I enable repository for hosted engine? ( through WEB UI
>> change is not saved ).
>>
>>
>>
>> Best Regards,
>> Paul Groeneweg
>>
>> --
>> Met vriendelijke groeten,
>>
>> Paul Groeneweg
>> Pazion
>> Webdevelopment  -  Hosting  -  Apps
>>
>> T +31 26 3020038
>> M +31 614 277 577
>> E  p...@pazion.nl
>>
>>  ***disclaimer***
>> "This e-mail and any attachments thereto may contain information which is
>> confidential and/or protected by intellectual property rights and are
>> intended for the sole use of the recipient(s) named above. Any use of the
>> information contained herein (including, but not limited to, total or
>> partial reproduction, communication or distribution in any form) by persons
>> other than the designated recipient(s) is prohibited. If you have received
>> this e-mail in error, please notify the sender either by telephone or by
>> e-mail and delete the material from any computer. Thank you for your
>> cooperation."
>>
>> ___
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>>
> --
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
Hmm, that would be a pity, then I also need a second shared storage.

Anyone tested mixed el6 and el7 cluster on 3.5.5 or 3.6 ?

Met vriendelijke groeten,
Paul Groeneweg


Op do 12 nov. 2015 om 10:48 schreef Gianluca Cecchi <
gianluca.cec...@gmail.com>:

> On Thu, Nov 12, 2015 at 10:44 AM, Gianluca Cecchi <
> gianluca.cec...@gmail.com> wrote:
>
>> On Thu, Nov 12, 2015 at 10:40 AM, Paul Groeneweg | Pazion > > wrote:
>>
>>> OK, I understand, I would need to upgrade my Hosts to go to 3.6.
>>>
>>> I think I read somewhere I can't mix EL6 and EL7 hosts in the same
>>> cluster, is this true?
>>>
>>>
>> You can have a mix of EL6 and EL7 hosts with 3.5 cluster compatibility in
>> place.
>> But you have to notice that you can do live migrations in direction EL6
>> --> EL7 but not the reverse.
>> SO you have to care about this for your migration strategy.
>> Probably bettere to update at least two hosts to EL7 before beginning to
>> place critical VMs on them.
>> HIH,
>> Gianluca
>>
>
> Opsss, perhaps I'm wro and you have to create a different cluster in the
> same datacenter and progressively migrate VMs from hosts in first cluster
> to hosts in second cluster.
> At least so it was in 3.5.1 did it change?
>
> See
> http://lists.ovirt.org/pipermail/users/2015-May/032818.html
> and bugzilla
> https://bugzilla.redhat.com/show_bug.cgi?id=1150191
>
-- 
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Gianluca Cecchi
On Thu, Nov 12, 2015 at 10:40 AM, Paul Groeneweg | Pazion 
wrote:

> OK, I understand, I would need to upgrade my Hosts to go to 3.6.
>
> I think I read somewhere I can't mix EL6 and EL7 hosts in the same
> cluster, is this true?
>
>
You can have a mix of EL6 and EL7 hosts with 3.5 cluster compatibility in
place.
But you have to notice that you can do live migrations in direction EL6 -->
EL7 but not the reverse.
SO you have to care about this for your migration strategy.
Probably bettere to update at least two hosts to EL7 before beginning to
place critical VMs on them.
HIH,
Gianluca
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
You are right, I confused Cluster with DC entity.
I created another Cluster within the same DC and it has access to the same
storage domain.

Then I 'only' have to upgrade/reinstall my OS. :-)



Op do 12 nov. 2015 om 11:04 schreef Gianluca Cecchi <
gianluca.cec...@gmail.com>:

> On Thu, Nov 12, 2015 at 10:52 AM, Paul Groeneweg | Pazion 
> wrote:
>
>> Hmm, that would be a pity, then I also need a second shared storage.
>>
>> Anyone tested mixed el6 and el7 cluster on 3.5.5 or 3.6 ?
>>
>>
>>
> Actually you attach a storage domain to a Data Center object, not to a
> Cluster object.
> I hope that two different clusters inside the same datacenter can consume
> the same storage domains concurrently, isn't it?
>
> Gianluca
>
-- 
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Paul Groeneweg | Pazion
Hi Dan,

I followed the described procedure:

1. put hosted engine in global maintenance
2. yum updated engine-setup
3. ran engine-setup and did updgrade
4. Next day ( all running fine ) I started update of the hosts with yum
update.
5. I did not put host to maintenance.
6. As soon as yum updated/finished the errors started
7. I tried to restart services, ovirt-ha-agent, ovirt-ha-broker, vdsm no
luck.
8. I put a host to maintenance and restarted machine ( did this for all
hosts )
9. On the last host the hosted engine refused to migrate, the error was
something, HA filter no available host. ( I noticed the score was 0 with
hosted-engine )
10. I put hosted engine to global maintenance and powered off the hosted
engine and rebooted the final host.
11. I put hosted engine back online and it restarted.
12. Error was gone.

I did had old meta data ID entries in my hosted-engine listing, these are
now also cleaned, maybe it had to do something with these?

I send the log file of one of the hosts to your email.

Let me know if you want more info.

( issue with compatibility version is clear, I need to upgrade EL6 to EL7 )

Met vriendelijke groeten,
Paul Groeneweg

>
>
>
> --
Met vriendelijke groeten,

Paul Groeneweg
Pazion
Webdevelopment  -  Hosting  -  Apps

T +31 26 3020038
M +31 614 277 577
E  p...@pazion.nl

 ***disclaimer***
"This e-mail and any attachments thereto may contain information which is
confidential and/or protected by intellectual property rights and are
intended for the sole use of the recipient(s) named above. Any use of the
information contained herein (including, but not limited to, total or
partial reproduction, communication or distribution in any form) by persons
other than the designated recipient(s) is prohibited. If you have received
this e-mail in error, please notify the sender either by telephone or by
e-mail and delete the material from any computer. Thank you for your
cooperation."
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Dan Kenigsberg
On Thu, Nov 12, 2015 at 08:03:05AM +, Paul Groeneweg | Pazion wrote:
> I have finished the upgrade to 3.6.

Can you describe how you've performed the upgrade? Did you upgrade
Engine first and then all the hosts (it is highly recommended to upgrade
host one at a time, and move each to maintenance mode before doing so)?
When did the troubling log appeared?

> I received a lot (every 3 seconds ) of the following messages in the
> logs after upgrading the hosts:
>
>  vdsm jsonrpc.JsonRpcServer ERROR Internal server error#012Traceback (most
> recent call last):#012  File
> "/usr/lib/python2.6/site-packages/yajsonrpc/__init__.py", line 501, in
> _serveRequest#012res = method(**params)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 291, in _dynamicMethod#012return
> self._fixupRet(className, methodName, ret)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 235, in _fixupRet#012
>  self._typeFixup('return', retType, result)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 215, in _typeFixup#012if k in
> item:#012TypeError: argument of type 'NoneType' is not iterable
>
> I restarted ovirt-ha-agent ovirt-ha-broker and vdsmd.
> After I rebooted all hosts ( migrating VMS from one to another ) the
> message finally disappeared.

Can you share your vdsm.log of that time? I wish to understand what
method has failed.

>
> Then I tried to set compatibility Version to 3.6, but without luck. I have
> put hosted engine back in global maintenance, but I can't find out why it
> fails. The message says "Error while executing action: Cannot change
> Cluster Compatibility Version to higher version when there are active Hosts
> with lower version.
> -Please move Hosts with lower version to maintenance first."

Can you iterate over your hosts to find which is the culprit?
Then you can move it to maintenance.

> 
> I have installed ovirt-release36 on hosted engine and hosts.
> I have updated hosted engine with engine-setup.
> I ran yum update on all hosts.
> What do I need to do to set compatibility version to 3.6?
> 
> And how can I enable repository for hosted engine? ( through WEB UI change
> is not saved ).


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] upgrade to oVirt 3.6 and compabitibility 3.6

2015-11-12 Thread Simone Tiraboschi
On Thu, Nov 12, 2015 at 12:43 PM, Dan Kenigsberg  wrote:

> On Thu, Nov 12, 2015 at 08:03:05AM +, Paul Groeneweg | Pazion wrote:
> > I have finished the upgrade to 3.6.
>
> Can you describe how you've performed the upgrade? Did you upgrade
> Engine first and then all the hosts (it is highly recommended to upgrade
> host one at a time, and move each to maintenance mode before doing so)?
> When did the troubling log appeared?
>
> > I received a lot (every 3 seconds ) of the following messages in the
> > logs after upgrading the hosts:
> >
> >  vdsm jsonrpc.JsonRpcServer ERROR Internal server error#012Traceback
> (most
> > recent call last):#012  File
> > "/usr/lib/python2.6/site-packages/yajsonrpc/__init__.py", line 501, in
> > _serveRequest#012res = method(**params)#012  File
> > "/usr/share/vdsm/rpc/Bridge.py", line 291, in _dynamicMethod#012
> return
> > self._fixupRet(className, methodName, ret)#012  File
> > "/usr/share/vdsm/rpc/Bridge.py", line 235, in _fixupRet#012
> >  self._typeFixup('return', retType, result)#012  File
> > "/usr/share/vdsm/rpc/Bridge.py", line 215, in _typeFixup#012if k in
> > item:#012TypeError: argument of type 'NoneType' is not iterable
> >
> > I restarted ovirt-ha-agent ovirt-ha-broker and vdsmd.
> > After I rebooted all hosts ( migrating VMS from one to another ) the
> > message finally disappeared.
>
> Can you share your vdsm.log of that time? I wish to understand what
> method has failed.
>
> >
> > Then I tried to set compatibility Version to 3.6, but without luck. I
> have
> > put hosted engine back in global maintenance, but I can't find out why it
> > fails. The message says "Error while executing action: Cannot change
> > Cluster Compatibility Version to higher version when there are active
> Hosts
> > with lower version.
> > -Please move Hosts with lower version to maintenance first."
>
> Can you iterate over your hosts to find which is the culprit?
> Then you can move it to maintenance.
>

As far as I understood all the hosts were el6 and so no one got really
upgraded.


>
> >
> > I have installed ovirt-release36 on hosted engine and hosts.
> > I have updated hosted engine with engine-setup.
> > I ran yum update on all hosts.
> > What do I need to do to set compatibility version to 3.6?
> >
> > And how can I enable repository for hosted engine? ( through WEB UI
> change
> > is not saved ).
>
>
> ___
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users