Re: Tomcat doesn't refreshes and still gives me an old error again and again

2019-09-10 Thread Greg Huber
Eclipse works the way it works, but what you can use is https://marketplace.eclipse.org/content/eclipse-tomcat-plugin which is basically an update of the mighty http://www.eclipsetotale.com/tomcatPlugin.html I use a blank dynamic web project, with a standard plugin setup, ie default output folder

Re: SSLHostConfig configuration

2019-09-10 Thread Mark Thomas
On 09/09/2019 23:28, Herb Burnswell wrote: > Questions: > > 1. What has changed in between Tomcat 8.5.32 --> 8.5.40 that seemingly now > requires truststore information in this connector configuration? There have have been several changes aimed at making it easier to switch between JSSE and

Re: Tomcat 9.0.16 Packaging Change (Extras)

2019-09-10 Thread Mark Thomas
On 10/09/2019 09:41, Stephen Hames wrote: > Hi All, > > After Tomcat 9.0.14, the packaging available for download seems to have > changed in that the bin/extras directory has been removed. > > I am finding a bit of confusion on this. We use catalina-jmx-remote.jar > and previously this was

Re: POST request fails if content is ignored?

2019-09-10 Thread Mark Thomas
On 09/09/2019 16:41, Leon Atherton wrote: > Our use case is rejecting the request based on IP. > > In the browser the status code is 0, and the network tab in developer > tools is showing no response to the request. It's the same in Chrome and > Firefox. > > The request works fine when I send

Re: SSO fails on Tomcat 9

2019-09-10 Thread Mark Thomas
On 06/09/2019 13:20, Heidi Leerink - Duverger wrote: > Hello Mark, > > That helps somewhat, my browser now shows the login page for our application, > BUT I do not get my username in HTTP variable REMOTE_USER but the principal > keytab related name. > > So instead of hduverge I get

Re: SSLHostConfig configuration

2019-09-10 Thread Mark Thomas
On 10/09/2019 13:14, Herb Burnswell wrote: > My apologies for my ignorance here, when you say 'configured on the > SSLHostConfig' are you saying it should NOT be in this block: > > > > > > certificateKeystoreFile="/app/config/keystore.p12" >

Re: POST request fails if content is ignored?

2019-09-10 Thread Leon Atherton
Very grateful for your reply, this does indeed solve my issue (and I learned something new too). Thanks, Leon On 10/09/2019 12:03, Mark Thomas wrote: > On 09/09/2019 16:41, Leon Atherton wrote: >> Our use case is rejecting the request based on IP. >> >> In the browser the status code is 0, and

Re: SSLHostConfig configuration

2019-09-10 Thread Herb Burnswell
On Tue, Sep 10, 2019 at 3:46 AM Mark Thomas wrote > > > > >> Questions: > >> > >> 1. What has changed in between Tomcat 8.5.32 --> 8.5.40 that seemingly > now > >> requires truststore information in this connector configuration? > > > There have have been several changes aimed at making it

Re: SSO fails on Tomcat 9

2019-09-10 Thread Mark Thomas
On 10/09/2019 16:47, André Warnier (tomcat) wrote: > On 10.09.2019 15:38, Mark Thomas wrote: >> On 06/09/2019 13:20, Heidi Leerink - Duverger wrote: >>> Hello Mark, >>> >>> That helps somewhat, my browser now shows the login page for our >>> application, BUT I do not get my username in HTTP

Re: SSO fails on Tomcat 9

2019-09-10 Thread tomcat
On 10.09.2019 15:38, Mark Thomas wrote: On 06/09/2019 13:20, Heidi Leerink - Duverger wrote: Hello Mark, That helps somewhat, my browser now shows the login page for our application, BUT I do not get my username in HTTP variable REMOTE_USER but the principal keytab related name. So instead

RE: APR libs present but not found

2019-09-10 Thread John Beaulaurier -X (jbeaulau - ADVANCED NETWORK INFORMATION INC at Cisco)
Hi Christopher, I needed to build the APR libs from source as there was no rpm in yum, but the default directory where the libs were place was not in the Java path, and so once I noticed that and added that directory to the path in setenv.sh APR is found and used. Thanks -John

Re: SSLHostConfig configuration

2019-09-10 Thread Herb Burnswell
On Tue, Sep 10, 2019 at 5:38 AM Mark Thomas wrote: > On 10/09/2019 13:14, Herb Burnswell wrote: > > > > > My apologies for my ignorance here, when you say 'configured on the > > SSLHostConfig' are you saying it should NOT be in this block: > > > > > > > > > > > > > >

Re: Windows registry entry missing on Tomcat Silent install - 9.0.20

2019-09-10 Thread Mark Thomas
On 09/09/2019 15:33, Mark Thomas wrote: > On 06/09/2019 07:26, Pradeep Kumar M N wrote: >> Hi All, >> >> I am using Tomcat 9.0.20. I am installing the Tomcat silently from a >> PowerShell script. But after silent installation, below mentioned registry >> entry seems not added. I am passing a

Re: Tomcat doesn't refreshes and still gives me an old error again and again

2019-09-10 Thread Mark Thomas
On 06/09/2019 15:36, Karen Goh wrote: > > > > > > On Thursday, September 5, 2019, 9:47:40 PM GMT+8, Mark Thomas > wrote: > > > Personally, I gave up on using Tomcat and Eclipse in this way a long > time ago. It is a little more work but I run a completely separate > Tomcat instance and

Tomcat 9.0.16 Packaging Change (Extras)

2019-09-10 Thread Stephen Hames
Hi All, After Tomcat 9.0.14, the packaging available for download seems to have changed in that the bin/extras directory has been removed. I am finding a bit of confusion on this. We use catalina-jmx-remote.jar and previously this was included in the extras directory. I saw an entry in the