Re: issues starting Tomcat 6.0.18 when CATALINA_BASE does not match CATALINA_HOME

2008-08-06 Thread Rainer Jung
Mark Thomas schrieb: [EMAIL PROTECTED] wrote: And thats it. I have confirmed tomcat starts just fine when BASE matches HOME. I experimented with copying catalina.sh from 6.0.16 into 6.0.18's bin directory, and the server then starts as expected. However, I can't seem to find what in

Re: Setting CATALINA_BASE failed with tomcat-6.0.18

2008-08-06 Thread Rainer Jung
See also http://marc.info/?t=12180313421r=1w=2 Regards, Rainer Zemian Deng schrieb: Hi Mark, I am away from a computer now. But the steps I gave to reproduce out of default download is only 4 steps!!! You can't see error using that? I guess I can check the log for the stacktrace later.

Re: Refresh the cache

2008-08-06 Thread David Smith
Mark Thomas wrote: David Smith wrote: Could you provide some better detail regarding what you mean? Tomcat itself does not have a cache in any of it's versions. Not strictly true. Static resources are cached (for a few seconds), classes are cached in the classloader, expressions are cached

Tomcat 6 classpath issue

2008-08-06 Thread wskent
I have the following jars in my web projects \web\WEB-INF\lib dirdectory - log4j-1.2.13.jar, mysql-connector-java-5.0.5.jar, servlet-api-2.4.jar, standard-1.1.2.jar When I retrieve the classpath using - String classPath = System.getProperty(java.class.path,.);

RE: Refresh the cache

2008-08-06 Thread Gordon, Jack
We were told by our vendor to clear the cache. That may not be the right term, but the process that they have us do is to remove the folders from the following directory: D:\Tomcat 4.1\work\Standalone\localhost -Original Message- From: David Smith [mailto:[EMAIL PROTECTED] Sent:

SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Ken Bowen
Hi all, Using: Mac OS X 10.4.5 running Tomcat 5.5.26 -- this is a brand-new copy downloaded from Apache unzipped; no changes. This project used to work; I'm trying to figure out what got broken. Symptom: listenerStart fails without even getting to the first line of the AppListener

Re: Refresh the cache

2008-08-06 Thread Mark Thomas
Gordon, Jack wrote: We were told by our vendor to clear the cache. That may not be the right term, but the process that they have us do is to remove the folders from the following directory: D:\Tomcat 4.1\work\Standalone\localhost OK - you can't do that without stopping Tomcat. Mark

Re: Tomcat 6 classpath issue

2008-08-06 Thread Mark Thomas
wskent wrote: I have the following jars in my web projects \web\WEB-INF\lib dirdectory - log4j-1.2.13.jar, mysql-connector-java-5.0.5.jar, servlet-api-2.4.jar, standard-1.1.2.jar When I retrieve the classpath using - String classPath = System.getProperty(java.class.path,.);

Re: Tomcat 6 classpath issue

2008-08-06 Thread Steve Ochani
Date sent: Wed, 06 Aug 2008 08:36:48 -0700 (PDT) From: wskent [EMAIL PROTECTED] Subject:Tomcat 6 classpath issue To: users@tomcat.apache.org Send reply to: Tomcat Users List users@tomcat.apache.org I have the following

Re: SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread David Smith
Each listener should be in it's own listener ... /listener element block. Don't try to put all three in one. --David Ken Bowen wrote: Hi all, Using: Mac OS X 10.4.5 running Tomcat 5.5.26 -- this is a brand-new copy downloaded from Apache unzipped; no changes. This project used to work;

CHKJ4014W Warning

2008-08-06 Thread Bell, Geoffrey T.
I'm getting a warning that I can't seem to find an answer for. The Eclipse console is stating: Severity and Description: CHKJ4014W: Empty Entry of Type Parameter Name. Path: emtk-air/src/main/webapp/WEB-INF Resource: web.xml Location: [EMAIL PROTECTED] e (paramName:

Re: Parsing a URL to see if a param exists

2008-08-06 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 David, You could use HttpUtils.parseQueryString, but the entire class is deprecated. I like your home made parser below, with a couple of tweaks: David Wall wrote: | Not really since I just need to process the query string portion to see | if a

Re: Tomcat does not shutdown properly and kill -3 does not work!

2008-08-06 Thread Maduranga Kannangara
Peter and all, Earlier was from my MAC. This thread dump is from RedHat (production server). Your help is much appreciated. Attaching to process ID 12649, please wait... Debugger attached successfully. Client compiler detected. JVM version is 1.5.0_09-b01 Thread 12649: (state = BLOCKED)

RE: CHKJ4014W Warning

2008-08-06 Thread Martin Gainty
Hi Geoff- masking out the propietary vits can you supply your web.xml ? Martin __ Disclaimer and confidentiality note Everything in this e-mail and any attachments relates to the official business of Sender. This transmission is of a confidential

[NOT-FIXED]SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Ken Bowen
Ok, I fixed that (see below), but that does seem to change the problem at all. The catalina.out trace is the same. Current web.xml: web-app listener listener-classcom.connectedtrading.listener.AppListener/ listener-class /listener listener

RE: Tomcat does not shutdown properly and kill -3 does not work!

2008-08-06 Thread Peter Crowther
From: Maduranga Kannangara [mailto:[EMAIL PROTECTED] Below is my dump and thanks a lot for your time. [...] Thread [EMAIL PROTECTED]: (state = BLOCKED) - java.lang.Thread.sleep(long) @bci=0 (Interpreted frame) - org.quartz.core.QuartzSchedulerThread.run() @bci=870, line=420 (Interpreted

RE: CHKJ4014W Warning

2008-08-06 Thread Bell, Geoffrey T.
Sure, here it is: ?xml version=1.0 encoding=UTF-8? !DOCTYPE web-app PUBLIC -//Sun Microsystems, Inc.//DTD Web Application 2.3//EN http://java.sun.com/dtd/web-app_2_3.dtd; web-app display-nameemtk-air/display-name descriptionLiveCycle Data Services Application/description

Re: Parsing a URL to see if a param exists

2008-08-06 Thread David Wall
Thanks for the code idea. I like what you wrote. If there's no '?' in the URL, then you can return false right away, right? Indeed! public boolean isParamInUrl(String url, String paramName) { ~ return url.contains('?' + paramName + '=') ~ || url.contains('' + paramName + '='); }

Re: Parsing a URL to see if a param exists

2008-08-06 Thread Johnny Kewl
- Original Message - From: David Wall [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Wednesday, August 06, 2008 1:17 AM Subject: Parsing a URL to see if a param exists Is there an API call to parse an URL I have as a String so that I can determine if a given

Re: [NOT-FIXED]SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Mark Thomas
Ken Bowen wrote: Ok, I fixed that (see below), but that does seem to change the problem at all. The catalina.out trace is the same. Have a look at the files in the logs directory. One of them should have more information (like the stacktrace from the failed listener). Mark

j_security_check

2008-08-06 Thread Carlos Morales
Hello all, I'm having problems with j_security_check because when I try to log in my login.jsp it doesn't work and I don't know why. Here is my web.xml : ?xml version=1.0 encoding=UTF-8? web-app xmlns=http://java.sun.com/xml/ns/j2ee; xmlns:xsi=http://www.w3.org/2001/XMLSchema-instance;

Re: Parsing a URL to see if a param exists

2008-08-06 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Johnny, Johnny Kewl wrote: | Dave this is how I do it... | |Enumeration paramNames = request.getParameterNames(); Go back and read the OP: he says that he's got a String and he wants to treat it as a URL and check for parameters. He's

Re: How to programmatically add parameters to ServletRequest objects?

2008-08-06 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Jonathan, Jonathan Mast wrote: | I can't figure out how to use the pageContext.forward() method like it's | equivalent script element: Do you mean that you want to add parameters to a forwarded URL without using JSP? | How do I pass the name-value

Re: j_security_check

2008-08-06 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Carlos, Carlos Morales wrote: | I'm having problems with j_security_check because when I try to log | in my login.jsp it doesn't work and I don't know why. Care to elaborate? - -chris -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.9 (MingW32)

Re: Setting CATALINA_BASE failed with tomcat-6.0.18

2008-08-06 Thread Zemian Deng
Hum... so it is a confirmed bug then. I don't see a ticket open on those threads. Should I create one? On Wed, Aug 6, 2008 at 11:14 AM, Rainer Jung [EMAIL PROTECTED]wrote: See also http://marc.info/?t=12180313421r=1w=2 Regards, Rainer Zemian Deng schrieb: Hi Mark, I am away from

Re: Monitoring tomcat process

2008-08-06 Thread Johnny Kewl
- Original Message - From: Fu-Tung Cheng [EMAIL PROTECTED] To: tomcat-u users@tomcat.apache.org Sent: Wednesday, August 06, 2008 12:50 AM Subject: Monitoring tomcat process Hi, I was wondering what solutions people are using to monitor their tomcat processes. I've been having a

RE: CHKJ4014W Warning

2008-08-06 Thread Martin Gainty
Geoff- did you verify security-context.xml contains the required context attributes and is located on classpath e.g.? security login-command class=com.gdais.security.AcegiLoginCommand server=Tomcat/ security-constraint id=basic-read-access auth-methodBasic/auth-method roles

RE: CHKJ4014W Warning

2008-08-06 Thread Bell, Geoffrey T.
Yes, it appears to be valid XML. I checked it with 3 validation services online. ~ Geoff ~ -Original Message- From: David Smith [mailto:[EMAIL PROTECTED] Sent: Wednesday, August 06, 2008 10:22 AM To: Tomcat Users List Subject: Re: CHKJ4014W Warning Does your web.xml pass a xml

Re: Monitoring tomcat process

2008-08-06 Thread Johnny Kewl
Hi, I was wondering what solutions people are using to monitor their tomcat processes. I've been having a look at the following: http://code.google.com/p/tomcat-monitor/wiki/TomcatMonitor Are there better scripts or alternatives for handling restarting the vm in the case of out of memory

Re: j_security_check

2008-08-06 Thread Carlos Morales
I have my login and password to access onto my web which I try to go after authenticate my login and password in a form called login.jsp where I use the j_security_check, well when I press logon, it doesn't work. It stays in the same page login.jsp but I use my password and login well and I

Re: How to programmatically add parameters to ServletRequest objects?

2008-08-06 Thread Jonathan Mast
| This is really the only way to do it. The other option is to create a | new request object and stuff your own parameters into it (or, better | yet, wrap the original request and add your parameters only to the wrapper). How would I do this? This is basically what Jakarta Commons HTTPClient

Re: j_security_check

2008-08-06 Thread Carlos Morales
In my conf folder inside of my Tomcat directory in my server.xml I have this: Context path=./Capitulo19_1 docBase=Capitulo19_1 debug=0 reloadable=true    Realm className=org.apache.catalina.realm.JDBCRealm debug=99    driverName=org.gjt.mm.mysql.Driver   

Re: [NOT-FIXED]SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Ken Bowen
That's what's frustrating. I'm using a new Tomcat unzip with simple JULI logging, so the files of interest are catalina.out and catalina.2008-08-06.log, which are essentially identical. Normally when a listener class fails, the trace is shown in catalina.out, before/after the Error

Re: j_security_check

2008-08-06 Thread Fu-Tung Cheng
I suggest you start with a working example and modify it once you have it working. You might also provide the following information if you expect help. In general though I think you should have a read of the following: http://www.catb.org/~esr/faqs/smart-questions.html What realm do you

RE: CHKJ4014W Warning

2008-08-06 Thread Bell, Geoffrey T.
Wierd. I checked all of your points and they seemed fine. I 'cleaned' my project, and the warning went away. I know I did that before Thanks for the help. ~ Geoff ~ -Original Message- From: Martin Gainty [mailto:[EMAIL PROTECTED] Sent: Wednesday, August 06, 2008 10:38 AM To:

Acceptable values for SSLProtocol parameter for HTTPS connector in Tomcat5.5

2008-08-06 Thread sharanabasavaraj . x . mudgal
Hi!, Could someone please tell the acceptable values for sslprotocol parameter for the HTTP Connector. The default is set to TLS1.0. However, I wanted to know if it could be set to both TLS1.0 and SSLv3. The How-to document lists only two of the values SSL and TLS1.0 and does not

Re: [NOT-FIXED]SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Mark Thomas
Ken Bowen wrote: That's what's frustrating. I'm using a new Tomcat unzip with simple JULI logging So what is the log4j message doing in this trace? Mark - To start a new topic, e-mail: users@tomcat.apache.org To

RE: CHKJ4014W Warning

2008-08-06 Thread Martin Gainty
good pointcleaning your work folders! Martin __ Disclaimer and confidentiality note Everything in this e-mail and any attachments relates to the official business of Sender. This transmission is of a confidential nature and Sender does not

Re: Tomcat 6 classpath issue

2008-08-06 Thread wskent
I looked at the Tomcat HowTo, so what do I use in place of System.getProperty(java.class.path,.); Ageed on not including the 2.4 jar! -- View this message in context: http://www.nabble.com/Tomcat-6-classpath-issue-tp18853872p18856933.html Sent from the Tomcat - User mailing list archive at

rewrite.properties - AJP1.3 connector (isapi_redirect.dll) from IIS 6 to tomcat 5.5

2008-08-06 Thread Saltzman, Robert B (GE, Research)
I have installed tomcat 5.5.26 and JK 1.2.26 on a Windows 2003 Standard Server running IIS 6. isapi_redirect.properties, workers.properties, uriworkermap.properties, server.xml are all configured, and IIS to tomcat jvm AJP connection is working fine. However I need to do URL rewriting (may also

Re: How to programmatically add parameters to ServletRequest objects?

2008-08-06 Thread Warren Killian
Hi Jonathan, About ServletRequest and ServletResponse Interfaces not having a setParameter(name, value) method...depending on your situation, you may not need to do that. Are you forwarding to another URI within your web app? If so, you could use request/session.setAttribute( String name,

Re: rewrite.properties - AJP1.3 connector (isapi_redirect.dll) from IIS 6 to tomcat 5.5

2008-08-06 Thread Mladen Turk
Saltzman, Robert B (GE, Research) wrote: I have installed tomcat 5.5.26 and JK 1.2.26 on a Windows 2003 Standard Server running IIS 6. isapi_redirect.properties, workers.properties, uriworkermap.properties, server.xml are all configured, and IIS to tomcat jvm AJP connection is working fine.

Re: How to programmatically add parameters to ServletRequest objects?

2008-08-06 Thread Tim Funk
I suggest you look at ServletRequest.setAttribute() In programming Servlets - you can work with parameters which are the fun little things which come off the query string or via the POST body. These items should be thought readonly - and only set/sent from the HttpClient (aka - the web

[??-FIXED: Yes, but]SEVERE: Error listenerStart -- without entering the listener

2008-08-06 Thread Ken Bowen
Mark, Somewhat odd. I've been slowly reworking the app (significant rebuilding) for a couple of months, and have routinely been seeing that log4j complaint, although everything was working ok -- so of course I wasn't even seeing the complaint anymore, expecting that everything would clean

Re: Would like to monitor memory use offline

2008-08-06 Thread Richard S. Huntrods
To Ben Mark, Thanks for the replies. I've been trying various things based on your suggestions. I find my best tool at the moment is Lambda Probe - though it hasn't been updated in a while, it does show me all the things (for the most part) that I wanted to watch. There's definitely some

Re: Setting CATALINA_BASE failed with tomcat-6.0.18

2008-08-06 Thread Rainer Jung
Are we sure, that you experience the same problem? In other words, is CATALINA_HOME/conf/logging.properties missing in your setup and does the suggested workaround to catalina.sh solve the problem for you? Regards, Rainer Zemian Deng schrieb: Hum... so it is a confirmed bug then. I don't see a

Re: Setting CATALINA_BASE failed with tomcat-6.0.18

2008-08-06 Thread Zemian Deng
am I sure? I think it is. Well, I gave explicit 4 little instructions to repeat exactly what I found. I read your post and by simply touch/create a empty file under $CATALINA_BASE/conf/logging.properties and that indeed fixed the problem and server starts up fine. So call it same problem or

Re: Tomcat 6 classpath issue

2008-08-06 Thread Steve Ochani
Date sent: Wed, 06 Aug 2008 11:25:23 -0700 (PDT) From: wskent [EMAIL PROTECTED] Subject:Re: Tomcat 6 classpath issue To: users@tomcat.apache.org Send reply to: Tomcat Users List users@tomcat.apache.org I looked at the

Tomcat cluster (NullPointer when replicating session)

2008-08-06 Thread Lia
Hi everybody, I am using - Tomcat 6.0.18 ( but I've also tested the same scenario with Tomcat 6.0.16 and Tomcat 6.0.14 and I got the same problem); - in cluster ( two machines); - on Debian x64, 4.0. When using DeltaManager (with or without sticky sessions) the cluster works fine, but for some

Re: Setting CATALINA_BASE failed with tomcat-6.0.18

2008-08-07 Thread Rainer Jung
Zemian Deng wrote: am I sure? I think it is. Well, I gave explicit 4 little instructions to repeat exactly what I found. I read your post and by simply touch/create a empty file under $CATALINA_BASE/conf/logging.properties and that indeed fixed the problem and server starts up fine. Thank's

Regarding Service Unavailable

2008-08-07 Thread welcome.partha
i run my web application after started my apache-tomcat server,it displayed service unavailable.If i refreshed it its run successfully.Actually sometimes its working initially ,sometimes i give refresh then only its run successfully. Please help me.. Thanks in advance P.Parthasarathi -- View

Re: Regarding Service Unavailable

2008-08-07 Thread Ch Praveena
Hi, You have to wait until the application is loaded to the tomcat container and the server has to respond. But, when did u get this 503 error? is it soon after ur startup? if so, jus check the command console page to read the status of the tomcat container/server is completely loaded

Status Web Application

2008-08-07 Thread Kaushal Shriyan
Hi I am running tomcat-5.0.27-r6/sun-jdk-1.5.0.10/Gentoo. when i look at the Status Web Application (http://example.com:8080/manager/status) I see lots of this page StageTimeB SentB RecvClientVHost S678731459 ms0 KB0 KB10.10.1.6host12 is there a way to

Re: Regarding Service Unavailable

2008-08-07 Thread Johnny Kewl
- Original Message - From: welcome.partha [EMAIL PROTECTED] To: users@tomcat.apache.org Sent: Thursday, August 07, 2008 9:47 AM Subject: Regarding Service Unavailable i run my web application after started my apache-tomcat server,it displayed service unavailable.If i refreshed it

How to set up logging level to debug in tomcat

2008-08-07 Thread Thangavel Sankaranarayanan
At present logging level is 'info'. How do i set up tomcat to write logs in debug level. Regards, Thangavel Sankaranarayanan _ Web and Cust Care – Vodafone ANZ IBM India Pvt Ltd, Block D3, Manyata Embassy Business Park, Outer Ring Road, Rachenahalli,

RE: Regarding Service Unavailable

2008-08-07 Thread Martin Gainty
Partha which TC you are implementing? Also how you are starting your TC service which will look something like $TOMCAT_HOME/bin/tomcat5.exe //TS//Tomcat5 http://tomcat.apache.org/tomcat-5.5-doc/windows-service-howto.html check the tomcat logs for any exceptions in $TOMCAT_HOME/logs HTH Martin

Re: How to programmatically add parameters to ServletRequest objects?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Jonathan, Jonathan Mast wrote: | | This is really the only way to do it. The other option is to create a | | new request object and stuff your own parameters into it (or, better | | yet, wrap the original request and add your parameters only to the

Re: Would like to monitor memory use offline

2008-08-07 Thread Philip Wigg
Hi, the manager application can return values in XML. You just need to hit:- http://localhost:8080/manager/status?XML=true or wherever it's located. This makes it a bit easier to write shell scripts based on Free Heap or Max Threads or whatever. I've got a perl script which checks whatever

RE: Cool SSL/TLS Deployment Trick! How Does It Work?

2008-08-07 Thread Patrick Markiewicz
Hi Warren, It is my understanding that all tomcat does with a WAR file is unjar it. I.e. whatever is in the war becomes extracted into a particular location. Tomcat does not edit any of the files that come from the WAR file, it just reads those files for servlet mappings (web.xml) and

Re: Cool SSL/TLS Deployment Trick! How Does It Work?

2008-08-07 Thread Warren Killian
Hi Patrick, Thank you very much for the response. I was so perplexed (and ignorant) about how this worked, that I stayed up to all hours of the morning with my Tomcat book reading, researching and experimenting on my home system to figure out how this particular deployment practice actually

Weird stack trace when reloading a webapp

2008-08-07 Thread Olivier Lamy
Hi, I use the ant deploy target : deploy url=${url} username=${tomcat.user} password=${tomcat.password} path=/{webPath} localWar=${warPath} update=true config=${contextPath} / But in catalina.out, I have the following stack trace : INFO: Deploying web application archive

Re: Tomcat cluster (NullPointer when replicating session)

2008-08-07 Thread Filip Hanik - Dev Lists
In Tomcat 6, use DeltaManager or BackupManager Filip Lia wrote: Hi everybody, ... ... I am using - Tomcat 6.0.18 ( but I’ve also tested the same scenario with Tomcat 6.0.16 and Tomcat 6.0.14 and I got the same problem); - in cluster ( two machines); - on Debian x64, 4.0. When using

RE: How to set up logging level to debug in tomcat

2008-08-07 Thread Narasimha Prasad Subraveti
You have to modify your log4j propertiesyou can modify the root logger or even have a log4j.properties in your webapps/application/WEB-INF/classes/ directory and use log4j specific to your application. Check this link out http://tomcat.apache.org/tomcat-5.5-doc/logging.html

tomcat and naming-common.jar problem.

2008-08-07 Thread Ivan Gonzalez
Hello everyone! I have my server using tomcat 6.0.16 and apache 2.2.3 on CentOS 5.1 When i try to display the content of my page the only thing i get is a blank page but when i delete naming-common.jar and restart the tomcat service it works great (display all the content of my page). Does

Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 All, I've checked everything I can think of. Today, my dev instance of Tomcat started acting funny, saying: java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet ~at java.lang.ClassLoader.defineClass1(Native Method) ~at

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 All, Oh, yeah: there's no SecurityManager to worry about, either. Thanks, - -chris Christopher Schultz wrote: | All, | | I've checked everything I can think of. Today, my dev instance of Tomcat | started acting funny, saying: |

Problem with POST to servlet: 16384 bytes maximum?

2008-08-07 Thread Michele Fuortes
Hi, I have a problem with POSTing an XML file to a servlet which writes the XML to disk. If the XML file is less than 16384 bytes all goes well. If it's bigger the first 16384 bytes are written correctly, the rest all all 00s. The lenght of the file is the correct one as in the

Re: Problem with POST to servlet: 16384 bytes maximum?

2008-08-07 Thread John . C . Cartwright
I've had similar problems in various versions of tomcat. Currently the problem seems to exist in 6.0.16 but not in 6.0.14 nor 5.5.17. There was a bug filed, but I don't have the reference handy. --john - Original Message - From: Michele Fuortes [EMAIL PROTECTED] Date: Thursday, August

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread David Smith
So to boil this down a bit, it doesn't work with your webapp, but suddenly comes to life if you remove your webapp and install LambdaProbe? That's bizaar. Is there another package javax.servlet.http that might be messing up the classloaders? Anything in any of the classes directories?

Re: Tomcat 6 Cluster Woes

2008-08-07 Thread Zachariah Zachariah
Thanks Filip. I found that changing the Host name to localhost from the actual node names made it to work properly. So in my case z2 and z3 were the actual node names that the OS (Solaris) knew them to be. I changed Engine and Host elements of the server.xml in these nodes to point to

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 David, David Smith wrote: | So to boil this down a bit, it doesn't work with your webapp, but | suddenly comes to life if you remove your webapp and install | LambdaProbe? Exactly. | That's bizarre. Yeah, it sure is. Since I originally

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Hassan Schroeder
On Thu, Aug 7, 2008 at 12:18 PM, Christopher Schultz [EMAIL PROTECTED] wrote: I'm going to start looking at the Velocity and Velocity-Tools JARs to see if they might have been corrupted or something. They are stored in CVS in our project, and cvs doesn't say anything, but since I'm grasping

Re: Weird stack trace when reloading a webapp

2008-08-07 Thread Johnny Kewl
- Original Message - From: Olivier Lamy [EMAIL PROTECTED] To: users@tomcat.apache.org Sent: Thursday, August 07, 2008 5:17 PM Subject: Weird stack trace when reloading a webapp Hi, I use the ant deploy target : deploy url=${url} username=${tomcat.user} password=${tomcat.password}

Re: Weird stack trace when reloading a webapp

2008-08-07 Thread Johnny Kewl
- Original Message - From: Johnny Kewl [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Thursday, August 07, 2008 9:45 PM Subject: Re: Weird stack trace when reloading a webapp - Original Message - From: Olivier Lamy [EMAIL PROTECTED] To:

Re: Problem with POST to servlet: 16384 bytes maximum?

2008-08-07 Thread Rainer Jung
[EMAIL PROTECTED] schrieb: I've had similar problems in various versions of tomcat. Currently the problem seems to exist in 6.0.16 but not in 6.0.14 nor 5.5.17. There was a bug filed, but I don't have the reference handy. That was 44494. But 44494 has an 8KB limit and also it's very

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Hassan Schroeder
On Thu, Aug 7, 2008 at 1:09 PM, Christopher Schultz [EMAIL PROTECTED] wrote: Yeah, I did that and everything looks good. CVS will only destroy a binary file if you forget to disable keyword expansion (been there!). Ah, that could have been the case -- I hadn't set it up, and wasn't all that

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Johnny Kewl
- Original Message - From: Christopher Schultz [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Thursday, August 07, 2008 7:45 PM Subject: Sudden missing javax/servlet/http/HttpServlet ? -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 All, I've checked

Re: Weird stack trace when reloading a webapp

2008-08-07 Thread Olivier Lamy
Hi, Thanks for your reponse but undeploy/redeploy don't save me same issue :-(. -- Olivier 2008/8/7 Johnny Kewl [EMAIL PROTECTED]: - Original Message - From: Olivier Lamy [EMAIL PROTECTED] To: users@tomcat.apache.org Sent: Thursday, August 07, 2008 5:17 PM Subject: Weird stack trace

Re: Problem with POST to servlet: 16384 bytes maximum?

2008-08-07 Thread Johnny Kewl
- Original Message - From: Michele Fuortes [EMAIL PROTECTED] To: users@tomcat.apache.org Sent: Thursday, August 07, 2008 8:18 PM Subject: Problem with POST to servlet: 16384 bytes maximum? Hi, I have a problem with POSTing an XML file to a servlet which writes the XML to disk. If

Re: [SOLVED] Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 All, Thanks for your patience with my stupidity. I try not to do it publicly very often ;) I found the culprit: multiple instances of a class were defined in my webapp. You'll never guess why. A clean checkout from cvs revealed that my webapp was

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Johnny, Johnny Kewl wrote: | Chris, your webapps probably still work out side the dev environment | I think all thats happening is your IDE is not loading the commons lib... No IDE involved: real men use emacs ;) Okay, maybe vi. The

Re: Weird stack trace when reloading a webapp

2008-08-07 Thread Johnny Kewl
- Original Message - From: Olivier Lamy [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Thursday, August 07, 2008 11:21 PM Subject: Re: Weird stack trace when reloading a webapp Hi, Thanks for your reponse but undeploy/redeploy don't save me same issue :-(.

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Johnny Kewl
- Original Message - From: Christopher Schultz [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Thursday, August 07, 2008 11:40 PM Subject: Re: Sudden missing javax/servlet/http/HttpServlet ? -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Johnny, Johnny Kewl

Re: Would like to monitor memory use offline

2008-08-07 Thread Richard S. Huntrods
Well, thanks to Lamda probe and then to jmap, I have found my memory leak. Here are the gory details in case anyone is interested. It's not really a Tomcat issue, but rather the boundary between Tomcat and MySQL: I have a memory leak in my application, and jmap shows me that all my objects of

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Johnny, Johnny Kewl wrote: | | - Original Message - From: Christopher Schultz | [EMAIL PROTECTED] | To: Tomcat Users List users@tomcat.apache.org | Sent: Thursday, August 07, 2008 11:40 PM | Subject: Re: Sudden missing

Re: Would like to monitor memory use offline

2008-08-07 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Richard, Richard S. Huntrods wrote: | In my code I was calling resultSet.close(), but not statement.close(). That'll do it. | The problem is, even though I verified (debug statements) that the call | is being made, the memory is STILL not being

Re: Sudden missing javax/servlet/http/HttpServlet ?

2008-08-07 Thread Hassan Schroeder
On Thu, Aug 7, 2008 at 5:23 PM, Christopher Schultz [EMAIL PROTECTED] wrote: | Ha ha... I didnt look at who was asking the question... guru's... always | want to build the freezer, just to get a cold beer ;) I kept trying to come up with a funny you should see what I do what I want to

application failed to start : Error in dependencyCheck java.util.zip.ZipException: invalid entry CRC

2008-08-08 Thread [EMAIL PROTECTED]
attempting to run application on Tomcat 5.5 server (Fails to load at context path) I see this in the catalina.log Google search suggests a zip file error with the .war - but I have only used an exploded tree and removed previous .war file. Any suggestions? -- James Stanbridge Kellstan IM:

mvn command line failed with archetype....

2008-08-08 Thread Sam Wun
Hi, I am wondering how to fix the following attached error (mvn command run)? I tried to follow the instruction shown in the following website, but got error. http://struts.apache.org/2.x/docs/developing-a-portlet-using-eclipse.html === attached mvn command run === Maven

Apache / mod_jk / Jboss-tomcat weirdness

2008-08-08 Thread pthyseba
Hello everyone, I previously asked this on the Apache users mailing list - but it occurred to me that this list may be more appropriate) I'm trying to figure out some weirdness in a fairly large web environment. We're running a web environment using RHEL 4, Apache 2.0.52 with Worker MPM,

mvn failed with archetype....

2008-08-08 Thread Sam Wun
Hi, I am wondering how to fix the following attached error (mvn command run)? I tried to follow the instruction shown in the following website, but got error. http://struts.apache.org/2.x/docs/developing-a-portlet-using-eclipse.html === attached mvn command run === Maven

Re: Weird stack trace when reloading a webapp

2008-08-08 Thread Olivier Lamy
Ok I will search and try reordering filters. Thanks for your time ! -- Olivier 2008/8/8 Johnny Kewl [EMAIL PROTECTED]: - Original Message - From: Olivier Lamy [EMAIL PROTECTED] To: Tomcat Users List users@tomcat.apache.org Sent: Thursday, August 07, 2008 11:21 PM Subject: Re: Weird

Re: Apache / mod_jk / Jboss-tomcat weirdness

2008-08-08 Thread Mladen Turk
[EMAIL PROTECTED] wrote: A weird thing I see is that sometimes, the apache server status page displays requests/threads in the W (sending reply) state up to Apache timeout, while the Jboss Jk status shows no threads for that client in the Service state. Fix your firewall. It silently closes

Re: JDNI Resource not reusable

2008-08-08 Thread Sebastian Gerdes
Hello, to whom it may concern, I solved this problem in another way. In the ContextFactory I only return an InitialDirContext. The class which wants to connect to the LDAP uses this InitialDirContext, looks up the environment and connects to the LDAP. You can find the source code at:

No available certificate or key corresponds to the SSL cipher suites which are enabled

2008-08-08 Thread paulsnodgrass
I am trying to configure SSL on a tomcat 6.0.13. I began by creating a default keystore (using keytool) in the user's directory where the apache tomcat server is installed. From this keystore I generated a server cert request. Once I received the server cert, I loaded the trusted certs and

My Log4j statements going crazy in catalina.out

2008-08-08 Thread emerson cargnin
Hi Guys My Log4j configuration has all turned to ERROR in my log4j.lcf. In resin this works right, so no INFO or DEBUG in the resin main log file. In tomcat, though, even if my log file has only ERROR statements, catalina.out seems to be getting all INFO, DEBUG from my application. I couldnt'

Re: No available certificate or key corresponds to the SSL cipher suites which are enabled

2008-08-08 Thread Mark Thomas
[EMAIL PROTECTED] wrote: I am trying to configure SSL on a tomcat 6.0.13. I began by creating a default keystore (using keytool) in the user's directory where the apache tomcat server is installed. From this keystore I generated a server cert request. Once I received the server cert, I

Re: Tomcat 6.0.18 startup Permission Denied Error:listen failed initializing endpoint

2008-08-08 Thread Charles Lim
Finally the issue was solved. It was due to the Norman Anti-virus+Firwall. Although I have disable the firewall, stopped all Norman services that can be stopped, i still get the Permission Denied error. Only after I have uninstalled Norman can Tomcat start. After which I 1) installed AVG free

Re: Problem with POST to servlet: 16384 bytes maximum?

2008-08-08 Thread Warren Killian
Hi, If you can't get past this limitation, you might look into the Apache Commons file upload utility. It is an API specifically for allowing (large) file uploads to a server. It works great, has a simple API and some decent documentation as well. Hope this helps. On Thu, Aug 7, 2008 at 2:18

Re: Problem with POST to servlet: 16384 bytes maximum?

2008-08-08 Thread Sam Wun
Hi, I am wondering how to fix the following attached error (mvn command run)? I tried to follow the instruction shown in the following website, but got error. http://struts.apache.org/2.x/docs/developing-a-portlet-using-eclipse.html === attached mvn command run === Maven

  1   2   3   4   5   6   7   8   9   10   >