Help with Tomcat 7 clustering using BIO receiver

2014-06-30 Thread João Sávio
Hello people This is my first message on this group! I'm trying to set up a Tomcat clustering using BIO receiver but I've been receiving the following error when I started two nodes and tried to enter on my application: Jun 30, 2014 9:25:12 PM

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-02 Thread João Sávio
? 2014-06-30 18:38 GMT-03:00 João Sávio joaosa...@gmail.com: Hello people This is my first message on this group! I'm trying to set up a Tomcat clustering using BIO receiver but I've been receiving the following error when I started two nodes and tried to enter on my application: Jun 30

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
, but don't solve it. Thanks 2014-07-02 13:28 GMT-03:00 Mark Eggers its_toas...@yahoo.com.invalid: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 7/2/2014 6:37 AM, João Sávio wrote: ? 2014-06-30 18:38 GMT-03:00 João Sávio joaosa...@gmail.com: Hello people This is my first message

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
Unfortunately it's not working yet I increased the log level as you suggested. Log attached Thanks 2014-07-03 11:10 GMT-03:00 João Sávio joaosa...@gmail.com: Hello Mark Thanks for your answer. I put the new information and cluster works (maybe because I reboot my machine) Indeed, I'm

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
Hello! Using NIO (with channelSendOptions=4, i.e., synchronous), with lightly load, my tests pass 100%. But, on heavy load, not all sessions are replicated on time, and I have about 20% of errors. If I increase maxThreads to 400, I have about 15% of errors. More information: * I am not

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
cluster.log - http://pastebin.com/c98WhnmG 2014-07-03 13:04 GMT-03:00 João Sávio joaosa...@gmail.com: Hello! Using NIO (with channelSendOptions=4, i.e., synchronous), with lightly load, my tests pass 100%. But, on heavy load, not all sessions are replicated on time, and I have about 20

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
tests using NIO, default VM configuration and FINER logs. Thanks a lot João 2014-07-03 14:07 GMT-03:00 Mark Eggers its_toas...@yahoo.com.invalid: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 7/3/2014 9:12 AM, João Sávio wrote: cluster.log - http://pastebin.com/c98WhnmG 2014-07

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
replying to. See here for mailing list notes: http://tomcat.apache.org/lists.html#tomcat-users On 7/3/2014 10:24 AM, João Sávio wrote: Hello Some points below: ** What is on time?* In my application, a group of users should always hit the same node after the first request

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
Hello Filip The nodes are in the same machine! Regards João

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
Hello Mark In fact, I'm not explicit invalidating session on this two requests. Regards João

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
Hello Filip I'm using channelSendOptions=4, which is supposed to be synchronous Regards João

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
I don't think so. Here it is: http://pastebin.com/qYCzmECb (server.xml - node1) Regards João

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-03 Thread João Sávio
If I set channelSendOptions=8 (default value = asynchronous), the % of errors increase (as expected) Regards João 2014-07-03 19:43 GMT-03:00 João Sávio joaosa...@gmail.com: I don't think so. Here it is: http://pastebin.com/qYCzmECb (server.xml - node1) Regards João -- http

Re: Help with Tomcat 7 clustering using BIO receiver

2014-07-04 Thread João Sávio
Hello Filip You solved my issue! Thank you very much! Thanks everyone João

Re: Tomcat7 cluster don't replicates session

2014-11-17 Thread João Sávio
Rapaz, sugiro vc perguntar na lista do Tomcat Ab Em 29/10/2014 15:06, Nilson Uehara nilueh...@gmail.com escreveu: I have a Ubuntu with 2 Tomcat7 with a cluster configurations. The balancer is Apache MOD_JK. *SERVER.XML:* Engine name=Catalina defaultHost=localhost jvmRoute=no0

HTTP session change is not been replicated when changing it in event processing

2014-11-19 Thread João Sávio
Hi guys I have a Tomcat cluster with 4 nodes that is set to replicate HTTP session across all nodes. Common session operations work fine (e.g., user perform a request, and something is saved on the session). However, I have a situation where the session is not replicated. My application works

Re: HTTP session change is not been replicated when changing it in event processing

2014-11-19 Thread João Sávio
I found the solution: I was updating an attribute in a session object. In that case, I need to explicitly call session.setAttribute() with the updated object Thanks

Re: HTTP session change is not been replicated when changing it in event processing

2014-11-19 Thread João Sávio
Thanks! 2014-11-19 13:48 GMT-02:00 Mark Thomas ma...@apache.org: On 19/11/2014 16:32, João Sávio wrote: I found the solution: I was updating an attribute in a session object. In that case, I need to explicitly call session.setAttribute() with the updated object https

NullPointerException when using NIO connector

2016-01-28 Thread João Sávio
Hello guys I'm using Tomcat 7.0.53 and I've changed it to use the NIO connector recently. So, the following error start appearing on the logs (few per day) Jan 25, 2016 3:10:16 PM org.apache.tomcat.util.net.NioEndpoint processSocket SEVERE: Error allocating socket processor

Synchronous Tomcat cluster

2016-01-25 Thread João Sávio
Hello guys I'm trying to setup a Tomcat cluster to be synchronous (default uses channelSendOptions=8, which is asynchronous). Some time ago, I had issues with session replication, I asked on this list, and using the configuration channelSendOptions="6" solved my issues. However, now, during load

Re: ids of all active sessions

2016-01-25 Thread João Sávio
I think you can also retrieve them via JMX Regards 2016-01-23 9:05 GMT-02:00 Kaouthar Ghorbel : > thanks Thomas ☺ > > 2016-01-18 10:02 GMT+01:00 Thomas Scheffler >: > > > Am 18.01.16 um 09:35 schrieb Kaouthar Ghorbel: > > > >> Hello everyone