RE: Tomcat 8/NIO performance discrepancies

2017-06-12 Thread Piyush Kumar Nayak
Thanks, Mark. I have been testing with 100 concurrent users. While the executor had the maxThreads set to 150, the connector without the executor was left to the default value (which should be 200). I did not have the disableKeepAlivePercentage attribute set, which means that it should take to

RE: Tomcat 8/NIO performance discrepancies

2017-06-12 Thread Piyush Kumar Nayak
Mark, I apologize for not bringing this up before, but is that BIO vs NIO or BIO with executor vs NIO with executor? Thanks again, for looking into this. -Original Message- From: Mark Thomas [mailto:ma...@apache.org] Sent: Friday, June 09, 2017 12:30 AM To: Tomcat Users List

RE: Tomcat 8/NIO performance discrepancies

2017-06-12 Thread Piyush Kumar Nayak
ers@tomcat.apache.org> Subject: Re: Tomcat 8/NIO performance discrepancies On 12/06/17 20:27, Piyush Kumar Nayak wrote: > Thanks, Mark. > I have been testing with 100 concurrent users. While the executor had the > maxThreads set to 150, the connector without the executor was left to the

RE: Tomcat 8/NIO performance discrepancies

2017-06-07 Thread Piyush Kumar Nayak
be in use. Thanks Piyush. -Original Message- From: Mark Thomas [mailto:ma...@apache.org] Sent: Wednesday, June 07, 2017 8:27 PM To: Tomcat Users List <users@tomcat.apache.org> Subject: Re: Tomcat 8/NIO performance discrepancies On 06/06/17 09:10, Piyush Kumar Nayak wrote: > Tha

RE: Tomcat 8/NIO performance discrepancies

2017-06-06 Thread Piyush Kumar Nayak
.5.14 N/A 45600 1.67 N/A 46000 1.67 Regards, Piyush. -Original Message- From: Mark Thomas [mailto:ma...@apache.org] Sent: Tuesday, June 06, 2017 12:50 PM To: Tomcat Users List <users@tomcat.apache.org> Subject: Re: Tomcat 8/NIO performance discrepancies On 06/06/17 07:30

Tomcat 8/NIO performance discrepancies

2017-06-06 Thread Piyush Kumar Nayak
We have been testing different connectors of tomcat for performance. We have tested the following server versions: - Tomcat 7.077 - Tomcat 8.0.44 - Tomcat 8.0.32 - Tomcat 8.5.14 with the following HTTP connectors: - BIO - BIO with

RE: Tomcat 8/NIO performance discrepancies

2017-06-06 Thread Piyush Kumar Nayak
...@apache.org] Sent: Tuesday, June 06, 2017 7:09 PM To: Tomcat Users List <users@tomcat.apache.org> Subject: Re: Tomcat 8/NIO performance discrepancies Hi, 2017-06-06 11:10 GMT+03:00 Piyush Kumar Nayak <pna...@adobe.com.invalid<mailto:pna...@adobe.com.invalid>>: > > Thanks, M

RE: Tomcat 8/NIO performance discrepancies

2017-06-06 Thread Piyush Kumar Nayak
- Throughput: requests per sec. ART: msecs Also, forgot to add earlier, the jMeter client has keep-alive header enabled, and the server is left to use the default keepalive values. -Original Message- From: Piyush Kumar Nayak [mailto:pna...@adobe.com.INVALID] Sent: Tuesday, June 06

Recall: error when using ContentStreamDataSource in DIH

2019-08-18 Thread Piyush Kumar Nayak
Piyush Kumar Nayak would like to recall the message, "error when using ContentStreamDataSource in DIH". - To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org For additional commands, e-mail: users-h...@tomcat.apache.org

Recall: error when using ContentStreamDataSource in DIH

2019-08-18 Thread Piyush Kumar Nayak
Piyush Kumar Nayak would like to recall the message, "error when using ContentStreamDataSource in DIH". - To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org For additional commands, e-mail: users-h...@tomcat.apache.org

error when using ContentStreamDataSource in DIH

2019-08-18 Thread Piyush Kumar Nayak
Hi, I am trying to get data import to work with the data source embedded in the stream of the current request. I've enabled the dataImport request handler in the solrConfig.xml of the bookClub collection I'm testing this on, and reloaded the collection. But I keep running into the error