Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Dariusz Dolecki
Hi,

Which version of Tomcat is best for compatibility with these releases of
apache and JDK. Please help, we are on a deadline.

Regards,

Dariusz


RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Carrillo, Dan
If you want to utilize Servlet spec 3.0 or JSP spec 2.2 then use Tomcat version 
7.0.39.  This is compatible with Java 1.6.

If you prefer or are constrained to using the older servlet or JSP 
specifications, then use Tomcat version 6.0.36.

If you don't know or don't care, then my recommendation would be to use the 
latest stable version of Tomcat 7 because of the bug fixes and security 
enhancements.

Both Tomcat 6 and 7 are solid.

Do you plan on using the AJP connector with Apache httpd?

-Original Message-
From: Dariusz Dolecki [mailto:dariusz.dole...@gmail.com] 
Sent: Tuesday, April 30, 2013 8:09 AM
To: users@tomcat.apache.org
Subject: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

Hi,

Which version of Tomcat is best for compatibility with these releases of apache 
and JDK. Please help, we are on a deadline.

Regards,

Dariusz


-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org



RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Caldarale, Charles R
 From: Carrillo, Dan [mailto:dcarri...@idanalytics.com] 
 Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

 If you want to utilize Servlet spec 3.0 or JSP spec 2.2 then use Tomcat 
 version 
 7.0.39.  This is compatible with Java 1.6.

 If you prefer or are constrained to using the older servlet or JSP 
 specifications,
 then use Tomcat version 6.0.36.

No, Tomcat 7 supports the older specs as well.  No reason to use Tomcat 6 at 
this point.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY 
MATERIAL and is thus for use only by the intended recipient. If you received 
this in error, please contact the sender and delete the e-mail and its 
attachments from all computers.


-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org



Re: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Dariusz Dolecki
Does it matter if we are using AJP connector?


On Tue, Apr 30, 2013 at 10:56 AM, Caldarale, Charles R 
chuck.caldar...@unisys.com wrote:

  From: Carrillo, Dan [mailto:dcarri...@idanalytics.com]
  Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

  If you want to utilize Servlet spec 3.0 or JSP spec 2.2 then use Tomcat
 version
  7.0.39.  This is compatible with Java 1.6.

  If you prefer or are constrained to using the older servlet or JSP
 specifications,
  then use Tomcat version 6.0.36.

 No, Tomcat 7 supports the older specs as well.  No reason to use Tomcat 6
 at this point.

  - Chuck


 THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
 MATERIAL and is thus for use only by the intended recipient. If you
 received this in error, please contact the sender and delete the e-mail and
 its attachments from all computers.


 -
 To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
 For additional commands, e-mail: users-h...@tomcat.apache.org




RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Carrillo, Dan
Then documentation needs to be updated
http://tomcat.apache.org/whichversion.html


-Original Message-
From: Caldarale, Charles R [mailto:chuck.caldar...@unisys.com] 
Sent: Tuesday, April 30, 2013 8:57 AM
To: Tomcat Users List
Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

 From: Carrillo, Dan [mailto:dcarri...@idanalytics.com]
 Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

 If you want to utilize Servlet spec 3.0 or JSP spec 2.2 then use 
 Tomcat version 7.0.39.  This is compatible with Java 1.6.

 If you prefer or are constrained to using the older servlet or JSP 
 specifications, then use Tomcat version 6.0.36.

No, Tomcat 7 supports the older specs as well.  No reason to use Tomcat 6 at 
this point.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY 
MATERIAL and is thus for use only by the intended recipient. If you received 
this in error, please contact the sender and delete the e-mail and its 
attachments from all computers.


-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org




-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org



Re: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Mark Thomas
On 30/04/2013 17:14, Carrillo, Dan wrote:
 Then documentation needs to be updated
 http://tomcat.apache.org/whichversion.html

No it doesn't.

The Servlet specifications are backwards compatible so, for example, any
Servlet 2.5 app will run on container that implements Servlet 3.0 such
as Tomcat 7.

Mark

 
 
 -Original Message-
 From: Caldarale, Charles R [mailto:chuck.caldar...@unisys.com] 
 Sent: Tuesday, April 30, 2013 8:57 AM
 To: Tomcat Users List
 Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0
 
 From: Carrillo, Dan [mailto:dcarri...@idanalytics.com]
 Subject: RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0
 
 If you want to utilize Servlet spec 3.0 or JSP spec 2.2 then use 
 Tomcat version 7.0.39.  This is compatible with Java 1.6.
 
 If you prefer or are constrained to using the older servlet or JSP 
 specifications, then use Tomcat version 6.0.36.
 
 No, Tomcat 7 supports the older specs as well.  No reason to use Tomcat 6 at 
 this point.
 
  - Chuck
 
 
 THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY 
 MATERIAL and is thus for use only by the intended recipient. If you received 
 this in error, please contact the sender and delete the e-mail and its 
 attachments from all computers.
 
 
 -
 To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
 For additional commands, e-mail: users-h...@tomcat.apache.org
 
 
 
 
 -
 To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
 For additional commands, e-mail: users-h...@tomcat.apache.org
 


-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org



RE: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

2013-04-30 Thread Caldarale, Charles R
 From: Dariusz Dolecki [mailto:dariusz.dole...@gmail.com] 
 Subject: Re: Which version of tomcat for apache 2.2.24 and JDK 1.6.0

Don't top post.

 Does it matter if we are using AJP connector?

No.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY 
MATERIAL and is thus for use only by the intended recipient. If you received 
this in error, please contact the sender and delete the e-mail and its 
attachments from all computers.


-
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org