Re: Validating in form returns always error but textfield has a value

2011-10-18 Thread rawe
Here are some code snippets. When clicking on a tree node I validate the form.. If no errors I update the form component models. The class MyMutableTreeNode extends DefaultMutableTreeNode. Each node references an own panel component. getNodeEntryDetail() returns the panel referenced by the node.

Re: Efficiency of 1.5 MountMapper weighted/matching algorithm

2011-10-18 Thread Erik van Oosten
I realize it may not be a hotspot but, intuitively at least, it sounds like your new caching improvement will help reduce CPU load. It should also reduce the workload of the garbage collector by not having, in the above example, 2800 objects allocated and then dereferenced with every page

wicket + jasper reports

2011-10-18 Thread Paul Szulc
Hi, my recent webapp is supposed to generate PDF reports. Because I don't know much about JasperReports, I've outsourced the functionality to a freelancer. He created separate module (jar) that provides desired functionality. Part of maven structure of my project looks like this: - ngo |

RE: wicket + jasper reports

2011-10-18 Thread Wilhelmsen Tor Iver
URL resource = getClass().getClassLoader().getResource(DOCOferta.jrxml); An aside: This is the equivalent to getClass().getResource(/DOCOferta.jrxml); i.e. a resource on the classpath root. Check your projects to see if the file is in the correct location to be included at runtime.

Re: wicket + jasper reports

2011-10-18 Thread Paul Szulc
Ok, to clarify: 1. DOCOferta.jrxml lies inside ngo.pdf module folder src/main/resources 2. When I run generate method inside of ngo.pdf modules all works fine, but when I try to use it in webapplication (separate, differnet maven module) I get this NPE. I know the issue is because probably

Re: wicket + jasper reports

2011-10-18 Thread Paul Szulc
yeah, ok, my bad resources where under src/main/resource not src/main/resource*s* * * thx Tor

Re: Using SubmitLink as a tree node ?

2011-10-18 Thread Martin Grigorov
You need to override org.apache.wicket.markup.html.tree.BaseTree.newLink(String, ILinkCallback) On Tue, Oct 18, 2011 at 10:00 AM, rawe ralph.wey...@dachser.com wrote: I'm using a Tree with LinkTree components for the nodes. Is there a way to use SubmitLink instead of LinkTree components for the

Re: Validating in form returns always error but textfield has a value

2011-10-18 Thread manuelbarzi
at which point are you pretending to call validate, what logic fires it? see no code if defaultFormProcessing is true (default) on submitting components, then all validation and form updating is executed automatically. On Tue, Oct 18, 2011 at 8:52 AM, rawe ralph.wey...@dachser.com wrote: Here

Re: Using SubmitLink as a tree node ?

2011-10-18 Thread rawe
Hi Martin, thank you! This was the helping hint! works perfectly! Ralph -- View this message in context: http://apache-wicket.1842946.n4.nabble.com/Using-SubmitLink-as-a-tree-node-tp3914407p3914691.html Sent from the Users forum mailing list archive at Nabble.com.

Re: Validating in form returns always error but textfield has a value

2011-10-18 Thread rawe
Yes, I'm using the form default setting (DefaultFormProcessing = true). But for form processing you have to use a submit button or a SubmitLink or you can call the form validate() method programmatic. See also Wicket API Doc of Form: (

Re: Validating in form returns always error but textfield has a value

2011-10-18 Thread manuelbarzi
See also Wicket API Doc of Form: ( http://wicket.apache.org/apidocs/1.4/org/apache/wicket/markup/html/form/Form.html Wicket API Doc ) /If you want you can call validate() to execute form validation, hasError() to find out whether validate() resulted in validation errors, and

Re: Validating in form returns always error but textfield has a value

2011-10-18 Thread rawe
Got it ! Thank you! Ralph -- View this message in context: http://apache-wicket.1842946.n4.nabble.com/Validating-in-form-returns-always-error-but-textfield-has-a-value-tp3912361p3914841.html Sent from the Users forum mailing list archive at Nabble.com.

wicket - form debug

2011-10-18 Thread nazeem
I have simple case, which worked for me in another project but failed in the current one. Both use same set of libraries. I am doing something wrong, could not trace it down. Please help to debug this. I am designing a reusable form textfield component, which will have provision to show feedback

Nested Forms in 1.4.x - order of calling onSubmit

2011-10-18 Thread Bruno Borges
After playing with Nested Forms in WIcket 1.4.18, I found out that the onSubmit method of these forms is called at the end of the process. If a parent form has a button and this button is submited, its onSubmit method is called before anything. Then, parent form's onSubmit method is called. Then,

UrlRenderer [1.5]: Why is absolute of relative Url ending with a [dot]?

2011-10-18 Thread Per Newgro
Hi, i try to add a sitemap for my app. When i add the loc node in sitemap-url this way to my ListView code item.add(new Label(locNode, RequestCycle.get().getUrlRenderer().renderFullUrl(Url.parse(String.valueOf(urlFor(homePageClass, homePageParameters)); /code the generate xml looks

Weblogic deployment

2011-10-18 Thread Wolfgang Schreiner
Hi all, I am having problems deploying my web application on Weblogic 10.3.2. Everything works fine on 10.3.5 but I am running into the following exception when deploying on 10.3.2 - see below How can I resolve this? And when and where is wicket.properties loaded? Can't find references in

Re: UrlRenderer [1.5]: Why is absolute of relative Url ending with a [dot]?

2011-10-18 Thread manuelbarzi
Component.urlFor - calls - RequestCycle.urlFor - calls - UrlRenderer.renderUrl - if relative url, calls - UrlRenderer.renderRelativeUrl - which may append / return the misterious . . On Tue, Oct 18, 2011 at 2:50 PM, Per Newgro per.new...@gmx.ch wrote: Hi, i try to add a sitemap for my app.

Re: UrlRenderer [1.5]: Why is absolute of relative Url ending with a [dot]?

2011-10-18 Thread Per Newgro
Thanks for reply manuel, sorry for being not clear on this. While debugging i've found that already. But why is this . be set. That's not clear to me. Per Am 18.10.2011 15:47, schrieb manuelbarzi: Component.urlFor - calls - RequestCycle.urlFor - calls - UrlRenderer.renderUrl - if relative

Re: Weblogic deployment

2011-10-18 Thread manuelbarzi
Application.initializeComponents() may you try running wl in non-blank-spaces path? (zip:C:/Documents[16 charater here])...) . On Tue, Oct 18, 2011 at 3:31 PM, Wolfgang Schreiner wschrei...@csc.com wrote: Hi all, I am having problems deploying my web application on Weblogic 10.3.2.

Re: UrlRenderer [1.5]: Why is absolute of relative Url ending with a [dot]?

2011-10-18 Thread manuelbarzi
Matej, Igor? . On Tue, Oct 18, 2011 at 3:57 PM, Per Newgro per.new...@gmx.ch wrote: Thanks for reply manuel, sorry for being not clear on this. While debugging i've found that already. But why is this . be set. That's not clear to me. Per Am 18.10.2011 15:47, schrieb manuelbarzi:

Re: Weblogic deployment

2011-10-18 Thread jcgarciam
Weblogic doesn't play well with classpath resouces having space on its path. As Manuel, suggest try putting your domain in a path without space on it On Tue, Oct 18, 2011 at 11:02 AM, manuelbarzi [via Apache Wicket] ml-node+s1842946n3915471...@n4.nabble.com wrote:

Re: UrlRenderer [1.5]: Why is absolute of relative Url ending with a [dot]?

2011-10-18 Thread Martin Grigorov
IIRC the '.' is set temporarily to overcome a bug in Tomcat(and Jetty?!) which produced bad URL after passing http://localhost to HttpServletResponse.encodeURL() This bug has been fixed in 7.0.16, I think. This code has been added by Peter Ertl, so maybe he remembers better the case. On Tue, Oct

Re: Can not locate error messages from property messages

2011-10-18 Thread Erinc Arikan
Sorry for the late response, It does generate the valid key bundle, there should be something I am missing and overlooking since I just started a clean quickstart and it's also happening there. Erinc On Sat, Oct 15, 2011 at 9:05 AM, Andrea Del Bene an.delb...@gmail.comwrote: Hi, are you sure

Re: Weblogic deployment

2011-10-18 Thread Wolfgang Schreiner
Ok thanks, will give it a go Is there another workaround? Like removing wicket.properties and calling the Initializers from code? From: jcgarciam jcgarc...@gmail.com To: users@wicket.apache.org Date: 18.10.2011 16:26 Subject: Re: Weblogic deployment Weblogic doesn't play well with

Re: page expire / ajax error

2011-10-18 Thread Martin Grigorov
For the problem with 1.5 see WICKET-4116. Will be better in 1.5.2 On Tue, Oct 18, 2011 at 5:35 PM, Jonathan Locke jonathan.lo...@gmail.com wrote: I have two wicket applications running on the same box (my laptop, for example) with one on port 8880 and one on port 8881. Each application does

Re: Weblogic deployment

2011-10-18 Thread jcgarciam
Nop, this is a bug in the container no within the wicket framework. On Tue, Oct 18, 2011 at 11:44 AM, Wolfgang Schreiner [via Apache Wicket] ml-node+s1842946n3915620...@n4.nabble.com wrote: Ok thanks, will give it a go Is there another workaround? Like removing wicket.properties and calling

Re: page expire / ajax error

2011-10-18 Thread manuelbarzi
it seems to be tomcat mixing/sharing user/session data/resources somewhere and reseting it on second start :? . On Tue, Oct 18, 2011 at 4:35 PM, Jonathan Locke jonathan.lo...@gmail.com wrote: I have two wicket applications running on the same box (my laptop, for example) with one on port 8880

Re: wicket - form debug

2011-10-18 Thread Igor Vaynberg
myFormBorder.add(ftf); this line adds the textfield outside the form, so your form stays empty thus validation passes. -igor On Tue, Oct 18, 2011 at 5:00 AM, nazeem md.naz...@gmail.com wrote: I have simple case, which worked for me in another project but failed in the current one. Both use

Re: wicket - form debug

2011-10-18 Thread nazeem
Thanks Igor. I was mislead by seeing the generated html. In the rendered html the textfield is inside, but from the code, I am adding the MyTextField to the border and not to the form. In MyFormBorder I am adding the contents to the form, will this not solve ? form.add(getBodyContainer()); I

Re: wicket - form debug

2011-10-18 Thread Igor Vaynberg
myFormBorder.getBodyContainer().add(ftf) should do it. -igor On Tue, Oct 18, 2011 at 8:40 AM, nazeem md.naz...@gmail.com wrote: Thanks Igor. I was mislead by seeing the generated html. In the rendered html the textfield is inside, but from the code, I am adding the MyTextField to the border

Re: wicket - form debug

2011-10-18 Thread nazeem
Wow ! it worked. Thank you so much. So i did not understand the borders well.. :) I am developing a component library on wicket and I enjoy doing it, and it gives great productivity boost to the developers and helps to get the look and feel consistent. Thank you so much for the support. -- View

Re: wicket + jasper reports

2011-10-18 Thread Jim Pinkham
Paul, I am doing something very similar - I'd be interested to know more about how you got this working - here is what I've got that works for now, but I'm not real happy with it: In my report forms, I have buttons like this: (details about params omitted - nothing fancy there)

RE: Efficiency of 1.5 MountMapper weighted/matching algorithm

2011-10-18 Thread Chris Colman
I will definitely try to get up to speed with WicketTester and see if it's possible for it to run in a multi threaded way that can simulate a massive load test. Any suggestions as to which profiler to use while it's running? Would need to be one that can measure the CPU usage of the GC, not just

Re: page expire / ajax error

2011-10-18 Thread Jonathan Locke
Yes, that's exactly it. Some weirdness with Tomcat sessions colliding (although not resetting). I have a workaround for now... I simply mount each application on a separate path and it all works. Strange. -- View this message in context:

Re: wicket + jasper reports

2011-10-18 Thread jchappelle
I believe the way I have done this in the past is by putting the report file at the root of the WEB-INF/classes folder when building the war file. I don't use maven so I can't advise you on where to place the files in your project before deployment. I hope this helps. Josh -- View this message