Re: @RequireHttps - forms misbehaving

2010-03-22 Thread gilberthuph
I'm having the same problem and I can reproduce this in a quickstart, I just want to check before creating a jira: - In my quickstart I'm calling setRedirect(true) within the form submit button's onSubmit(), is this the correct place to force a redirect? - SignInPage has the @RequireHttps

Re: @RequireHttps - forms misbehaving

2009-12-22 Thread VGJ
My redirect method isn't overriding anything, it's just there to provide a shortcut to an external redirect, should I need it. Could it still be doing some damage, somehow? I was using bookmarkable pages just before switching to Hybrids, at the same time I started using @RequireHttps, so they

Re: @RequireHttps - forms misbehaving

2009-12-21 Thread bht
VGJ, You might have discovered a limitation of the system or a bug. As I wrote, I would recommend you make a testcase with all distracting detail removed and submit it as a jira issue, then post a link to the the issue here. I understand your frustration, but I think the above would be the best

Re: @RequireHttps - forms misbehaving

2009-12-21 Thread VGJ
I see, I guess I misunderstood you. I wasn't able to reproduce it in a separate test application, however. It has to be encountering something in this particular application that is causing a problem. I just can't figure out what that might be, exactly. I would submit the small test case I

Re: @RequireHttps - forms misbehaving

2009-12-21 Thread VGJ
Jason...excellent! setResponsePage(UserAccount.class) did the trick! Thanks! Using setRedirect(true) didn't have any effect however. I had to redirect to the page class rather than a new instance of it. This works for me right now...but what happens when I'd like to pass parameters into the

Re: @RequireHttps - forms misbehaving

2009-12-21 Thread Jason Lea
yay! But it is odd if setRedirect(true) didn't work when using a page instance. I wonder if the there is an issue with HybridUrlCodingStrategy and RequireHttps... can you mount the page you redirect to using a simple bookmarkable page and see if it works? I also noticed you have a method

Re: @RequireHttps - forms misbehaving

2009-12-20 Thread bht
Hi VGJ, If, as you say you can reproduce this in your storefront app no matter where you use it then you may want to reduce this to a testcase and create a jira issue from it. You are already writing that you can reproduce it and consequently it would be only a matter of removing all distracting

Re: @RequireHttps - forms misbehaving

2009-12-18 Thread Igor Vaynberg
can you recreate in a quickstart? -igor On Fri, Dec 18, 2009 at 7:56 AM, VGJ zambi...@gmail.com wrote: I'm now using @RequireHttps to switch to https on certain pages but it's not quite working right. In our storefront app, I'm switching to https at the point in the checkout process where

Re: @RequireHttps - forms misbehaving

2009-12-18 Thread VGJ
I'll create one and post it, if I can. -v On Fri, Dec 18, 2009 at 9:21 AM, Igor Vaynberg igor.vaynb...@gmail.comwrote: can you recreate in a quickstart? -igor On Fri, Dec 18, 2009 at 7:56 AM, VGJ zambi...@gmail.com wrote: I'm now using @RequireHttps to switch to https on certain pages

Re: @RequireHttps - forms misbehaving

2009-12-18 Thread VGJ
I was unable to re-create it in a simple web app w/ a few pages. However, no matter where I use it in my storefront app, it happens. It's very strange because it starts a page late. I put the annotation on the User Account page, yet it doesn't switch to https until I reach the *following* page