Re: [xwiki-users] Problems with links

2010-03-18 Thread ccoreggioli
2.3M1 is ok! claudio -- View this message in context: http://n2.nabble.com/Problems-with-links-tp4435123p4755346.html Sent from the XWiki- Users mailing list archive at Nabble.com. ___ users mailing list users@xwiki.org

[xwiki-users] Problem with broken link in header sections

2010-03-18 Thread ccoreggioli
Hello, i found a problem when in a header section there is a broken link. for example, in wiki editor mode i have: = SOME TITLE [[Some Broken Link]] = if i click Preview button the page is shown correctly. Changing the editor to WYSIWYG mode, when i click Preview button the following error

Re: [xwiki-users] Livetable

2010-03-18 Thread Frantisek Kall
Hello Jerome, thanks for answer. Now we have 2.2.M1 version running. The name of class is XWiki.SLMClass and template name is XWiki.SLMTemplate. We will upgrade to 2.2.2 soon, then I will try livetable again and I will write you if problem persist. Regards Frantisek -- View this message

Re: [xwiki-users] xEclipse

2010-03-18 Thread Florin Ciubotaru
Hi Omar, On 3/17/2010 9:19 PM, Omar Morales wrote: Hello Florin, I want to develop the hypertext stand alone, to load it next in a xWiki server. The reason for this is that, unfortunately I travel a lot, and I don't want to depend on inet connections to a server to develop the hypertext.

Re: [xwiki-users] Xwiki integration with SMS

2010-03-18 Thread Jeremie BOUSQUET
Hi, I think biggest issue will be to have someone to send the SMSs to (SMSC or SME). If you have such connection sending SMS Text should not be a big issue. In your case I believe you will have to take care of the encoding of special characters (7bit alphabet or UTF-16, but with only 70

Re: [xwiki-users] Problem with broken link in header sections

2010-03-18 Thread Thomas Mortagne
Could you comment if you are able to reproduce it all the time and detail it. I will reopen the issue. On Thu, Mar 18, 2010 at 10:04, ccoreggioli claudio.coreggi...@gidi.it wrote: Hello, i found a problem when in a header section there is a broken link. for example, in wiki editor mode i

[xwiki-users] PDF Export, includechilds and toc issues

2010-03-18 Thread Jeremie BOUSQUET
Hi, Some little issues I think I found on PDF Export (XE 2.2.1/MySQL5): - if using includechilds=n, and if child pages refer to parent as xwiki:Space.Page (which seems to be default now), they are not included. To get included, I had to change parent value in child to Space.Page only - Table Of

Re: [xwiki-users] Registration

2010-03-18 Thread stefan bachert
Hi Caleb, I do not understand why the view is not allowed. XWiki.Preference is/was explicitly allowed for view of XWikiAllGroup. I checked the Registration document and detected, that there is a createUser call. I found out, that there is an overload version of this call allowing to specify

Re: [xwiki-users] Problem with broken link in header sections

2010-03-18 Thread ccoreggioli
Hi Thomas, yes, it always happen. if I complete the link (for instance [[LinkURL]]) this problem disappear. I'm using xwiki entreprise 2.2.2 on tomcat 5.5.20 running with jdk 1.6.0_18. SO is linux Centos 5. on client side i tested it on win xp sp3 (last update) with IE7, FF 3.5.8, Chrome and

Re: [xwiki-users] Livetable

2010-03-18 Thread Frantisek Kall
Hello Jerome We upgraded XWiki to version 2.2.2. I didn't change anything but now I have opposite problem, no one document is in livetable. I have TestClass in TestSpace, template is TestTemplate in TestSpace. Class properties for TestClass ID (ID: Number) Servis Name (Name: String) Servis

Re: [xwiki-users] Problem with broken link in header sections

2010-03-18 Thread Thomas Mortagne
On Thu, Mar 18, 2010 at 12:37, ccoreggioli claudio.coreggi...@gidi.it wrote: Hi Thomas, yes, it always happen. if I complete the link (for instance [[LinkURL]]) this problem disappear. I'm using xwiki entreprise 2.2.2 on tomcat 5.5.20 running with jdk 1.6.0_18. SO is linux Centos 5. on

Re: [xwiki-users] Livetable

2010-03-18 Thread Jeremie BOUSQUET
There is an issue in 2.2 when sorting on a non-string property (see http://jira.xwiki.org/jira/browse/XWIKI-4973). As you don't specify a sort column, I think it sorts on first column wich is a Number, and so livetable is empty ... Waiting for 2.2.3 release, you can try this workaround : add

[xwiki-users] Manage Watchlist page.

2010-03-18 Thread Sophie Alexandre
Hello, I have first configured (and used without problem) my Watchlist when I was working with XWiki Enterprise 2.0. In this case when I clicked on the menu : WATCH - MANAGE YOUR WATCHLIST, I am redirected to this page : http://myDomain/xwiki/bin/view/XWiki/WatchListManager and I can really

Re: [xwiki-users] Manage Watchlist page.

2010-03-18 Thread Guillaume Lerouge
Hi Sophie, On Thu, Mar 18, 2010 at 2:47 PM, Sophie Alexandre sophie.alexan...@loria.fr wrote: Hello, I have first configured (and used without problem) my Watchlist when I was working with XWiki Enterprise 2.0. In this case when I clicked on the menu : WATCH - MANAGE YOUR WATCHLIST, I am

Re: [xwiki-users] Problem with broken link in header sections

2010-03-18 Thread ccoreggioli
sorry, i misunderstood... :) now i posted it on jira... thanks a lot, claudio -- View this message in context: http://n2.nabble.com/Problem-with-broken-link-in-header-sections-tp4755395p4756634.html Sent from the XWiki- Users mailing list archive at Nabble.com.

Re: [xwiki-users] Problem with broken link in header sections

2010-03-18 Thread Thomas Mortagne
On Thu, Mar 18, 2010 at 15:01, ccoreggioli claudio.coreggi...@gidi.it wrote: sorry, i misunderstood... :) now i posted it on jira... Thanks thanks a lot, claudio -- View this message in context: http://n2.nabble.com/Problem-with-broken-link-in-header-sections-tp4755395p4756634.html

Re: [xwiki-users] Manage Watchlist page.

2010-03-18 Thread Sophie Alexandre
Yes, I have do that : importing xwiki-enterprise-wiki-2.2.2 but as soon as I import my own data from file.xar to rretrieve my site the trouble occurs. S.A Le jeudi 18 mars 2010 à 14:54 +0100, Guillaume Lerouge a écrit : Hi Sophie, On Thu, Mar 18, 2010 at 2:47 PM, Sophie Alexandre

Re: [xwiki-users] xEclipse

2010-03-18 Thread Marius Dumitru Florea
Florin Ciubotaru wrote: Hi Omar, On 3/17/2010 9:19 PM, Omar Morales wrote: Hello Florin, I want to develop the hypertext stand alone, to load it next in a xWiki server. The reason for this is that, unfortunately I travel a lot, and I don't want to depend on inet connections to a server

Re: [xwiki-users] Manage Watchlist page.

2010-03-18 Thread Guillaume Lerouge
Hi, On Thu, Mar 18, 2010 at 3:18 PM, Sophie Alexandre sophie.alexan...@loria.fr wrote: Yes, I have do that : importing xwiki-enterprise-wiki-2.2.2 but as soon as I import my own data from file.xar to rretrieve my site the trouble occurs. When you import your own XAR, make sure NOT TO

Re: [xwiki-users] Manage Watchlist page.

2010-03-18 Thread Jean-Vincent Drean
The usual way to upgrade a xwiki instance is to keep the data in place and to import the new xar inside the wiki, see http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation#HUpgradingwikidocuments If you really wish to export your data as XAR then you must import it first, then import

[xwiki-users] xwiki Macro using groovy

2010-03-18 Thread Alaina
Hi everyone, Thanks so much for your quick answer on my previous question. I am trying to write a bibliography/cite macro (I am happy to share once it dies something useful). I am writing the macro in a wiki page and I am using groovy as scripting language. I would like to have access to the