Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jeremie BOUSQUET
Hello, {{velocity}} #set($logger = $services.logging.getLogger(My script)) $logger.info(foobar) {{/velocity}} This is exactly what is on the page linked by Vincent, just with a more similar look to your own sample. My script is just an informative name of the logger you create. You could use

Re: [xwiki-users] Can I send email to a group with xwiki 6?

2014-08-26 Thread Shaddy
Pascal BASTIEN pbasnews-xwiki@... writes: Thxs. I will use a loop then. Hello everybody, I'm currently working on the same issue. Can you show how you managed to send an email to a group of users?? Thank you very much. Daniele.

Re: [xwiki-users] Can I send email to a group with xwiki 6?

2014-08-26 Thread Pascal BASTIEN
Sorry I didn't take the time to writing this loop (another priorities on Xwiki) But I hope  to find some time to writing it... :-) De : Shaddy danigagli...@gmail.com À : users@xwiki.org Envoyé le : Mardi 26 août 2014 10h02 Objet : Re: [xwiki-users] Can I send

[xwiki-users] black cross to delete with flamingo ?

2014-08-26 Thread Pascal BASTIEN
Hello, Is it normal the black color of this icon to delete attachment of page with flamingo skin? http://snag.gy/TKzPp.jpg Generaly, to delete it is a red cross (a black cross is to select,), no? an oversight? Thxs pascal B ___ users mailing list

Re: [xwiki-users] black cross to delete with flamingo ?

2014-08-26 Thread Pascal BASTIEN
NB: with 6.2 SNAPSHOT (20/08) De : Pascal BASTIEN pbasnews-xw...@yahoo.fr À : XWiki Users users@xwiki.org Envoyé le : Mardi 26 août 2014 10h34 Objet : [xwiki-users] black cross to delete with flamingo ? Hello, Is it normal the black color of this icon to

[xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread WEKU
Hi guys, I have installed a new Wiki on a 2012 R2 Windows Server. I also installed the standard Wiki. Now i have a Problem with PDF attachments. When I upload the PDF attachment and make a Link with the Admin User the PDF is opened in browser when klicking the link or directly the attachment

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread DeepakEra
Have you tried PDF Macro ? Upload PDF document and edit page source you want to view your PDF like this, {{pdfviewer file=Link to PDF attachment/}} -- View this message in context:

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread WEKU
Thanks for your reply, no thats not that what i meant. Normally a PDF is opened by a browser plugin and shown in a browser page. But when the PDF is uploaded by a normal User and not by the Admin user the file isnt opened in a browser page. It shouldnt be opened inside the wiki page. -- View

Re: [xwiki-users] need help with getContext

2014-08-26 Thread Pascal BASTIEN
Silly on me: of course include fix doesn't work. it doesn't matter I will find another fix later. Thxs. De : Pascal BASTIEN pbasnews-xw...@yahoo.fr À : XWiki Users users@xwiki.org Envoyé le : Lundi 25 août 2014 16h10 Objet : Re: [xwiki-users] need help with

Re: [xwiki-users] black cross to delete with flamingo ?

2014-08-26 Thread Ecaterina Moraru (Valica)
In Colibri it was red. In Flamingo all icons of the same type should share the same color (monochromatic). IMO it's not an oversight, since we are going for a less colorful approach with Flamingo. Thanks, Caty On Tue, Aug 26, 2014 at 11:36 AM, Pascal BASTIEN pbasnews-xw...@yahoo.fr wrote: NB:

Re: [xwiki-users] black cross to delete with flamingo ?

2014-08-26 Thread Pascal BASTIEN
Yes but you let red cross to delete on some places, like AdministrationUsers Groups Groups (http://localhost:8080/xwiki/bin/admin/XWiki/XWikiPreferences?editor=globaladminsection=Groups#|t=groupstablep=1l=10wiki=local) by example. De : Ecaterina Moraru

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread Clemens Klein-Robbenhaar
On 08/26/2014 10:47 AM, WEKU wrote: Hi guys, I have installed a new Wiki on a 2012 R2 Windows Server. I also installed the standard Wiki. Now i have a Problem with PDF attachments. When I upload the PDF attachment and make a Link with the Admin User the PDF is opened in browser when

Re: [xwiki-users] black cross to delete with flamingo ?

2014-08-26 Thread Ecaterina Moraru (Valica)
http://jira.xwiki.org/browse/XWIKI-10755 Thanks, Caty On Tue, Aug 26, 2014 at 12:50 PM, Pascal BASTIEN pbasnews-xw...@yahoo.fr wrote: Yes but you let red cross to delete on some places, like AdministrationUsers Groups Groups (

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread WEKU
I think were on a good way. The opened PDF is Type: application/pdf and the downloaded pdf is shown as Type: text/plain. What do i have to do, that all pdfs are Type: application/pdf? Thanks in advance! -- View this message in context:

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread Clemens Klein-Robbenhaar
On 08/26/2014 01:23 PM, WEKU wrote: I think were on a good way. The opened PDF is Type: application/pdf and the downloaded pdf is shown as Type: text/plain. What do i have to do, that all pdfs are Type: application/pdf? slowly my memory came back: it is a feature ;)

Re: [xwiki-users] PDF Attachment is downloaded instead of opened in Browser

2014-08-26 Thread WEKU
Hi Clemens, thank you very much. It worked. I activated the attachment.download.blacklist feature and now every PDF is opened in a browser window. Thats ok for me. Best regards -- View this message in context:

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jason Clemons
That's why I said forgive my ignorance in my previous email :) I was thrown off by defining the informative name. Is that a persistent value once defined? Or is just something that gets added to the log entry? On Aug 25, 2014, at 11:28 PM, Jeremie BOUSQUET jeremie.bousq...@gmail.com wrote:

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jason Clemons
So sorry, but one more question..since I'm new to Xwiki, and all of it's underlying architecture (I'm a .net guy) I'm sure this is something that I'm doing wrong, but I figured I'd ask. When I copy and paste the code you provided below into a page (in the source section) the page and the

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jeremie BOUSQUET
2014-08-26 16:39 GMT+02:00 Jason Clemons jason.clem...@live.com: That's why I said forgive my ignorance in my previous email :) I was thrown off by defining the informative name. Is that a persistent value once defined? Or is just something that gets added to the log entry? That's

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Valdis Vītoliņš
You need to say that following will be velocity script with opening/closing tags like this: {{velocity}} #set($logger = $services.logging.getLogger(My script)) $logger.info(foobar) {{/velocity}} Valdis ___ users mailing list users@xwiki.org

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jason Clemons
I have exactly that in my page, that's why I was confused :) On Aug 26, 2014, at 8:17 AM, Valdis Vītoliņš valdis.vitol...@odo.lv wrote: You need to say that following will be velocity script with opening/closing tags like this: {{velocity}} #set($logger = $services.logging.getLogger(My

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jeremie BOUSQUET
2014-08-26 17:08 GMT+02:00 Jason Clemons jason.clem...@live.com: So sorry, but one more question..since I'm new to Xwiki, and all of it's underlying architecture (I'm a .net guy) I'm sure this is something that I'm doing wrong, but I figured I'd ask. When I copy and paste the code you

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jason Clemons
This is something new to 6.1? I'm not on 6.1 yet, maybe that's why? On Aug 26, 2014, at 8:21 AM, Jeremie BOUSQUET jeremie.bousq...@gmail.com wrote: 2014-08-26 17:08 GMT+02:00 Jason Clemons jason.clem...@live.com: So sorry, but one more question..since I'm new to Xwiki, and all of it's

Re: [xwiki-users] Write to logger using Velocity

2014-08-26 Thread Jeremie BOUSQUET
Yes, quoting Vincent Massol above : Since XWiki 6.1 ;-) See also here: http://extensions.xwiki.org/xwiki/bin/view/Extension/Logging+Module#HGetaLoggerfromscript So for 6.1, I think there must be a solution but right now I don't know ... 2014-08-26 17:25 GMT+02:00 Jason Clemons