Re: [xwiki-users] Access value of property on same page

2014-11-12 Thread Marius Dumitru Florea
You're probably looking for $doc.updateObjectFromRequest('myspace.myclass') See

[xwiki-users] Not able to read attachments from server thread

2014-11-12 Thread Stefan Bernsdorf
Hi, I created a Macro in xwiki. In this macro a server process is started that tries to read attachments. For this, I created a XWikiCOntext to access the Wiki. This is the code: XWikiStubContextProvider prov=Utils.getComponent(XWikiStubContextProvider.class);

Re: [xwiki-users] Not able to read attachments from server thread

2014-11-12 Thread Thomas Mortagne
Could you copy the complete error, you should have a more detailed cause. On Wed, Nov 12, 2014 at 11:39 AM, Stefan Bernsdorf gruener.heinr...@web.de wrote: Hi, I created a Macro in xwiki. In this macro a server process is started that tries to read attachments. For this, I created a

Re: [xwiki-users] Not able to read attachments from server thread

2014-11-12 Thread Marius Dumitru Florea
Btw, you should take a look at the Job Module http://extensions.xwiki.org/xwiki/bin/view/Extension/Job+Module which provides a clean way to perform, in a background thread, tasks that access the XWiki model. Hope this helps, Marius On Wed, Nov 12, 2014 at 2:45 PM, Thomas Mortagne

Re: [xwiki-users] Upgrade 0.9.840 version to Latest version.

2014-11-12 Thread Manjunath Kashyap
Hi Vincent, Thanks for the reply and all the links. Yes as you *said *the current wiki is very very old. These are the links which i went through for the upgrade process. As depicted in the documentation(links), the Xwiki pages needs to be exported into a XRAR format to re-import them into the

[xwiki-users] [ANN] XWiki 6.3 released

2014-11-12 Thread Guillaume Louis-Marie Delhumeau
The XWiki development team is proud to announce the availability of XWiki 6.3. This release provides a great stabilization of the Flamingo Skin, and includes new themes and some improvements to manage them. It also contains a new mail API and module to replace the old mailsender plugin, a new

Re: [xwiki-users] Upgrade 0.9.840 version to Latest version.

2014-11-12 Thread Jeremie BOUSQUET
Hi, 2014-11-12 14:33 GMT+01:00 Manjunath Kashyap mail2manjukash...@gmail.com: Hi Vincent, Thanks for the reply and all the links. Yes as you *said *the current wiki is very very old. These are the links which i went through for the upgrade process. As depicted in the documentation(links),

[xwiki-users] Using HTML5 File Upload Widget for non-XWiki files

2014-11-12 Thread Bryn Jeffries
I'd like to upload files through a custom File Upload servlet that runs from the same Tomcat server but is not part of XWiki. This servlet does some file processing and stores the file in a separate area away from the XWiki attachments, and it's possible that eventually this servlet might be

[xwiki-users] permissions issue

2014-11-12 Thread Paul Pinkerton (ACLCO)
I am struggling with a page permissions issue. What am I doing wrong here? I have done this before, but it doesn't seem to be working this time. I have a SPACE that is only available to a specific GROUP. That seems to be working just fine. I have a PAGE in that SPACE that I only want a

Re: [xwiki-users] Not able to read attachments from server thread

2014-11-12 Thread Stefan Bernsdorf
Hi, the Job Module looks promising, however this is the stack: CONTENT IS NUL!com.xpn.xwiki.XWikiException: Error number 3231 in 3: Exc eption while loading attachment myseedfile.dgn of document microtest_oto.Templates_Test-Stefan at

Re: [xwiki-users] localization string missing - xe.blog.code.title

2014-11-12 Thread Ricardo.Julio.Rodriguez.Fernandez
Hi! Please, allow me to top post: it will be easier to summarise. Clemens's answer did the trick. Here you'll see how my Blog.BlogSheet looked before editing its title as Clemens suggested... http://goo.gl/k4T6ub Now, after an upgrade to 6.4 and after editing the title it looks good...