Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread Maxime Sinclair
Hi Dan, Embedding links in a diagram is not available in the current PlantUML Macro but it could be possible using the Image Map service (as described on this page http://plantuml.com/server.html ). The drawback would be to define links as absolute URLs and not in the xwiki simpler syntax.

Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread Maxime Sinclair
Hi Thomas, What do you mean by "to depend on net.sf.plantuml:plantuml" ? Is it a new feature ? Can you give me a few pointer on this subject ? Thanks. Maxime On 12/04/2016 15:53, Thomas Mortagne wrote: Note that a cleaner solution would be to refactor PlantUML Macro extension to depend on

Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread dullfig
I think there is a problem with how xwiki renders pages. Because the SVG macro can't show embedded links either. I have been trying it out, you can include links in the svg devinition, but they just don't render as links. XWiki seems to just convert everything to dumb images. Dan -- View this

[xwiki-users] hyperlinks in SVG images

2016-04-12 Thread dullfig
Hello: hyperlinks don't work in svg images. I have the following example on a page: but you cannot click on it. You should be able to. Does it have something to do with how xwiki renders images? or is the problem in the svg macro? I really would like this to work. Dan -- View this

Re: [xwiki-users] DocumentDeletingEvent

2016-04-12 Thread Vincent Massol
Hi Peter, > On 05 Apr 2016, at 19:28, Peter Huisman wrote: > > From the XWiki source code, I see there is a difference in passing a document > to the evenmanager: > > The DocumentDeletingEvent is passing a “new > XWikiDocument(doc.getDocumentReference())" > The

Re: [xwiki-users] hyperlinks in SVG images

2016-04-12 Thread Daniel Ullfig
oops. the example doesn't come out in the email; here it is. {{svg width="640" height="480"}} http://www.w3.org/2000/svg; xmlns:svg="http://www.w3.org/2000/svg; xmlns:xlink="http://www.w3.org/1999/xlink;> Layer 1 transform="rotate(-21.6429 404.099 249.6)" stroke-width="5" stroke="#00"

Re: [xwiki-users] hyperlinks in SVG images

2016-04-12 Thread Daniel Ullfig
ok, so I'm doing some testing, and the following code gives you a clickable box, if placed inside a xwiki document. {{html wiki="false" clean="false"}} http://www.w3.org/2000/svg; xmlns:xlink="http://www.w3.org/1999/xlink;> http://dc1/bin/view/Main/; target="_top"> {{/html}}

Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread Vincent Massol
Hi, > On 11 Apr 2016, at 23:47, dullfig wrote: > > Hello: > > I want to upload the latest PlantUML.jar server as an attachment to the > PlantUMLMacroGClass page. The current PlantUML.jar is outdated, and is > already an attachment to this page. > > I press the "chose

Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread Thomas Mortagne
Note that a cleaner solution would be to refactor PlantUML Macro extension to depend on net.sourceforge.plantuml:plantuml extension instead of embedding it. Extension will simply put the plantuml jar in the classloader and it would be automatically available to the PlantUML Macro (no need to load

Re: [xwiki-users] Uploading .jar as attachment to page fails

2016-04-12 Thread dullfig
ok, so it turns out the problem was not just jar files, but any large files. I had to mess around with the max_allowed_packet variable in mysql, plus increase the size of uploads in xwiki, which at first I didn’t realize is given in BYTES. so now I can upload large files. I wanted a local