[xwiki-users] Parsing external JSON with Velocity in XWiki

2016-04-19 Thread Mahomed Hussein
Hi I started off on something I thought would be simple, but my limited knowledge is failing me and Google isn’t bringing up anything useful. Basically, I have a url that returns JSON content (for the sake of this example – assume the url is https://status.com/api/status.json) The content

Re: [xwiki-users] Can't make a groovy macro work

2016-04-19 Thread Vincent Massol
still can’t help you without the error… -Vincent > On 15 Apr 2016, at 18:55, Daniel Ullfig wrote: > > here is the code I'm working on; it's in a page called PlantUMLMacroGClass; > I'm modifying plantuml to output svg instead of png so it is clickable and > can contain

Re: [xwiki-users] Ansible playbook for installing XWiki Enterprise

2016-04-19 Thread Vincent Massol
Hi Andrea, This is a great contribution! Thanks! I’ve added it to http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation#HOtherInstallationMethods Waiting for even more contributions now ;) I’m curious: what do you like the most in XWiki? Thanks -Vincent > On 07 Apr 2016, at

Re: [xwiki-users] What would be a simple way to display a Masonry view in XWiki ?

2016-04-19 Thread Vincent Massol
> On 14 Apr 2016, at 21:59, Thibaut DEVERAUX wrote: > > Hi, > > Thanks ! Totem seems pretty intersting. > Theorically "ImageOnTop" should do the job. > > I created a section with ImageOnTop display. > In "edit elements of this section" / advanced, I added the

Re: [xwiki-users] Disabling javascript in HTML macro

2016-04-19 Thread Vincent Massol
Hi Andrew, > On 18 Apr 2016, at 19:32, Andrew Kuang wrote: > > Thank you for the responses, Vincent and Marius. > > After playing around with the HTML macro, I came across a potential > solution. It appears that all the XWiki-created pages reside within certain > spaces

Re: [xwiki-users] Parsing external JSON with Velocity in XWiki

2016-04-19 Thread Vincent Massol
> On 19 Apr 2016, at 19:18, Mahomed Hussein wrote: > > Hi > > I started off on something I thought would be simple, but my limited > knowledge is failing me and Google isn’t bringing up anything useful. > > Basically, I have a url that returns JSON content (for the

[xwiki-users] Moving AppWithinMinutes app to another location in the same wiki

2016-04-19 Thread Ryszard Łach
Hi. Is there a way to migrate (xwiki 7.2.4) an application created via AppWithinMInutes to another node in the same wiki tree, with all documents created by the app ? The easy way (move parent document with all children) doesn't seem to work. TIA, R.

Re: [xwiki-users] Moving AppWithinMinutes app to another location in the same wiki

2016-04-19 Thread Vincent Massol
Hi, > On 19 Apr 2016, at 22:02, Ryszard Łach wrote: > > Hi. > > Is there a way to migrate (xwiki 7.2.4) an application created via > AppWithinMInutes to another node in the same wiki tree, with all documents > created by the app ? The easy way (move parent document

[xwiki-users] General XWiki Exception after Tomcat Startup (Component manager has not been initialized before lookup)

2016-04-19 Thread matti
Hello, our XWiki installation isn't running anymore. After restarting Tomcat, there is always the stacktrace below. No change to content has been made, afaik. Any help is most welcome. The XWiki version is 5.2.1 according to the "version.properties" file. Matthias -- View this message in

[xwiki-users] Printable Index

2016-04-19 Thread dullfig
So I am writing this Quality Manual using XWiki; The main manual is one page, has many headings, and a TOC. There's also a bunch of supporting procedures, all linked to one another, and the system is really slick The problem is, we sometimes need to hand out hard printed copies of the manual to

Re: [xwiki-users] XWiki Button with ActionListener?

2016-04-19 Thread Rochlin Oleg
Thanks for the link. it´s still not really helping me with my question. ) -Ursprüngliche Nachricht- Von: Mohamed Boussaa [mailto:mohamed.bous...@xwiki.com] Gesendet: Montag, 18. April 2016 17:41 An: XWiki Users Betreff: Re: [xwiki-users] XWiki Button with ActionListener? Hello, Here

Re: [xwiki-users] Advice on building simple app

2016-04-19 Thread Marius Dumitru Florea
On Mon, Apr 18, 2016 at 7:21 PM, Ecaterina Moraru (Valica) < vali...@gmail.com> wrote: > Hi Tim, > > Have you tried using AWM? > > http://extensions.xwiki.org/xwiki/bin/view/Extension/App+Within+Minutes+Application > > > After you have the structure you can try to modify the Sheet page and add >

Re: [xwiki-users] XWiki Button with ActionListener?

2016-04-19 Thread Eduard Moraru
Hi Oleg, This is not really an XWiki-related question as much as it`s a standard HTML form one. You want to create a simple (1 button) HTML form that submits to the current page and the result is to be handled with velocity to check if the request has the button clicked and execute some other

[xwiki-users] ACE Editor cannot be loaded after migration to version 7.4.2

2016-04-19 Thread Sebastian Schabbach
Dear all, a view weeks ago we updated our xwiki application from version 6.2 to version 7.4, but since upgrading the wiki we encountered several problems with the ACE editor. The problems causes unexpected behaviors (loading the article content in the ace editor will never end due to

Re: [xwiki-users] xWiki RESTful/HTTP Connection

2016-04-19 Thread Thomas Mortagne
That's because what Mohamed is referring is the old (3.x) HttpClient and not the new (4.x) one which have different (sometime very different) API. The main issue you have is probably the fact that XWiki does not ask the client for credential by default since anonymous access is valid. That means

Re: [xwiki-users] Configuring LDAP.

2016-04-19 Thread Thomas Mortagne
When you don't understand what is wrong the best is usually to enable debug log to follow step by step what the authenticator is doing. See http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Authentication#HEnableLDAPdebuglog. On Mon, Apr 18, 2016 at 9:28 PM,