Re: [xwiki-users] Link with Open in new Window not working (again?)

2009-09-09 Thread Anca Luca
Trevor Russ wrote: I am inserting a link to a web page using WYSIWYG and Wiki Syntax 2.0, and have checked Open in new Window. It inserts rel= instead of target= into the source and does not open in a new page. I found it's the same problem described by this bug, which was closed as

Re: [xwiki-users] Link with Open in new Window not working (again?)

2009-09-09 Thread Anca Luca
Jean-Vincent Drean wrote: Actually XWIKI-3641 wasn't fixing anything on the 1.9 branch because of some missing JS var. It's now fixed, thanks for the report. Actually it was fixed, from M2 to 1.9.2, I reintroduced it in this commit

Re: [xwiki-users] [xwiki-devs] [UX] Edit Buttons Order

2009-09-14 Thread Anca Luca
Ecaterina Valica wrote: Hi, Because we want to make a standard from vertical-aligned form, this means the buttons should be left-ordered with the most important action first. This should be changed also in Toucan and Albatross skin, not only just in Colibri. I just noticed the change made

Re: [xwiki-users] Problem of locks when saving pages, after migration to 2.0.rc1.

2009-09-14 Thread Anca Luca
Hi there, it seems to be the issue http://jira.xwiki.org/jira/browse/XE-489 you're hitting here, which was fixed for the installers by http://jira.xwiki.org/jira/browse/XE-490 , but now you hit it on the war. To fix it, go to your hibernate.cfg.xml and add mapping

Re: [xwiki-users] xwiki 2.0 - GWT WYSIWYG - file links

2009-10-09 Thread Anca Luca
Hi Hel, On 10/09/2009 11:08 AM, hel-o wrote: Hi, we got links to the Filesystem like [file://server/sharepoint_layouts$file:/server/sharepoint_layouts$] they are converted correctly to syntax 2.0 and are working there too

Re: [xwiki-users] [Vote] New colors for the XWiki.org websites

2009-10-13 Thread Anca Luca
+0.5 for [2] +0.5 for [3] On 10/13/2009 04:58 PM, Guillaume Lerouge wrote: Hi XWikiers, after a long discussion on the dev list we eventually narrowed down the new colors for XWiki.org to 3 options (see http://markmail.org/thread/2b3io6wv4yzr324q for details): - [1] Pastel:

Re: [xwiki-users] [Proposal] Governance for xwiki.org

2009-12-15 Thread Anca Luca
a place for these companies to be visible too. I hope that all our contributors but also users of the XWiki Open Source software will find this proposal acceptable and I welcome any feedback on it. That would be a +1. Thanks, Anca Luca XWiki committer, XWiki SAS employed developer. Thanks

Re: [xwiki-users] set variables on request

2009-12-16 Thread Anca Luca
Hi Bubulina, On 12/16/2009 11:40 AM, Bubulina wrote: Hello, I know that i can get value from a request like this: #set($name= $request.getParameter('name')) Now, shouldn't i be able to put variables on request so i can use in the html page? something like this: #set($var =

Re: [xwiki-users] distinct select divs from page

2009-12-16 Thread Anca Luca
On 12/16/2009 05:00 PM, Bubulina wrote: hey My question is purely theoretically. If i create a table and eachtd from it has an id, can i extract the information from atd by an id? This is in a xwiki page. table tr tdname/td /tr tr td id=testbla bla/td /tr /table

Re: [xwiki-users] Link to a file in local file system

2010-01-10 Thread Anca Luca
Hi Ziggy, Actually that doesn't work on ff because it's a security issue: it cannot let web pages just access random files on your computer (see http://kb.mozillazine.org/Links_to_local_pages_don%27t_work ). It's a security issue in general, not only for firefox, that's why linking to a file

Re: [xwiki-users] Private RSS feeds with basic auth not working

2010-01-13 Thread Anca Luca
Hi Kevin, It seems to be http://jira.xwiki.org/jira/browse/XWIKI-4695 that you're hitting, which you can fix by applying these modifications http://fisheye2.atlassian.com/viewrep/xwiki/platform/web/trunk/standard/src/main/webapp/templates/accessdenied.vm?r1=21942r2=25903 on

Re: [xwiki-users] Bad HQL queries

2010-01-18 Thread Anca Luca
Hi Flavius, On 01/17/2010 05:23 PM, Flavius Olaru wrote: Hi, I've done a installation on my localhost (Windows XP machine) of XE 2.1.1, Tomcat 6 and MySQL 5.1. After this i wrote a bad hql query and executed it which brought MySQL to spyke the CPU usage to 100% and even more rendering both

Re: [xwiki-users] Bad HQL queries

2010-01-18 Thread Anca Luca
Hi Sergiu, On 01/18/2010 02:06 PM, Sergiu Dumitriu wrote: On 01/18/2010 10:15 AM, Anca Luca wrote: Hi Flavius, On 01/17/2010 05:23 PM, Flavius Olaru wrote: Hi, I've done a installation on my localhost (Windows XP machine) of XE 2.1.1, Tomcat 6 and MySQL 5.1. After this i wrote a bad hql

Re: [xwiki-users] Is it possible to programatically change xwiki class properties

2010-01-25 Thread Anca Luca
hi Radek, On 01/25/2010 07:21 AM, Radek Rekas wrote: Hi, I am trying to change the values for a static list field in a wiki class programatically but so far I have only figured out how to display them. Is it possible to set class property values for static list fields programatically

Re: [xwiki-users] [xwiki-devs] [ANN] XWiki Enterprise 2.2 Milestone 2 Released

2010-01-27 Thread Anca Luca
Hi Thomas, all On 01/27/2010 08:36 PM, Thomas Mortagne wrote: The XWiki development team is pleased to announce the release of XWiki Enterprise 2.2 Milestone 2. Go grab it at http://www.xwiki.org/xwiki/bin/view/Main/Download Changes from 2.2 Milestone 1: * New improved registration

Re: [xwiki-users] Installations-problems on Debian, MySQL Tomcat (Deployment as single war)

2010-03-05 Thread Anca Luca
Hi Gregor, On 03/05/2010 01:17 PM, 2smart4u wrote: Hi guys, first off, thanks to VBincent, Anca Sdumitriu for pointing me to this list via Twitter My current environment: Using CATALINA_BASE: /home/tomcat/www Using CATALINA_HOME: /home/tomcat/www Using CATALINA_TMPDIR:

Re: [xwiki-users] Platform module - javascript.vm template from header is ignored

2010-03-15 Thread Anca Luca
Hi Bogdan, On 03/15/2010 04:25 PM, Bogdan Flueras wrote: Hello, Ive build and deployed the WAR from *platform* module. When I access the xwiki, the main page displays in the header some velocity syntax instead of what it should normally output. See the attachement pls.(I ve modified a

Re: [xwiki-users] Unable to upload jpg into Blog

2010-03-23 Thread Anca Luca
Hi Sergiu, Gregor, On 03/23/2010 03:55 PM, Sergiu Dumitriu wrote: On 03/23/2010 02:50 PM, 2smart4u wrote: Some more investigation: Within my list of recent changes, the picture-attachment is listed. Clicking on that link, the picture gets loaded. However, when I view the Blog and

Re: [xwiki-users] Annotations feature not working

2010-03-26 Thread Anca Luca
Hi Dilipkumar, I'm pretty sure I know where the issue is coming from (because your wiki is running at localhost:8080/molecule/ and the annotations code is trying to connect to localhost:8080/xwiki/) and I'll fix it asap. Can you please report this issue on

Re: [xwiki-users] [xwiki-devs] XWiki Logo Challenge

2010-03-31 Thread Anca Luca
Hi all, It is very hard to choose (and by this all participants should understand that all proposals are noteworthy). I also took into account following criteria: can I draw it with a pencil on a paper in a single color and it would still be recognized? As a result my votes and comments go

Re: [xwiki-users] [xwiki-devs] XWiki Logo Challenge, Round 2

2010-04-12 Thread Anca Luca
hard to choose, but it's gonna be +1 for 16B (slanted Ws). Happy hacking, Anca On 04/08/2010 07:02 PM, Sergiu Dumitriu wrote: Hello XWiki Community, We're still looking for the new XWiki.org logo. First of all, many thanks to all those who submitted their ideas (

Re: [xwiki-users] [ANN] XWiki Enterprise and XWiki Enterprise Manager 2.2.6 Released

2010-04-28 Thread Anca Luca
Congrats for the release, Denis! On 04/28/2010 03:33 PM, Denis Gervalle wrote: The XWiki development team is pleased to announce the release of XWiki Enterprise and XWiki Enterprise Manager 2.2.6. Go grab it at http://www.xwiki.org/xwiki/bin/view/Main/Download This is a bug fix release for

Re: [xwiki-users] Annotation feature

2010-05-25 Thread Anca Luca
Hi Angelo, On 05/24/2010 11:19 AM, AngeloG wrote: Hi, I have a this question: is there a way to make annotation feature work in a virtual wiki environment? Suppose new xem 2.3 installation for the farm (and in the main wiki the annotations work!) and a number of wikis with xe 2.3 xar files

Re: [xwiki-users] Annotation feature

2010-05-25 Thread Anca Luca
Hi Angelo, see below. On 05/25/2010 03:10 PM, AngeloG wrote: Anca Luca wrote: Hi Angelo, On 05/24/2010 11:19 AM, AngeloG wrote: Hi, I have a this question: is there a way to make annotation feature work in a virtual wiki environment? Suppose new xem 2.3 installation for the farm

Re: [xwiki-users] Annotation feature

2010-05-26 Thread Anca Luca
FYI, this is the issue I created for this problem: http://jira.xwiki.org/jira/browse/XAANNOTATIONS-21 Anca On 05/26/2010 11:22 AM, AngeloG wrote: Anca Luca wrote: Hi Angelo, see below. On 05/25/2010 03:10 PM, AngeloG wrote: Anca Luca wrote: Hi Luca, here are some details: fresh

Re: [xwiki-users] Error when installing Watch over an existing xwiki

2010-05-31 Thread Anca Luca
Hi Tom, xwiki watch 1.0 is only working with xwiki 1.4 or 1.5. In order to install an xwiki watch on xwiki 2.3, you'd need to build a 1.1 snapshot from sources, instructions are here

Re: [xwiki-users] How to add a panel to all the spaces using the Panel Wizard

2010-06-03 Thread Anca Luca
Hi Abel, You'd need to go to administer wiki (global menu top left) and then from the admin page choose panel wizard. That should set it wiki-wide. Have fun, Anca On 06/03/2010 04:21 AM, Abel Solórzano Astorga wrote: Hi, I want to add a panel to my xwiki site using the Panel Wizard. I can

Re: [xwiki-users] Annotation not working

2010-06-09 Thread Anca Luca
Hi Eric, On 06/09/2010 03:17 PM, JUIN, Eric wrote: Hi, I try to configure annotations on cop-1.myxwiki.org without success The annotation menu doesn't appear on that wiki Can you help please. I've read somewhere in the forum that it is related to developer right on a space but I don't

[xwiki-users] [VOTE] [wysiwyg] Displaying the macro id and searching for it in the wysiwyg insert macro wizard

2010-06-23 Thread Anca Luca
Hi all, I wanted to insert a macro in a page using the wysiwyg and I noticed that the macros filter (search box on top right) is not searching in the macro ids. For example, if I try to write toc I get no results. If I write table I get the Table of contents macro as result, since its name

Re: [xwiki-users] Error when building new xwiki component

2010-07-06 Thread Anca Luca
Hi Marine, On 07/06/2010 02:55 PM, Marine JULIAN wrote: Hello, To understand how the creation of xwiki component works, I followed the tutorial at http://platform.xwiki.org/xwiki/bin/view/DevGuide/WritingComponents and I previously read the Building XWiki from sources page (

Re: [xwiki-users] Error when building new xwiki component

2010-07-06 Thread Anca Luca
Hi Marine, On 07/06/2010 02:55 PM, Marine JULIAN wrote: Hello, To understand how the creation of xwiki component works, I followed the tutorial at http://platform.xwiki.org/xwiki/bin/view/DevGuide/WritingComponents and I previously read the Building XWiki from sources page (

Re: [xwiki-users] can't start xwiki

2010-08-09 Thread Anca Luca
Hi Susan, On 08/09/2010 05:09 PM, Caleb James DeLisle wrote: Something is definitly wrong but that isn't enough information to go on. Can you start xwiki from the command line? Open the command line and navigate to where the xwiki exe file is and run it. Maybe it will output something

Re: [xwiki-users] Problem installing xwatch.xar

2010-08-12 Thread Anca Luca
Hi Simer, On 08/12/2010 09:51 AM, Simerpreet Singh wrote: Hi, I am installing xwiki-application-invitation-1.1.xar in my xwiki .it I doubt there is any WatchCode.GWT in that .xar. I would assume you're trying to install xwiki-watch-1.1-milestone-1.xar. Is this accurate? or it's another

Re: [xwiki-users] Problem building code for xwatch with maven

2010-08-17 Thread Anca Luca
Hi Simer, On 08/16/2010 01:28 PM, Simerpreet Singh wrote: Hi, Iam using xwiki 2.3.1 and trying to install xwatch on in.According to instructions given in http://watch.xwiki.org/xwiki/bin/view/Main/Installation#HBuildingandinstallinganXWikiWatchSnapshotoveranexistingXWikiEnterprise Setup

Re: [xwiki-users] Space drop down list on Main.WebSearch page shows all the XWiki spaces ignoring user rights

2010-08-21 Thread Anca Luca
Hi Abel, what do you understand by space that the user is not allowed to view? You can have rights at space level, indeed, but you can also have rights at page level, which override the rights at space level and can grant a user view access to a page in a space he normally does not have view

Re: [xwiki-users] Problem Building xwatch with maven

2010-08-24 Thread Anca Luca
not workingproperly (Raluca Stavro) 3. RES: Calendar Application on XE 2.4 not workingproperly (Ramon Gomes Brand?o - SERINT) 4. Re: Problem building code for xwatch with maven (Anca Luca) 5. Re: RES: Calendar Application on XE 2.4 not workingproperly

Re: [xwiki-users] Linking an image to larger image or floating the image on top??

2010-09-03 Thread Anca Luca
On 09/03/2010 03:31 PM, Kaya Saman wrote: Hi, I've attached 2 images to a page of which I want to have the smaller image (web image) displayed on the actual page but when clicked on a larger image appearing. This is actually quite simple: edit page in wysiwyg go to image menu, say insert

Re: [xwiki-users] Linking an image to larger image or floating the image on top??

2010-09-03 Thread Anca Luca
On 09/03/2010 03:54 PM, Anca Luca wrote: On 09/03/2010 03:31 PM, Kaya Saman wrote: Hi, I've attached 2 images to a page of which I want to have the smaller image (web image) displayed on the actual page but when clicked on a larger image appearing. This is actually quite simple: edit

Re: [xwiki-users] Linking an image to larger image or floating the image on top??

2010-09-03 Thread Anca Luca
15:59, Anca Luca wrote: On 09/03/2010 03:54 PM, Anca Luca wrote: On 09/03/2010 03:31 PM, Kaya Saman wrote: Hi, I've attached 2 images to a page of which I want to have the smaller image (web image) displayed on the actual page but when clicked on a larger image appearing

Re: [xwiki-users] [Vote] Resize images on the server side to reduce page loading time

2010-09-08 Thread Anca Luca
On 09/08/2010 11:40 PM, Marius Dumitru Florea wrote: Hi devs, Currently the image plugin [1] allows us to create image thumbnails by specifying the image width and/or height in the query string of the image attachment download URL: /xwiki/bin/download/Spage/Page/image.jpg?width=100 I

Re: [xwiki-users] [Vote] Resize images on the server side to reduce page loading time

2010-09-10 Thread Anca Luca
On 09/09/2010 10:25 AM, Marius Dumitru Florea wrote: On 09/09/2010 12:08 AM, Anca Luca wrote: On 09/08/2010 11:40 PM, Marius Dumitru Florea wrote: Hi devs, Currently the image plugin [1] allows us to create image thumbnails by specifying the image width and/or height in the query string

Re: [xwiki-users] Localize watchlists

2010-10-04 Thread Anca Luca
Le 4 oct. 2010 à 07:43, [Ricardo Rodriguez] eBioTIC. ricardo.rodrig...@ebiotic.ne t a écrit : Hi! Gerritjan Koekkoek wrote: Hi, I'm getting complaints of users that they can not read what is in their watchlist notifications. We have a multi language setup; in this case my visitors

Re: [xwiki-users] [myxwiki] new wiki request (Vincent Massol)

2010-10-08 Thread Anca Luca
On 09/30/2010 01:03 PM, Bogdan Flueras wrote: -- Message: 1 Date: Wed, 29 Sep 2010 12:13:29 +0200 From: Vincent Massolvinc...@massol.net Subject: Re: [xwiki-users] [myxwiki] new wiki request To: XWiki Usersusers@xwiki.org

Re: [xwiki-users] accessing to document running macro

2010-10-26 Thread Anca Luca
On 10/26/2010 12:28 PM, Marius Dumitru Florea wrote: Hi Arnaud, On 10/26/2010 12:38 PM, Arnaud bourree wrote: Hello, I develop a macro which display object attached to the current page. Here summary of my code: {{goovy}} def topic = doc.getObject(ActivityReport.TopicClass,

Re: [xwiki-users] Annotations extension didn't work

2011-02-22 Thread Anca Luca
Hi Erica, On 22 févr. 2011, at 21:01, Erica Usui erica87...@gmail.com wrote: Hello! Annotations extension didn't work. It is not translation even though I put AnnotationCode.Translations in XWiki.Preferences. It shouldn't need it. What xwiki are you running? Which version? Do you

Re: [xwiki-users] Annotations extension didn't work

2011-02-23 Thread Anca Luca
On 02/23/2011 01:32 PM, Erica Usui wrote: I'm running XWiki Enterprise 2.2.1.27354. The annotations were introduced in XWiki 2.3, so I guess you installed the annotations application described at http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application . Which version

Re: [xwiki-users] Add Progress info on document

2011-06-15 Thread Anca Luca
On Thu, 2011-06-09 at 11:56 +0200, MAI QUOC, Phuong-Tram wrote: Thank you Luca I'll try this But i might need help because i'm new to XWiki + velocity... and although what you said does sound very simple and basic... i just don't know how to get it... - defining the class that hold the

Re: [xwiki-users] Activity Dashboard doesn't work

2011-06-16 Thread Anca Luca
This issue was fixed in the mean time http://jira.xwiki.org/jira/browse/XE-922 and it's possible that it causes your problem. Now let's try to see what's happening: 1/ did you upgrade the entire .xar or only some pages? 2/ what page do you look at and see no activity? Main.WebHome or other? 3/

Re: [xwiki-users] Evaluate request parameters

2011-07-17 Thread Anca Luca
Hi Gerritjan, see below On 07/16/2011 03:58 PM, Gerritjan Koekkoek wrote: Hi, I would like to conditional show pages based on request parameter But i'm struggling with the fact if there is not a request parameter {{velocity}} #if($request.cntryCode != es) {{include

Re: [xwiki-users] Annotations are not shown on pages

2011-08-01 Thread Anca Luca
Hi Cristoph, On 08/01/2011 05:49 PM, Schreiber, Dr. Christoph (privat) wrote: Hi, I am trying to configure our xwiki to show the annotations on every page. I have configured the Administration - Applications - Annotations like this: Annotations are activated (X) Ja Nein Except for the

Re: [xwiki-users] Developing Discussion Forum using xwiki?

2012-04-18 Thread Anca Luca
On 04/18/2012 08:13 AM, mohit gupta wrote: Seems great. *But looks one severity1 exist here. whenever i post any message i get below warning* Warning This request contains an invalid authentication information. This might happen in the following situations: - You left the editor open in

Re: [xwiki-users] Having a blog on the wiki front page

2012-05-07 Thread Anca Luca
On 05/07/2012 07:59 AM, Hamster wrote: On a side note (using XWiki 3.5) XWiki uses a lot of drag and drop features, but the layout of components in the DashBoard is by setting row and column numbers! That's just brutal :-) Hi Hamster, I fail to understand what brutal means in this context,

Re: [xwiki-users] Having a blog on the wiki front page

2012-05-07 Thread Anca Luca
On 05/07/2012 03:03 PM, Guillaume Lerouge wrote: Hi Hamster, On Mon, May 7, 2012 at 2:13 PM, Hamsterteun...@hotmail.com wrote: Hi Anca, If you want to modify the main page, you can use Edit -- Objects to change the layout/contents, right? Editing is documented at

Re: [xwiki-users] Panels backward compatibility

2012-06-13 Thread Anca Luca
On 06/13/2012 01:52 PM, Raluca Stavro wrote: Hi, On Wed, Jun 13, 2012 at 2:15 PM, Vincent Massolvinc...@massol.net wrote: On Jun 13, 2012, at 12:44 PM, Raluca Stavro wrote: I'm resending this mail by using the right subject pattern. Hello, I am trying to upgrade an old XEM to 3.5.1. In

Re: [xwiki-users] Panels backward compatibility

2012-06-14 Thread Anca Luca
On 06/13/2012 06:09 PM, Sergiu Dumitriu wrote: On 06/13/2012 09:17 AM, Vincent Massol wrote: On Jun 13, 2012, at 2:52 PM, Anca Luca wrote: On 06/13/2012 02:44 PM, Vincent Massol wrote: On Jun 13, 2012, at 2:39 PM, Anca Luca wrote: On 06/13/2012 01:52 PM, Raluca Stavro wrote: Hi, On Wed

Re: [xwiki-users] Can you hide WebHome from page lists?

2012-12-28 Thread Anca Luca
Hi xRichard, depending on which XWiki version you're using, the option might not be available at all or might not be available for the type of user you're using. The issue adding the UI to mark documents as hidden in the document information panel is http://jira.xwiki.org/browse/XWIKI-7568

Re: [xwiki-users] EventListener automatic start - is it possible?

2013-02-08 Thread Anca Luca
On 02/08/2013 05:40 PM, Vincent Massol wrote: On Jan 17, 2013, at 11:52 AM, Eugen Colesnicovecolesni...@gmail.com wrote: Thanks, but unfortunately this is so hard for me ... (I am not a programmer). Maybe in the future, will be possible to introduce this in class structure? Yes, what I'd

Re: [xwiki-users] XWiki Publication Workflow Application

2014-05-13 Thread Anca Luca
Hello, So first you need to make sure you installed both the API and the application (the APi is a dependency of the application, so if you install with Extension Manager that will just work, if you install manually you need to handle it yourself). Then, once installed, create at least one

Re: [xwiki-users] Annotations

2014-05-13 Thread Anca Luca
Hello Michael, there is a chance that this is a standard issue, but it also depends on what you're trying to do. The main limitation of the annotations is that they are not working on content rendered with the {{html}} macro, because they are rendered at the XDOM Level and the html macro is not

Re: [xwiki-users] Not able to create xwiki pages from PDF document

2016-06-08 Thread Anca Luca
Hello, The pdf macro that you installed is for visualizing the pdf documents, not for transforming them into a wiki page (importing their content as a wiki page). That's what most of the extensions that you find under the "pdf" search do. For importing a pdf document as a wiki page, you should

[xwiki-users] [contrib][workflow-publication] Release of Publication Workflow application version 1.5.1

2016-05-31 Thread Anca Luca
Hello all, A new version of the application workflow was released this morning, version 1.5.1. It contains only one fix compared to 1.5, issue http://jira.xwiki.org/browse/XAWORKFLOW-16 , which is actually quite particular (we might want to revert this modification at some point in a future