Re: [xwiki-users] when creating a page via REST, it doesn't appear in children (via REST)

2016-10-25 Thread dmd3eorg
Filed http://jira.xwiki.org/browse/XWIKI-13830 , thanks. -- View this message in context: http://xwiki.475771.n2.nabble.com/when-creating-a-page-via-REST-it-doesn-t-appear-in-children-via-REST-tp7601706p7601711.html Sent from the XWiki- Users mailing list archive at Nabble.com.

[xwiki-users] GUIDs or other stable names for pages, via REST

2016-10-21 Thread dmd3eorg
Is there a way to get the GUID for a page, or some other stable name which will not change for a page if that page is renamed -- via the REST API? Thanks! -- View this message in context: http://xwiki.475771.n2.nabble.com/GUIDs-or-other-stable-names-for-pages-via-REST-tp7601683.html Sent

Re: [xwiki-users] when creating a page via REST, it doesn't appear in children (via REST)

2016-10-24 Thread dmd3eorg
So, it looks like I need to *explicitly* set mywiki.foo.bar.WebHome xwiki:mywiki.foo.bar.WebHome in the XML I *PUT*. However, this appears to still be a bug or at least an inconsistency, because the web version of ?viewer=children shows the page even if this was not done, whereas REST's

[xwiki-users] when creating a page via REST, it doesn't appear in children (via REST)

2016-10-24 Thread dmd3eorg
I have a Wiki called 'mywiki', and I've created some nested pages/spaces within the web interface. I use REST to walk the children tree recursively, and I see the following fullNames: mywiki.foo.WebHome mywiki.foo.bar.WebHome mywiki.foo.kitten.WebHome mywiki.dog.WebHome Now, I create a page via

Re: [xwiki-users] when creating a page via REST, it doesn't appear in children (via REST)

2016-10-24 Thread dmd3eorg
A clue: Pages created via REST don't seem to get their parent set. The question then is - why does xwiki/bin/view/.?viewer=children show pages that do not have that page set as parent? How can I either (a) set parent correctly, or (b) get the same view that the web version gets, but via