Re: [xwiki-users] Multilingual problem in 1.8.1

2009-04-14 Thread Vincent Massol

On Apr 13, 2009, at 10:35 PM, Sergiu Dumitriu wrote:

 jerem wrote:
 Hi,
 I just installed XWiki 1.8.1 in ubuntu 8.10 / tomcat 6 / MySQL 5.0.  
 My ubuntu is in english language (administration / language  
 support / default language), so is my LANG environment variable.
 In my prefs by default I have language en, multilingual no. If  
 I select yes for multilingual, page content is in english but all  
 menus switch to french. Adding only en to the list of languages  
 doesn't change this.
 How can I have my wiki fully english by default with multilingual  
 set and default language en ?

 The wiki uses by default the language specified by the browser in a  
 HTTP
 header. Normally, you should be able to switch to English by following
 the language link from the right side of the header (there should a  
 link
 called En), or by appending ?language=en to the URL. You can also  
 force
 the wiki to display only in one of the languages specified in the
 settings, by changing xwiki/WEB-INF/xwiki.cfg. Search the
 Internationalization section, and you should see two commented
 settings: xwiki.language.preferDefault, and
 xwiki.language.forceSupported. Uncomment them and set them to 1.

See
* http://platform.xwiki.org/xwiki/bin/view/Features/I18N
* 
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#HLanguagesettings

Thanks
-Vincent

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Multilingual problem in 1.8.1

2009-04-14 Thread jerem

Thanks for your answers, ... :)
... and sorry for not having searched enough before posting ... :(
-- 
View this message in context: 
http://n2.nabble.com/Multilingual-problem-in-1.8.1-tp2627477p2631854.html
Sent from the XWiki- Users mailing list archive at Nabble.com.

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Multilingual problem in 1.8.1

2009-04-13 Thread Sergiu Dumitriu
jerem wrote:
 Hi,
 I just installed XWiki 1.8.1 in ubuntu 8.10 / tomcat 6 / MySQL 5.0. My ubuntu 
 is in english language (administration / language support / default 
 language), so is my LANG environment variable.
 In my prefs by default I have language en, multilingual no. If I select 
 yes for multilingual, page content is in english but all menus switch to 
 french. Adding only en to the list of languages doesn't change this.
 How can I have my wiki fully english by default with multilingual set and 
 default language en ?

The wiki uses by default the language specified by the browser in a HTTP 
header. Normally, you should be able to switch to English by following 
the language link from the right side of the header (there should a link 
called En), or by appending ?language=en to the URL. You can also force 
the wiki to display only in one of the languages specified in the 
settings, by changing xwiki/WEB-INF/xwiki.cfg. Search the 
Internationalization section, and you should see two commented 
settings: xwiki.language.preferDefault, and 
xwiki.language.forceSupported. Uncomment them and set them to 1.

-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users