Re: [xwiki-users] Slash in the page title

2016-09-08 Thread Bruno


Sorry. I had just set up Apache with "AllowEncodedSlashes On" instead of 
"AllowEncodedSlashes NoDecode".
Tomcat is configured with 
"org.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true".


Thanks a lot !

Signature mails
_

Bruno Joffredo

Ecole Centrale de Nantes

Centre de Ressources Informatiques - Bur. D019

1 rue de la Noë

BP 92101

F-44321 Nantes cedex 3

Tél. 02.40.37.68.06
Mail : bruno.joffr...@ec-nantes.fr 
_


Le 08/09/2016 à 14:45, Bruno a écrit :


Thanks Vincent.

I have configured Tomcat and Apache to accept the conversion of the 
slash in the URL.

It seems to work. I can find my page and view it.

But when I create a page with a slash in the title, XWiki tree create 
a new space that contains the page.


Example :
-
Page title : "TEST with a / in the title"
Tree :
TEST with a
 |- TEST with a / in the title

Have you ever encountered this?

Signature mails
_

Bruno Joffredo

Ecole Centrale de Nantes

Centre de Ressources Informatiques - Bur. D019

1 rue de la Noë

BP 92101

F-44321 Nantes cedex 3

Tél. 02.40.37.68.06
Mail : bruno.joffr...@ec-nantes.fr 
_


Le 08/09/2016 à 12:00, Vincent Massol a écrit :

Hi,


On 08 Sep 2016, at 11:57, Bruno  wrote:


Hello,

In XWiki Enterprise 7.4.2, a user has put a slash in the title of 
his page.

XWiki has well transformed the URL to :
/xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie%2Fagenda+sous+androïd/ 



But Apache receives the following URL when I click on link in XWiki :
/xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie/agenda+sous+androïd 



Then I get the error "The requested URL was not found on this server."

So, I can't access this page or delete it.

Is there a solution ?
You’re most likely using a buggy tomcat version (which one are you 
using?).


See the warning on 
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationTomcat


Thanks
-Vincent


Thanks !

Signature mails
_

Bruno Joffredo

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Slash in the page title

2016-09-08 Thread Bruno


Thanks Vincent.

I have configured Tomcat and Apache to accept the conversion of the 
slash in the URL.

It seems to work. I can find my page and view it.

But when I create a page with a slash in the title, XWiki tree create a 
new space that contains the page.


Example :
-
Page title : "TEST with a / in the title"
Tree :
TEST with a
 |- TEST with a / in the title

Have you ever encountered this?

Signature mails
_

Bruno Joffredo

Ecole Centrale de Nantes

Centre de Ressources Informatiques - Bur. D019

1 rue de la Noë

BP 92101

F-44321 Nantes cedex 3

Tél. 02.40.37.68.06
Mail : bruno.joffr...@ec-nantes.fr 
_


Le 08/09/2016 à 12:00, Vincent Massol a écrit :

Hi,


On 08 Sep 2016, at 11:57, Bruno  wrote:


Hello,

In XWiki Enterprise 7.4.2, a user has put a slash in the title of his page.
XWiki has well transformed the URL to :
/xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie%2Fagenda+sous+androïd/

But Apache receives the following URL when I click on link in XWiki :
/xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie/agenda+sous+androïd

Then I get the error "The requested URL was not found on this server."

So, I can't access this page or delete it.

Is there a solution ?

You’re most likely using a buggy tomcat version (which one are you using?).

See the warning on 
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationTomcat

Thanks
-Vincent


Thanks !

Signature mails
_

Bruno Joffredo

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] Slash in the page title

2016-09-08 Thread Vincent Massol
Hi,

> On 08 Sep 2016, at 11:57, Bruno  wrote:
> 
> 
> Hello,
> 
> In XWiki Enterprise 7.4.2, a user has put a slash in the title of his page.
> XWiki has well transformed the URL to :
> /xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie%2Fagenda+sous+androïd/
> 
> But Apache receives the following URL when I click on link in XWiki :
> /xwiki/bin/view/Le+wiki+du+CRI/Support+aux+Utilisateurs/Synchronisation+messagerie/agenda+sous+androïd
> 
> Then I get the error "The requested URL was not found on this server."
> 
> So, I can't access this page or delete it.
> 
> Is there a solution ?

You’re most likely using a buggy tomcat version (which one are you using?).

See the warning on 
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationTomcat

Thanks
-Vincent

> 
> Thanks !
> 
> Signature mails
> _
> 
> Bruno Joffredo
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users