Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Vincent Massol


On Nov 22, 2007, at 3:51 PM, goldring, richard wrote:


Thanks. I'll try the newer version of Eclipse.


you can also use the RCP application of course.

-Vincent

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]  
Behalf Of Vincent Massol

Sent: 22 November 2007 14:50
To: XWiki Users
Subject: Re: [xwiki-users] XEclipse installation


On Nov 22, 2007, at 3:03 PM, goldring, richard wrote:


Hi,

I installed XEclipse following the instructions by unzipping into  
the plugin directory and then run up Eclipse and showed the XWiki  
explorer and got the following error ...


org.eclipse.ui.forms.FormToolkit.decorateFormHeading(Lorg/eclipse/ 
ui/forms.widgets/Form;)V


Anyone know what's wrong and how to get it running?


I guess you need Eclipse Europa Fall or above if you want to use it  
as a plugin.


Fabio, isn't that a prerequisites that we can set in the plugin so  
that eclipse gives a nice warning?


I've added that information to 
http://www.xwiki.org/xwiki/bin/view/Code/XEclipseExtension

Thanks
-Vincent

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XEclipse installation

2007-11-22 Thread goldring, richard
Thanks. I'll try the newer version of Eclipse.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Behalf Of
Vincent Massol
Sent: 22 November 2007 14:50
To: XWiki Users
Subject: Re: [xwiki-users] XEclipse installation



On Nov 22, 2007, at 3:03 PM, goldring, richard wrote:


Hi,
 
I installed XEclipse following the instructions by unzipping into the plugin
directory and then run up Eclipse and showed the XWiki explorer and got the
following error ...
 
org.eclipse.ui.forms.FormToolkit.decorateFormHeading(Lorg/eclipse/ui/forms.w
idgets/Form;)V
 
Anyone know what's wrong and how to get it running?


I guess you need Eclipse Europa Fall or above if you want to use it as a
plugin.

Fabio, isn't that a prerequisites that we can set in the plugin so that
eclipse gives a nice warning?

I've added that information to
http://www.xwiki.org/xwiki/bin/view/Code/XEclipseExtension
http://www.xwiki.org/xwiki/bin/view/Code/XEclipseExtension 

Thanks
-Vincent



Thales UK Ltd (Wells) DISCLAIMER: The information contained in this e-mail
is confidential. It may also be legally privileged. It is intended only for
the stated addressee(s) and access to it by any other person is
unauthorised. If you are not an addressee, you must not disclose, copy,
circulate or in any other way use or rely on the information contained in
this e-mail. Such unauthorised use may be unlawful. We may monitor all
e-mail communications through our networks. If you have received this e-mail
in error, please inform us immediately on +44 (0) 1749 672081 and delete it
and all copies from your system. We accept no responsibility for changes to
any e-mail which occur after it has been sent.  Attachments to this e-mail
may contain software viruses which could damage your system.  We therefore
recommend you virus-check all attachments before opening. A business of
Thales UK Ltd. Registered Office: 2 Dashwood Lang Road, The Bourne Business
Park, Addlestone, Weybridge, Surrey KT15 2NX Registered in England No.
868273
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Your XEN ICT Team - Ricardo Rodriguez

Vincent Massol wrote:


On Nov 22, 2007, at 3:51 PM, goldring, richard wrote:


Thanks. I'll try the newer version of Eclipse.


you can also use the RCP application of course.

-Vincent


I was writing a message when this thread sprouts. I do hope this won't 
be considered thread hijacking!


Following the message received in users and devs lists at xwiki.org last 
November the 19th I've downloaded and installed XEclipse 1.0. This 
utility looks simply great! Thanks to the develpers.


The ability to work off-line (grab sites into local machine) and to 
receive warning about possible conflicts when syncing with server are 
key features for a wide adoption of XWiki for some research groups I'm 
working with.


At the moment, we are mainly using MacBook computers running Mac OS X 
10.5.1 with Java(TM) 2 Runtime Environment, Standard Edition (build 
1.5.0_13-b05-237) and Java HotSpot(TM) Client VM (build 1.5.0_13-119, 
mixed mode, sharing)



I am able to launch XEclipse as a standalone RCP application and connect 
to the server. The first time I connect, I get a number of folders with 
no name except for the Panels space. If I close XEclipse and relaunch 
it, only the Panels folder is shown. Any attempt to edit a document 
through the following error:


java.lang.ClassCastException: java.lang.String
   at org.codehaus.swizzle.confluence.MapObject.getInt(MapObject.java:53)
   at org.codehaus.swizzle.confluence.Page.getVersion(Page.java:71)
   at org.xwiki.eclipse.model.impl.XWikiPage.getVersion(XWikiPage.java:120)
   at 
org.xwiki.eclipse.editors.XWikiPageEditor.updateEditor(XWikiPageEditor.java:113)
   at 
org.xwiki.eclipse.editors.XWikiPageEditor.createPartControl(XWikiPageEditor.java:103)
   at 
org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:661)
   at 
org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:426)
   at 
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:592)

   at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:299)
   at 
org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:179)
   at 
org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:268)
   at 
org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
   at 
org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:400)
   at 
org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1256)

   at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1209)
   at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1604)
   at org.eclipse.ui.internal.PartStack.add(PartStack.java:499)
   at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)
   at org.eclipse.ui.internal.PartStack.add(PartStack.java:485)
   at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)
   at 
org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)
   at 
org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:217)
   at 
org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:207)
   at 
org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:774)
   at 
org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:673)
   at 
org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:634)
   at 
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2737)
   at 
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2651)
   at 
org.eclipse.ui.internal.WorkbenchPage.access$13(WorkbenchPage.java:2643)

   at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2595)
   at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:67)
   at 
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2590)
   at 
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2574)
   at 
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2557)
   at 
org.xwiki.eclipse.views.XWikiExplorerView$1.doubleClick(XWikiExplorerView.java:195)
   at 
org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredViewer.java:799)

   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
   at org.eclipse.core.runtime.Platform.run(Platform.java:857)
   at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:46)
   at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:199)
   at 
org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(StructuredViewer.java:797)
   at 
org.eclipse.jface.viewers.AbstractTreeViewer.handleDoubleSelect(AbstractTreeViewer.java:1387)
   at 
org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSelected(StructuredViewer.java:1173)
   at 
org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEvent(OpenStrategy.java:237)

   

Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Jean-Vincent Drean
Hi!

I get the same error running :
- XEclipse RCP 1.0
- XWiki 1.2-SNAPSHOT on localhost
- Windows vista

May be a problem with recent modifications on the XML-RPC API ?

On Nov 22, 2007 8:07 PM, Fabio Mancinelli [EMAIL PROTECTED] wrote:

 On Nov 22, 2007, at 5:35 PM, Your XEN ICT Team - Ricardo Rodriguez
 wrote:

 
  Following the message received in users and devs lists at xwiki.org
  last November the 19th I've downloaded and installed XEclipse 1.0.
  This utility looks simply great! Thanks to the develpers.
 
 Thanks on behalf of the developers team!

 
  Here a screen with the error...
 
  http://mire.environmentalchange.net/~webmaster/images/XEclipseEditorError.png
 
  Please, does this make sense for you? Is it any known problem? Is
  there any workaround?
 
 I use Mac OS X 10.5.1 with Europa 3.3.1.1 so this should not be the
 problem.
 Actually I see from the screenshot that you are working online so it
 might be a communication problem through the XMLRpc interface.

 Could you please tell us what XWiki version are you connecting to?
 In this way we could investigate the problem also on the server side.

 Thank you.


 Cheers,
 Fabio
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Fabio Mancinelli

On Nov 22, 2007, at 5:35 PM, Your XEN ICT Team - Ricardo Rodriguez  
wrote:


 Following the message received in users and devs lists at xwiki.org  
 last November the 19th I've downloaded and installed XEclipse 1.0.  
 This utility looks simply great! Thanks to the develpers.

Thanks on behalf of the developers team!


 Here a screen with the error...

 http://mire.environmentalchange.net/~webmaster/images/XEclipseEditorError.png

 Please, does this make sense for you? Is it any known problem? Is  
 there any workaround?

I use Mac OS X 10.5.1 with Europa 3.3.1.1 so this should not be the  
problem.
Actually I see from the screenshot that you are working online so it  
might be a communication problem through the XMLRpc interface.

Could you please tell us what XWiki version are you connecting to?
In this way we could investigate the problem also on the server side.

Thank you.

Cheers,
Fabio
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Fabio Mancinelli

On Nov 22, 2007, at 9:36 PM, Your XEN ICT Team - Ricardo Rodriguez  
wrote:

 I'm connecting locally to a 1.2-milestone-2.5917 installation and
 remotely to a couple of 1.2-milestone-1.5235 ones. Always the same  
 error
 and while connecting from different locations, some of them quite  
 reliables.

Since Jean-Vincent has experienced the same issue there should surely  
be a problem with the XMLRPC backend of the 1.2 series.
We will investigate it and we will release a patched version soon.

Cheers,
Fabio
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XEclipse installation

2007-11-22 Thread Your XEN ICT Team - Ricardo Rodriguez
Fabio Mancinelli wrote:
 Since Jean-Vincent has experienced the same issue there should surely  
 be a problem with the XMLRPC backend of the 1.2 series.
 We will investigate it and we will release a patched version soon.

 Cheers,
 Fabio

Good luck!

Cheers,

-- 
Ricardo Rodríguez
Your XEN ICT Team

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users