Re: [xwiki-users] XWiki and Ozone widgets

2011-06-09 Thread Ludovic Dubost
As I said, we cannot help if you don't give us more information (javascript error from firebug for instance) Ludovic 2011/6/8 afrey af...@modusoperandi.com I changed the wysiwyginput.vm as suggested, and the problem with the ModalBox was fixed. So now I'm able to get the DropBox in the

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
Yes, what I need to do is get all the functionality of the widgets in the Wysiwyg mode (that is, have the widgets interactive, query, get results, display them on the map, zoom on the map, etc). Then, when I click the Save and View button form the wysiwyg mode, the widgets should be displayed just

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
How do I load the jsx (Javascript extension) in wysiwyg mode? - - Alina. -- View this message in context: http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453895.html Sent from the XWiki- Users mailing list archive at Nabble.com.

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
You should check if your javascript is loaded when you are in wysiwyg mode. The issue is that SSX/JSX are loaded on demand when the content is rendered. Since you are in Wysiwyg, the rendering is in AJAX so the edit page has no knowledge of SSX/JSX being needed, so they are not loaded. This

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
Do you mind telling me how to do that, please? Thank you. - - Alina. -- View this message in context: http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453961.html Sent from the XWiki- Users mailing list archive at Nabble.com.

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 05:28 PM, afrey wrote: How do I load the jsx (Javascript extension) in wysiwyg mode? Did you read my first reply? :) The wysiwyginput.vm used to generate the input for the WYSIWYG editor doesn't include javascript.vm and thus none of the JavaScript extensions. Simply write:

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
You go to the JSX page (you use XWiki.ModalBox) and edit using edit objects. You then have a field in the objects to set when this JSX/SSX is available. But this might not be the problem. It's hard to actually tell the problem without more information about your problem or being to look at it on

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 05:35 PM, Ludovic Dubost wrote: You should check if your javascript is loaded when you are in wysiwyg mode. The issue is that SSX/JSX are loaded on demand when the content is rendered. Since you are in Wysiwyg, the rendering is in AJAX so the edit page has no knowledge of SSX/JSX

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox - Edit - Objects. Objects of type XWiki.JavaScriptExtension (1) - JavaScriptExtension 0: modalbox - Use this extension - Changed to Always on this wiki. Objects of type XWiki.StyleSheetExtension (1) - StyleSheetExtension 0: modalbox

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
I'd say your problem is different and you need to look at which javascript errors are reported by your browser. Firebug is your friend for that Ludovic 2011/6/8 afrey af...@modusoperandi.com So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox - Edit - Objects. Objects of type

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 08:11 PM, afrey wrote: So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox - Edit - Objects. Objects of type XWiki.JavaScriptExtension (1) - JavaScriptExtension 0: modalbox - Use this extension - Changed to Always on this wiki. Objects of type

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
I changed the wysiwyginput.vm as suggested, and the problem with the ModalBox was fixed. So now I'm able to get the DropBox in the wysiwyg mode. Thank you both for the info. Now the problem that I have is how do I make the results from the query widget show up in the map widget. As a reminder,

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-07 Thread afrey
Marius, Please see the attached file for the code that I'm using to display the Ozone widgets in the XWiki page. http://xwiki.475771.n2.nabble.com/file/n6451265/CodeSubmitedToXwikiTeam.txt CodeSubmitedToXwikiTeam.txt The problem is not displaying the widgets in the iframes. The problem is in

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-07 Thread Ludovic Dubost
This could be because the jsx (Javascript extension) might not be loaded in wysiwyg mode. Do you actually need to view your widgets in Wysiwyg mode ? If not you could use velocity and use #if($context.action==edit)Widgets are not displayed in Wysiwyg#else ... #end Ludovic On Tue, Jun 7, 2011

Re: [xwiki-users] XWiki and Ozone widgets

2011-06-03 Thread Marius Dumitru Florea
Hi Alina, On 06/01/2011 04:51 PM, afrey wrote: I am using XWiki (3.0) to display (using iframes) a couple of Ozone widgets as Common Map Widget, Common Query widget, and Data Generator. Ozone and XWiki are running on two different machines. I am able to see the query results on the map, but