Re: [xwiki-users] XWiki and Ozone widgets

2011-06-09 Thread Ludovic Dubost
As I said, we cannot help if you don't give us more information (javascript
error from firebug for instance)

Ludovic

2011/6/8 afrey af...@modusoperandi.com

 I changed the wysiwyginput.vm as suggested, and the problem with the
 ModalBox
 was fixed. So now I'm able to get the DropBox in the wysiwyg mode.

 Thank you both for the info.

 Now the problem that I have is how do I make the results from the query
 widget show up in the map widget. As a reminder, this is possible if not in
 the wysiwyg mode.

 Alina.

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6454704.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




-- 
Ludovic Dubost
Founder and CEO
Blog: http://blog.ludovic.org/
XWiki: http://www.xwiki.com
Skype: ldubost GTalk: ldubost
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
Yes, what I need to do is get all the functionality of the widgets in the
Wysiwyg mode (that is, have the widgets interactive, query, get results,
display them on the map, zoom on the map, etc). Then, when I click the Save
and View button form the wysiwyg mode, the widgets should be displayed just
as I had them set up in the wysiwyg (zoomed in with the results showing up
on the map), but not interactive (that is, not be able to zoom on the map,
or query in the query widget; just still images of whatever was set up in
the wysiwyg mode).

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453861.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
How do I load the jsx (Javascript extension) in wysiwyg mode?

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453895.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
You should check if your javascript is loaded when you are in wysiwyg mode.
The issue is that SSX/JSX are loaded on demand when the content is rendered.
Since you are in Wysiwyg, the rendering is in AJAX so the edit page has no
knowledge of SSX/JSX being needed, so they are not loaded.

This should probably be reported as a bug since they might be a need for a
mecanism for the Wysiwyg AJAX rendering to get a list of CSS and JS to load
once the page is rendered. These CSS and JS would needed to be dynamically
loaded.

Now this can cause some side effects since the CSS or JS could conflict with
the edit mode. Maybe the macros should declare that they want this to
happen.

A workaround for you would be to force load your SSX/JSX all the time (set
Always in the needed SSX and JSX).

Ludovic

On Wed, Jun 8, 2011 at 4:22 PM, afrey af...@modusoperandi.com wrote:

 Yes, what I need to do is get all the functionality of the widgets in the
 Wysiwyg mode (that is, have the widgets interactive, query, get results,
 display them on the map, zoom on the map, etc). Then, when I click the
 Save
 and View button form the wysiwyg mode, the widgets should be displayed
 just
 as I had them set up in the wysiwyg (zoomed in with the results showing up
 on the map), but not interactive (that is, not be able to zoom on the map,
 or query in the query widget; just still images of whatever was set up in
 the wysiwyg mode).

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453861.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




-- 
Ludovic Dubost
Founder and CEO
Blog: http://blog.ludovic.org/
XWiki: http://www.xwiki.com
Skype: ldubost GTalk: ldubost
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
Do you mind telling me how to do that, please?
Thank you.

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453961.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 05:28 PM, afrey wrote:
 How do I load the jsx (Javascript extension) in wysiwyg mode?

Did you read my first reply? :)

The wysiwyginput.vm used to generate the input for the WYSIWYG
editor doesn't include javascript.vm and thus none of the JavaScript
extensions.

Simply write:

#template(javascript.vm)

after the line with:

#template(stylesheets.vm)

Hope this helps,
Marius


 -
 - Alina.
 --
 View this message in context: 
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453895.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
You go to the JSX page (you use XWiki.ModalBox) and edit using edit
objects. You then have a field in the objects to set when this JSX/SSX is
available.

But this might not be the problem. It's hard to actually tell the problem
without more information about your problem or being to look at it on a real
site. You might want to use Firebug in Firefox to see if you have an JS
errors.

Ludovic

On Wed, Jun 8, 2011 at 4:41 PM, afrey af...@modusoperandi.com wrote:

 Do you mind telling me how to do that, please?
 Thank you.

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453961.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




-- 
Ludovic Dubost
Founder and CEO
Blog: http://blog.ludovic.org/
XWiki: http://www.xwiki.com
Skype: ldubost GTalk: ldubost
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 05:35 PM, Ludovic Dubost wrote:
 You should check if your javascript is loaded when you are in wysiwyg mode.
 The issue is that SSX/JSX are loaded on demand when the content is rendered.
 Since you are in Wysiwyg, the rendering is in AJAX so the edit page has no
 knowledge of SSX/JSX being needed, so they are not loaded.

 This should probably be reported as a bug since they might be a need for a
 mecanism for the Wysiwyg AJAX rendering to get a list of CSS and JS to load
 once the page is rendered. These CSS and JS would needed to be dynamically
 loaded.


 Now this can cause some side effects since the CSS or JS could conflict with
 the edit mode.

Exactly. JSX are not loaded on purpose. SSX are loaded though.

 Maybe the macros should declare that they want this to
 happen.

 A workaround for you would be to force load your SSX/JSX all the time (set
 Always in the needed SSX and JSX).

If you want to enable JSX loading for the edited content then you need 
to include javascript.vm template in wysiwyginput.vm like this:

#template(javascript.vm)

Hope this helps,
Marius


 Ludovic

 On Wed, Jun 8, 2011 at 4:22 PM, afreyaf...@modusoperandi.com  wrote:

 Yes, what I need to do is get all the functionality of the widgets in the
 Wysiwyg mode (that is, have the widgets interactive, query, get results,
 display them on the map, zoom on the map, etc). Then, when I click the
 Save
 and View button form the wysiwyg mode, the widgets should be displayed
 just
 as I had them set up in the wysiwyg (zoomed in with the results showing up
 on the map), but not interactive (that is, not be able to zoom on the map,
 or query in the query widget; just still images of whatever was set up in
 the wysiwyg mode).

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6453861.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox - Edit -
Objects.
Objects of type XWiki.JavaScriptExtension (1) - JavaScriptExtension 0:
modalbox - Use this extension - Changed to Always on this wiki.
Objects of type XWiki.StyleSheetExtension (1) - StyleSheetExtension 0:
modalbox - Use this extension - Changed to Always on this wiki.

These changes didn't solve my problem.

The next one is to modify wysiwyginput.vm. But I don't know how to edit it.
I poked around for info on the threads, but I couldn't find anything. Could
you please help me with that?

Thank you.
(Mersi mult :))

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6454549.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Ludovic Dubost
I'd say your problem is different and you need to look at which javascript
errors are reported by your browser.
Firebug is your friend for that

Ludovic

2011/6/8 afrey af...@modusoperandi.com

 So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox - Edit
 -
 Objects.
 Objects of type XWiki.JavaScriptExtension (1) - JavaScriptExtension 0:
 modalbox - Use this extension - Changed to Always on this wiki.
 Objects of type XWiki.StyleSheetExtension (1) - StyleSheetExtension 0:
 modalbox - Use this extension - Changed to Always on this wiki.

 These changes didn't solve my problem.

 The next one is to modify wysiwyginput.vm. But I don't know how to edit it.
 I poked around for info on the threads, but I couldn't find anything. Could
 you please help me with that?

 Thank you.
 (Mersi mult :))

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6454549.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




-- 
Ludovic Dubost
Founder and CEO
Blog: http://blog.ludovic.org/
XWiki: http://www.xwiki.com
Skype: ldubost GTalk: ldubost
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread Marius Dumitru Florea
On 06/08/2011 08:11 PM, afrey wrote:
 So, I went to http://localhost:8086/xwiki/bin/view/XWiki/ModalBox -  Edit -
 Objects.
 Objects of type XWiki.JavaScriptExtension (1) -  JavaScriptExtension 0:
 modalbox -  Use this extension -  Changed to Always on this wiki.
 Objects of type XWiki.StyleSheetExtension (1) -  StyleSheetExtension 0:
 modalbox -  Use this extension -  Changed to Always on this wiki.

 These changes didn't solve my problem.

 The next one is to modify wysiwyginput.vm. But I don't know how to edit it.
 I poked around for info on the threads, but I couldn't find anything. Could
 you please help me with that?

wysiwyginput.vm it's a Velocity template and you can find it on the file 
system, on the server, in the templates folder, where you deployed 
XWiki. If you don't have access to the file system then you can 
overwrite it in your skin (e.g. by attaching the modified version to 
your skin page).


 Thank you.
 (Mersi mult :))

:)

Hope this helps,
Marius


 -
 - Alina.
 --
 View this message in context: 
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6454549.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-08 Thread afrey
I changed the wysiwyginput.vm as suggested, and the problem with the ModalBox
was fixed. So now I'm able to get the DropBox in the wysiwyg mode.

Thank you both for the info.

Now the problem that I have is how do I make the results from the query
widget show up in the map widget. As a reminder, this is possible if not in
the wysiwyg mode.

Alina.

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6454704.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-07 Thread afrey
Marius,

Please see the attached file for the code that I'm using to display the
Ozone widgets in the XWiki page.

http://xwiki.475771.n2.nabble.com/file/n6451265/CodeSubmitedToXwikiTeam.txt
CodeSubmitedToXwikiTeam.txt 

The problem is not displaying the widgets in the iframes. The problem is in
displaying the query results on the map. And all of this only in the wysiwyg
mode. If I'm in the regular display mode, I'm able to see the all the
widgets (map, query, etc) plus the results returned by the query on the map.
When in the wysiwyg mode, I can see the widgets, but the results that I get
from the query widget, are not displayed on the map widget. Does that make
sense?

Alina.

-
- Alina.
--
View this message in context: 
http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6451265.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-07 Thread Ludovic Dubost
This could be because the jsx (Javascript extension) might not be loaded in
wysiwyg mode.

Do you actually need to view your widgets in Wysiwyg mode ?

If not you could use velocity and use #if($context.action==edit)Widgets
are not displayed in Wysiwyg#else ... #end

Ludovic

On Tue, Jun 7, 2011 at 10:31 PM, afrey af...@modusoperandi.com wrote:

 Marius,

 Please see the attached file for the code that I'm using to display the
 Ozone widgets in the XWiki page.

 http://xwiki.475771.n2.nabble.com/file/n6451265/CodeSubmitedToXwikiTeam.txt
 CodeSubmitedToXwikiTeam.txt

 The problem is not displaying the widgets in the iframes. The problem is in
 displaying the query results on the map. And all of this only in the
 wysiwyg
 mode. If I'm in the regular display mode, I'm able to see the all the
 widgets (map, query, etc) plus the results returned by the query on the
 map.
 When in the wysiwyg mode, I can see the widgets, but the results that I get
 from the query widget, are not displayed on the map widget. Does that make
 sense?

 Alina.

 -
 - Alina.
 --
 View this message in context:
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6451265.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users




-- 
Ludovic Dubost
Founder and CEO
Blog: http://blog.ludovic.org/
XWiki: http://www.xwiki.com
Skype: ldubost GTalk: ldubost
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWiki and Ozone widgets

2011-06-03 Thread Marius Dumitru Florea
Hi Alina,

On 06/01/2011 04:51 PM, afrey wrote:
 I am using XWiki (3.0) to display (using iframes) a couple of Ozone widgets
 as Common Map Widget, Common Query widget, and Data Generator. Ozone and
 XWiki are running on two different machines.
 I am able to see the query results on the map, but when in the Wysiwyg mode
 I'm not able to display them. Could anyone that is familiar with the Ozone
 Widget Framework suggest what do I need to do in order to accomplish that?

Besides the iframes, do you use any JavaScript code to display the Ozone 
widgets? The wysiwyginput.vm used to generate the input for the WYSIWYG 
editor doesn't include javascript.vm and thus none of the JavaScript 
extensions. Besides that, the WYSIWYG editor shouldn't have problems 
displaying iframes. You can test with a page that contains:

{{html}}iframe src=http://www.google.com;/iframe{{/html}}

Hope this helps,
Marius


 Thank you,

 Alina.

 -
 - Alina.
 --
 View this message in context: 
 http://xwiki.475771.n2.nabble.com/XWiki-and-Ozone-widgets-tp6427000p6427000.html
 Sent from the XWiki- Users mailing list archive at Nabble.com.
 ___
 users mailing list
 users@xwiki.org
 http://lists.xwiki.org/mailman/listinfo/users
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users