Re: [xwiki-users] XWikiLock and it's duration time

2009-05-11 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Hi,

Sergiu Dumitriu wrote:
 Another proof that the Lucene search doesn't work pretty well.

   

A pity! A whole and reliable index is a must. I've been stuck with 
1.3.8295 for almost a year promising a nice search utility once we get 
an update to the current XWiki release! :-)

I will browse dev list and Jira for Lucene related issues and follow the 
threads.
 Looks like somebody played with the access rights on that document. It 
 has been broken for a year and nobody complained about it... It's fixed 
 now, you can try again.

   
Reached! Thanks.

-- 
Ricardo Rodríguez
Your EPEC Network ICT Team

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-10 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Thanks, Sergiu.

Sergiu Dumitriu wrote:
 My bad, I didn't properly escape the #if. Fixed now.

   

Please, does search behave like expect if (posting here a paragraph from 
e previous entry for easier reference)...

I've tried to find the page by searching for locks and lock (no 
simultaneously). None of these two pages showed up. Even funnier: if i 
log into XWiki, I get a page given 12 results but showing just one. If I 
log out, I get 13 results, all of them showed in the result page.


Thanks again!

Cheers,

Ricardo

-- 
Ricardo Rodríguez
Your EPEC Network ICT Team

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-10 Thread Sergiu Dumitriu
[Ricardo Rodriguez] Your EPEC Network ICT Team wrote:
 Thanks, Sergiu.
 
 Sergiu Dumitriu wrote:
 My bad, I didn't properly escape the #if. Fixed now.

   
 
 Please, does search behave like expect if (posting here a paragraph from 
 e previous entry for easier reference)...
 
 I've tried to find the page by searching for locks and lock (no 
 simultaneously). None of these two pages showed up. Even funnier: if i 
 log into XWiki, I get a page given 12 results but showing just one. If I 
 log out, I get 13 results, all of them showed in the result page.
 

What search did you use?

Using the dedicated FAQ search from the FAQ home page, I correctly get 
the two entries at the top of the list:

http://www.xwiki.org/xwiki/bin/view/FAQ/FAQSearch?text=lock

-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-10 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team


Sergiu Dumitriu wrote:
 What search did you use?
   

The Lucene search available in the right column. Logged in as rrodriguez

http://www.xwiki.org/xwiki/bin/view/Main/LuceneSearch?text=lockx=0y=0

Here the results...

http://xen.net/images/searchingXWikiForLock.jpg
 Using the dedicated FAQ search from the FAQ home page, I correctly get 
 the two entries at the top of the list:

 http://www.xwiki.org/xwiki/bin/view/FAQ/FAQSearch?text=lock

   
Here what I get when accessing this link...

http://xen.net/images/errorSearchingXWiki.png

Does this make any sense for you? Thanks.

Cheers,

-- 
Ricardo Rodríguez
Your EPEC Network ICT Team

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-10 Thread Sergiu Dumitriu
[Ricardo Rodriguez] Your EPEC Network ICT Team wrote:
 
 Sergiu Dumitriu wrote:
 What search did you use?
   
 
 The Lucene search available in the right column. Logged in as rrodriguez
 
 http://www.xwiki.org/xwiki/bin/view/Main/LuceneSearch?text=lockx=0y=0
 
 Here the results...

Another proof that the Lucene search doesn't work pretty well.

 http://xen.net/images/searchingXWikiForLock.jpg
 Using the dedicated FAQ search from the FAQ home page, I correctly get 
 the two entries at the top of the list:

 http://www.xwiki.org/xwiki/bin/view/FAQ/FAQSearch?text=lock

   
 Here what I get when accessing this link...
 
 http://xen.net/images/errorSearchingXWiki.png
 

Looks like somebody played with the access rights on that document. It 
has been broken for a year and nobody complained about it... It's fixed 
now, you can try again.

-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-09 Thread Sergiu Dumitriu
ladar wrote:
 Hi,
 by changing manullay the date attribute in table xwikilock I have found that
 xwikilock lasts only about 30-45 minutes (approximatelly). Is there any way
 how to increase this time? I haven't found it neither in xwiki.cfg nor
 hibernate.cfg.xml...

See http://www.xwiki.org/xwiki/bin/view/FAQ/HowToIncreaseTheLockDuration

 And second question, if one user starts editing any page, then another user
 can also edit this page at the same time just by confirming alert message
 that is saying that other user is already editing this page. Is there any
 way how to disable this option that 2 users can edit the same page at the
 same time? 

See http://www.xwiki.org/xwiki/bin/view/FAQ/HowToEnforcePageLocks

-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-09 Thread ladar

Thanks a lot
-- 
View this message in context: 
http://n2.nabble.com/XWikiLock-and-it%27s-duration-time-tp2850310p2850557.html
Sent from the XWiki- Users mailing list archive at Nabble.com.

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-09 Thread [Ricardo Rodriguez] Your EPEC Network ICT Team
Hi Sergiu,


Sergiu Dumitriu wrote:

 See http://www.xwiki.org/xwiki/bin/view/FAQ/HowToEnforcePageLocks

   

I'm trying to to go to this second link to no avail. Here what I get...

http://mire.environmentalchange.net/~webmaster/images/unlocksXWikiError.png

I've tried to find the page by searching for locks and lock (no 
simultaneously). None of these two pages showed up. Even funnier: if i 
log into XWiki, I get a page given 12 results but showing just one. If I 
log out, I get 13 results, all of them showed in the result page.

Please, does this any sense for you? Thanks!

Cheers,

Ricardo

-- 
Ricardo Rodríguez
Your EPEC Network ICT Team

___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users


Re: [xwiki-users] XWikiLock and it's duration time

2009-05-09 Thread Sergiu Dumitriu
[Ricardo Rodriguez] Your EPEC Network ICT Team wrote:
 Hi Sergiu,
 
 
 Sergiu Dumitriu wrote:
 See http://www.xwiki.org/xwiki/bin/view/FAQ/HowToEnforcePageLocks

   
 
 I'm trying to to go to this second link to no avail. Here what I get...
 
 http://mire.environmentalchange.net/~webmaster/images/unlocksXWikiError.png

My bad, I didn't properly escape the #if. Fixed now.

-- 
Sergiu Dumitriu
http://purl.org/net/sergiu/
___
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users