Re: [utenti] Ooo 2.4 e JRE

2008-05-14 Per discussione Alessandro Braga
Il Tuesday 13 May 2008 11:47:39 Andrea ha scritto:
 Alessandro Braga ha scritto:
  1.5.0 Free Software Foundation /usr/lib
  1.6.0 Sun con supporto per l'accesso facilitato (?)
  posizione /usr/lib/jvm/java-6-openjdk/jre
  1.6.0_03, la  1.6.0_05 e la 1.6.0_06 sempre di sun se ne seleziono uno a
  caso la selezione non viene mantenuta cosa bisogna mettere nella
  sezione parametri?

 Dai post precedenti che affrontavano la stessa questione emergeva che:
 - OO sembra non avere problemi solo con la versione 1.5.0 Free Software
 Foundation.
 - Pare esserci un problema di mancato mantenimento della versione di
 Java selezionata dalle impostazioni di OO, o perché OO si accorge che
 quelle diverse dalla 1.5.0 Free Software Foundation, hanno elementi di
 incompatibilità, o per altre ragioni.
 Ti conviene quindi selezionare la versione 1.5.0 Free Software
 Foundation e se del caso disinstallare le versioni diverse dalla 1.5.0
 Free Software Foundation, a meno che tu non debba assolutamente
 utilizzarle con altri applicativi.

 Ciao
 Andrea

 -
 To unsubscribe, e-mail: [EMAIL PROTECTED]
 For additional commands, e-mail: [EMAIL PROTECTED]

Grazie Andrea della tua risposta,
il problema è che se seleziono per es. la 1.5.0 Free software foundation 
tale selezione non viene mantenuta, e rimangono tutti i java in bianco!!!
Ho provato a disinstallare qualche java da synaptic, ma in lista me ne 
rimangono altri come faccio a disinstallarli completamente?
In synaptic ho lasciato solo il seguente openoffice.org-java-common ma non so 
se è quello a cui ti riferisci tu?

Nel frattempo mi è successa un'altra cosa, all'apertura di Openoffice mi si 
apre un'altra finestra con la seg dicitura:
Un'altra istanza di Openoffice ha ccesso alle impostazioni personalizzate 
oppure le impostazioni personalizzate sono bloccate. L'accesso simultaneo può 
creare incongruenze alle impostazioni.
prima di procedere assicuratevi che l'utente alex chiuda Openoffice.org sul 
computer host 'alex-laptop.cheapnet.it'.
volete procedere comunque?
Che posso fare? non so minimamente come si sia aperta l'accesso 
alex-laptop.cheapnet.it?
Grazie dell'aiuto


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [utenti] Ooo 2.4 e JRE

2008-05-14 Per discussione Alessandro Braga
Il Tuesday 13 May 2008 23:10:54 sg ha scritto:
 sg ha scritto:
  Il problema è il seguente file:
 
  ~/.openoffice.org2/user/config/javasettings_Linux_x86.xml
 
  chiudi OOo e cancellalo con:
 
  $ rm ~/.openoffice.org2/user/config/javasettings_Linux_x86.xml
 
  poi rilancia OOo che sei a posto.
 
  PS: il file viene ricreato con la giusta versione di java.

Più difficile scriverlo che farlo Geniale Grazie funziona, ora almeno la 
selezione del JRE rimane fissa uso la 1.5.0 della free foundation come 
cosigliato?! e sembra non ci siano più problemi, riesco a vedere le macro sul 
foglio allegato che mi avevi mandato esempio modulo diciamo che la macro non 
è corta... me la guardo e sicuramente ti dovrò ricontattare... grazie e buona 
giornata alex


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [utenti] Ooo 2.4 e JRE

2008-05-13 Per discussione Andrea

Alessandro Braga ha scritto:

1.5.0 Free Software Foundation /usr/lib
1.6.0 Sun con supporto per l'accesso facilitato (?) 
posizione /usr/lib/jvm/java-6-openjdk/jre
1.6.0_03, la  1.6.0_05 e la 1.6.0_06 sempre di sun se ne seleziono uno a caso 
la selezione non viene mantenuta cosa bisogna mettere nella sezione 
parametri?


Dai post precedenti che affrontavano la stessa questione emergeva che:
- OO sembra non avere problemi solo con la versione 1.5.0 Free Software 
Foundation.
- Pare esserci un problema di mancato mantenimento della versione di 
Java selezionata dalle impostazioni di OO, o perché OO si accorge che 
quelle diverse dalla 1.5.0 Free Software Foundation, hanno elementi di 
incompatibilità, o per altre ragioni.
Ti conviene quindi selezionare la versione 1.5.0 Free Software 
Foundation e se del caso disinstallare le versioni diverse dalla 1.5.0 
Free Software Foundation, a meno che tu non debba assolutamente 
utilizzarle con altri applicativi.


Ciao
Andrea

-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [utenti] Ooo 2.4 e JRE

2008-05-13 Per discussione Attilio Tempestini

Alessandro Braga ha scritto:

Ho aggiornato Ubuntu alla versione Hardy 8.04 e OpenOffice alla versione 2.4.
Tutto ok ma qualche difficoltà me la ritrovo con JRE, infatti se apro un file 
odb o odt e cerco di leggere le macro incluse in questo file mi compare una 
finestra di errore che mi dice che ho installato una versione di JRE 
difettosa (?) cosa che ha fatto per conto suo Openoffice o Ubuntu Hardy. In 
questo modo non mi si apre la gestione della macro...
Ho provato a guardare in -Strumenti -Opzioni -Java e mi trovo le seguenti 
versioni:

1.5.0 Free Software Foundation /usr/lib
1.6.0 Sun con supporto per l'accesso facilitato (?) 
posizione /usr/lib/jvm/java-6-openjdk/jre
1.6.0_03, la  1.6.0_05 e la 1.6.0_06 sempre di sun se ne seleziono uno a caso 
la selezione non viene mantenuta cosa bisogna mettere nella sezione 
parametri? Quale devo utilizzare? Forse sono stati installati male? Come devo 
fare?

Grazie infinite per ogni aiuto


  
Sono appena venuto fuori, da un caso del genere. Nel mio caso, la 
finestra di errore compariva quando cercavo di aprire una tabella di Base.


Anche io trovavo, nella finestra in questione, varie versioni di Java; 
senza riuscire a passare ad una versione diversa dalla 1,6. Il problema 
me l'ha infine, restando nella 1,6, risolto un amico -con le spalle più 
larghe delle mie-, alle quali ho chiesto poi una specie di promemoria su 
come aveva fatto. Te lo riproduco, con alcune modifiche formali (e 
magari sei più bravo a metterlo in pratica, di quanto sarei io).




Aprire un terminale

Diventare utente di sistema (sudo su )

Dpkg -l |grep openoffice lista (si crea un file che si chiama lista, si 
può verificare con nano lista quello che c'è scritto dentro, ctrl+x 
per uscire da nano; la pipe | si trova con maiuscolo+\)


Si dovrebbe vedere una cosa del genere:
ii  openclipart-openoffice.org   0.18+dfsg-4   clip art 
for OpenOffice.org gallery
ii  openoffice.org   2.0.4.dfsg.2-7etch5   
OpenOffice.org Office suite version 2.0
ii  openoffice.org-base  2.0.4.dfsg.2-7etch5   
OpenOffice.org office suite - database
ii  openoffice.org-calc  2.0.4.dfsg.2-7etch5   
OpenOffice.org office suite - spreadsheet
ii  openoffice.org-common2.0.4.dfsg.2-7etch5   
OpenOffice.org office suite architecture ind



Sono pacchetti, questi contenuti nel file lista -e dunque installati nel 
pc in questione-, dei quali conta in realtà il solo nome, giacché la 
versione potrebbe essere cambiata. Per esempio, conta soltanto 
openclipart-openoffice.org


Inserire, prelevandoli da /etc/apt/source.list, gli indirizzi deb che si 
usano come repository


Rinominare openoffice in oldopenoffice (per il caso che qualcosa dovesse 
andare storta)


Aggiungere o scommentare i repository, che eventualmente mancano o sono 
commentati


Aggiornare la lista dei pacchetti (apt-get update)

Aggiornare il sistema (apt-get upgrade)

Installare tutti i pacchetti suddetti (per esempio, apt-get install 
openclipart-openoffice.org), anche in un computer in cui fossero già 
installati: tanto il sistema è intelligente e farà le correzioni necessarie




Ciao,

Attilio Tempestini

-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [utenti] Ooo 2.4 e JRE

2008-05-13 Per discussione sg

Ciao Alessandro,
sono a casa e ho potuto verificare il tuo problema (visto che ho ubuntu 
8.04).

Il problema è il seguente file:

~/openoffice.org2/user/config/javasettings_Linux_x86.xml

chiudi OOo e cancellalo con:

$ rm ~/openoffice.org2/user/config/javasettings_Linux_x86.xml

poi rilancia OOo che sei a posto.

PS: il file viene ricreato con la giusta versione di java.



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [utenti] Ooo 2.4 e JRE

2008-05-13 Per discussione sg

sg ha scritto:

Ciao Alessandro,
sono a casa e ho potuto verificare il tuo problema (visto che ho 
ubuntu 8.04).

Il problema è il seguente file:

~/.openoffice.org2/user/config/javasettings_Linux_x86.xml

chiudi OOo e cancellalo con:

$ rm ~/openoffice.org2/user/config/javasettings_Linux_x86.xml

poi rilancia OOo che sei a posto.

PS: il file viene ricreato con la giusta versione di java.


ops !!! scusate, il file è nella directory nascosta, cioè:

~/.openoffice.org2/user/config/javasettings_Linux_x86.xml
quindi:

$ rm ~/.openoffice.org2/user/config/javasettings_Linux_x86.xml

-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]