RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2003-01-01 Thread Matt Darcy
Still having the problem - any other suggestions of debug advice.

I am curious as to why there is no logging to better diagnose this problem.

Thanks,

Matt.


  -Original Message-
 From: Matt Darcy [mailto:[EMAIL PROTECTED]] 
 Sent: 30 December 2002 13:50
 To:   Cory Wright; vpopmail usergroup
 Subject:  RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
 logging.
 
 
 
 -Original Message-
 From: Cory Wright [mailto:[EMAIL PROTECTED]]
 Sent: 30 December 2002 05:42
 To: vpopmail usergroup
 Subject: Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
 logging.
 
 
 On Mon, Dec 30, 2002 at 01:28:57PM -0800, Matt Darcy wrote:
 
  [root@jordan pop3d]# ps ax | grep read
   1164 ?S  0:01 readproctitle service errors: ... unable to
 start
  qma
 
 This is not enough.  Do this:  `ps ax|grep readproc`.
 
 
  [root@jordan qmail-pop3d]# cat run
   #!/bin/sh
  exec /usr/local/bin/softlimit -m 500 \
  /usr/local/bin/tcpserver -H -R 0 pop-3
 /var/qmail/bin/qmail-popup \
  alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
  /var/qmail/bin/qmail-pop3d Maildir 21
 
 Not `cat run`, `cat -e run`.
 
 Cory
 
 
 
 Ok,  little better attention to detail
 
 
 [root@jordan qmail-pop3d]# ps ax|grep readproc
  1164 ?S  0:01 readproctitle service errors: ... unable to
 start qma
 il-pop3d/run: exec format error?supervise: fatal: unable to start
 qmail-pop3d/ru
 n: exec format error?supervise: fatal: unable to start qmail-pop3d/run:
 exec for
 mat error?supervise: fatal: unable to start qmail-pop3d/run: exec format
 error?s
 upervise: fatal: unable to start qmail-pop3d/run: exec format
 error?supervise: f
 atal: unable to start qmail-pop3d/run: exec format error?
  4575 pts/1R  0:00 grep readproc
 [root@jordan qmail-pop3d]#
 
 and the script
 
 [root@jordan qmail-pop3d]# cat -e run
  #!/bin/sh$
 exec /usr/local/bin/softlimit -m 500 \$
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup
 \$
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qma
 il-pop3d Maildir 21$
 $
 
 Thanks,
 
 Matt

attachment: winmail.dat

Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Cory Wright
On Mon, Dec 30, 2002 at 12:41:09PM -0800, Matt Darcy wrote:
 /service/qmail-pop3d: up (pid 31995) 0 seconds
 /service/qmail-pop3d/log: up (pid 1173) 2989243 seconds

There is a problem in your /service/qmail-pop3d/run script.  Post the 
output of `cat -e /service/qmail-pop3d/run`.  Also, when you run `ps ax`
you should see a program called 'readproctitle' running.  What is listed
after readproctitle service errors: ?

Cory

--
Cory Wright
Stand Blue Technology
http://www.standblue.net/




RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Matt Darcy


-Original Message-
From: Cory Wright [mailto:[EMAIL PROTECTED]]
Sent: 30 December 2002 05:20
To: vpopmail usergroup
Subject: Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
logging.


On Mon, Dec 30, 2002 at 12:41:09PM -0800, Matt Darcy wrote:
 /service/qmail-pop3d: up (pid 31995) 0 seconds
 /service/qmail-pop3d/log: up (pid 1173) 2989243 seconds

There is a problem in your /service/qmail-pop3d/run script.  Post the 
output of `cat -e /service/qmail-pop3d/run`.  Also, when you run `ps ax`
you should see a program called 'readproctitle' running.  What is listed
after readproctitle service errors: ?

Cory



Ok here we go

[root@jordan pop3d]# ps ax | grep read
 1164 ?S  0:01 readproctitle service errors: ... unable to start
qma
[root@jordan pop3d]#


And the script

[root@jordan qmail-pop3d]# cat run
 #!/bin/sh
exec /usr/local/bin/softlimit -m 500 \
/usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
/var/qmail/bin/qmail-pop3d Maildir 21


I can't see anything wrong with the startup script...




attachment: winmail.dat

Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Cory Wright
On Mon, Dec 30, 2002 at 01:28:57PM -0800, Matt Darcy wrote:

 [root@jordan pop3d]# ps ax | grep read
  1164 ?S  0:01 readproctitle service errors: ... unable to start
 qma

This is not enough.  Do this:  `ps ax|grep readproc`.


 [root@jordan qmail-pop3d]# cat run
  #!/bin/sh
 exec /usr/local/bin/softlimit -m 500 \
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qmail-pop3d Maildir 21

Not `cat run`, `cat -e run`.

Cory

--
Cory Wright
Stand Blue Technology
http://www.standblue.net/




RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Matt Darcy


-Original Message-
From: Cory Wright [mailto:[EMAIL PROTECTED]]
Sent: 30 December 2002 05:42
To: vpopmail usergroup
Subject: Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
logging.


On Mon, Dec 30, 2002 at 01:28:57PM -0800, Matt Darcy wrote:

 [root@jordan pop3d]# ps ax | grep read
  1164 ?S  0:01 readproctitle service errors: ... unable to
start
 qma

This is not enough.  Do this:  `ps ax|grep readproc`.


 [root@jordan qmail-pop3d]# cat run
  #!/bin/sh
 exec /usr/local/bin/softlimit -m 500 \
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup
\
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qmail-pop3d Maildir 21

Not `cat run`, `cat -e run`.

Cory



Ok,  little better attention to detail


[root@jordan qmail-pop3d]# ps ax|grep readproc
 1164 ?S  0:01 readproctitle service errors: ... unable to start
qma
il-pop3d/run: exec format error?supervise: fatal: unable to start
qmail-pop3d/ru
n: exec format error?supervise: fatal: unable to start qmail-pop3d/run: exec
for
mat error?supervise: fatal: unable to start qmail-pop3d/run: exec format
error?s
upervise: fatal: unable to start qmail-pop3d/run: exec format
error?supervise: f
atal: unable to start qmail-pop3d/run: exec format error?
 4575 pts/1R  0:00 grep readproc
[root@jordan qmail-pop3d]#

and the script

[root@jordan qmail-pop3d]# cat -e run
 #!/bin/sh$
exec /usr/local/bin/softlimit -m 500 \$
/usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \$
alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
/var/qmail/bin/qma
il-pop3d Maildir 21$
$

Thanks,

Matt

attachment: winmail.dat

Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Cory Wright
On Mon, Dec 30, 2002 at 01:49:54PM -0800, Matt Darcy wrote:

 [root@jordan qmail-pop3d]# ps ax|grep readproc
  1164 ?S  0:01 readproctitle service errors: ... unable to start
 qma
 il-pop3d/run: exec format error?supervise: fatal: unable to start
 qmail-pop3d/ru
 n: exec format error?supervise: fatal: unable to start qmail-pop3d/run: exec
 for
 mat error?supervise: fatal: unable to start qmail-pop3d/run: exec format
 error?s
 upervise: fatal: unable to start qmail-pop3d/run: exec format
 error?supervise: f
 atal: unable to start qmail-pop3d/run: exec format error?
  4575 pts/1R  0:00 grep readproc
 [root@jordan qmail-pop3d]#

It would be great if you could turn off line wrapping in your mailer. Thanks.

 [root@jordan qmail-pop3d]# cat -e run
  #!/bin/sh$
 exec /usr/local/bin/softlimit -m 500 \$
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \$
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qma
 il-pop3d Maildir 21$
 $

It is hard to tell with the line wrapping, but after looking at your first 
post of this file I believe the problem is that '/var/qmail/bin/qmail-pop3d`
is on a new line, when it should either be immediately after vchkpw or there
should be a \ as the last character on the vchkpw line.  Fix this, the pop3d
service should start within 5 seconds after its fixed.

What you have:
#!/bin/sh
   exec /usr/local/bin/softlimit -m 500 \
   /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
   alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
/var/qmail/bin/qmail-pop3d Maildir 21

What it should be:
#!/bin/sh
   exec /usr/local/bin/softlimit -m 500 \
   /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
   alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw \
  /var/qmail/bin/qmail-pop3d Maildir 21

Good luck,

Cory

--
Cory Wright
Stand Blue Technology
http://www.standblue.net/




RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread trell
Matt Darcy wrote:

  #!/bin/sh
 exec /usr/local/bin/softlimit -m 500 \
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qmail-pop3d Maildir 21
 
 I can't see anything wrong with the startup script...

Well Matt from looking at this and the fact that I also run Redhat 7.3 I see
one thing wrong. Your default /etc/services file has your pop-3 as pop3. There
are several ways to fix this, 1) either modify the /etc/services [bad idea], 
2) Modify your run script to say pop3 [good choice], or 3) modify your run
script to say 110 instead of pop-3 [best choice, unless you use a different
port number]. Hope that helps some.

Joe






RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Matt Darcy


-Original Message-
From: Cory Wright [mailto:[EMAIL PROTECTED]]
Sent: 30 December 2002 05:57
To: vpopmail usergroup
Subject: Re: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
logging.


On Mon, Dec 30, 2002 at 01:49:54PM -0800, Matt Darcy wrote:

 [root@jordan qmail-pop3d]# ps ax|grep readproc
  1164 ?S  0:01 readproctitle service errors: ... unable to
start
 qma
 il-pop3d/run: exec format error?supervise: fatal: unable to start
 qmail-pop3d/ru
 n: exec format error?supervise: fatal: unable to start qmail-pop3d/run:
exec
 for
 mat error?supervise: fatal: unable to start qmail-pop3d/run: exec format
 error?s
 upervise: fatal: unable to start qmail-pop3d/run: exec format
 error?supervise: f
 atal: unable to start qmail-pop3d/run: exec format error?
  4575 pts/1R  0:00 grep readproc
 [root@jordan qmail-pop3d]#

It would be great if you could turn off line wrapping in your mailer.
Thanks.

 [root@jordan qmail-pop3d]# cat -e run
  #!/bin/sh$
 exec /usr/local/bin/softlimit -m 500 \$
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup
\$
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qma
 il-pop3d Maildir 21$
 $

It is hard to tell with the line wrapping, but after looking at your first
post of this file I believe the problem is that '/var/qmail/bin/qmail-pop3d`
is on a new line, when it should either be immediately after vchkpw or there
should be a \ as the last character on the vchkpw line.  Fix this, the pop3d
service should start within 5 seconds after its fixed.

What you have:
#!/bin/sh
   exec /usr/local/bin/softlimit -m 500 \
   /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
   alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
/var/qmail/bin/qmail-pop3d Maildir 21

What it should be:
#!/bin/sh
   exec /usr/local/bin/softlimit -m 500 \
   /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \
   alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw \
  /var/qmail/bin/qmail-pop3d Maildir 21

Good luck,

Cory


Hi Cory,thanks for the input. the wrapping is not from my email client it is
the fact that I am using ms telnet and that is wrapping the text - I can't
turn this off it is just ms telnet is rubbish.


I have added the / as you suggested, and the pop3 daemon starts up for 1
second then the status shows it never lives longer than a second.


[root@jordan qmail-pop3d]# ps ax|grep readproc
 1164 ?S  0:01 readproctitle service errors: ... unable to start
qma
il-pop3d/run: exec format error?supervise: fatal: unable to start
qmail-pop3d/ru
n: exec format error?supervise: fatal: unable to start qmail-pop3d/run: exec
for
mat error?supervise: fatal: unable to start qmail-pop3d/run: exec format
error?s
upervise: fatal: unable to start qmail-pop3d/run: exec format
error?supervise: f
atal: unable to start qmail-pop3d/run: exec format error?
 7056 pts/1R  0:00 grep readproc
[root@jordan qmail-pop3d]#


(sorry about the wrap - )

and the script now looks like

[root@jordan qmail-pop3d]# cat -e run
 #!/bin/sh$
exec /usr/local/bin/softlimit -m 500 \$
/usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup \$
alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw \
/var/qmail/bin/q
mail-pop3d Maildir 21$
$
[root@jordan qmail-pop3d]#


I still can't connect - I am assuming this is because pop3 daemon is not
staying up longer than 1 second. I am re-reading the vchkpw documents I used
to install and configure vpopmail and it mentions setting up the qmail-pop3d
run script referencing the pop3 service from /etc/services

[root@jordan qmail-pop3d]# cat /etc/services | grep pop
# unfortunately the poppassd (Eudora) uses a port which has already
# been assigned to a different service. We list the poppassd as an
#3com-tsmux 106/tcp poppassd
#3com-tsmux 106/udp poppassd
pop2109/tcp pop-2   postoffice  # POP version 2
pop2109/udp pop-2
pop3110/tcp pop-3   # POP version 3
pop3110/udp pop-3
pop3s   995/tcp # POP-3 over SSL
pop3s   995/udp # POP-3 over SSL
kpop1109/tcp# Pop with Kerberos
poppassd106/tcp # Eudora
poppassd106/udp # Eudora

I am assuming pop-3 is the correct alias to put in the run script (as you
can see above) should it be pop3 though ?

Thanks for your time on this,

Matt.








RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Matt Darcy


-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]
Sent: 30 December 2002 07:15
To: [EMAIL PROTECTED]
Subject: RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
logging.


Matt Darcy wrote:

  #!/bin/sh
 exec /usr/local/bin/softlimit -m 500 \
 /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup
\
 alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
 /var/qmail/bin/qmail-pop3d Maildir 21

 I can't see anything wrong with the startup script...

Well Matt from looking at this and the fact that I also run Redhat 7.3 I see
one thing wrong. Your default /etc/services file has your pop-3 as pop3.
There
are several ways to fix this, 1) either modify the /etc/services [bad idea],
2) Modify your run script to say pop3 [good choice], or 3) modify your run
script to say 110 instead of pop-3 [best choice, unless you use a different
port number]. Hope that helps some.

Joe



This the question I have just asked.I have modified the script again as
suggested to reference pop3 instead of pop-3.

I still cannot get the qmail-pop3d daemon to stay up longer than 1 second.

I need to know if 1 second is whats expected as I would not expect the pop3
daemon to stay up all the time just spawn when called. I could be wrong
though.

Thanks,

Matt.








RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread rm
On Mon, 2002-12-30 at 16:34, Matt Darcy wrote:
 
 
 -Original Message-
 From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]
 Sent: 30 December 2002 07:15
 To: [EMAIL PROTECTED]
 Subject: RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
 logging.
 
 
 Matt Darcy wrote:
 
   #!/bin/sh
  exec /usr/local/bin/softlimit -m 500 \
  /usr/local/bin/tcpserver -H -R 0 pop-3 /var/qmail/bin/qmail-popup
 \
  alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
  /var/qmail/bin/qmail-pop3d Maildir 21
 
  I can't see anything wrong with the startup script...
 
 Well Matt from looking at this and the fact that I also run Redhat 7.3 I see
 one thing wrong. Your default /etc/services file has your pop-3 as pop3.
 There
 are several ways to fix this, 1) either modify the /etc/services [bad idea],
 2) Modify your run script to say pop3 [good choice], or 3) modify your run
 script to say 110 instead of pop-3 [best choice, unless you use a different
 port number]. Hope that helps some.
 
 Joe
 
 
 
 This the question I have just asked.I have modified the script again as
 suggested to reference pop3 instead of pop-3.
 
 I still cannot get the qmail-pop3d daemon to stay up longer than 1 second.
 
 I need to know if 1 second is whats expected as I would not expect the pop3
 daemon to stay up all the time just spawn when called. I could be wrong
 though.
 
 Thanks,
 
 Matt.
 
 
 
The pop daemon should be up all the time.

You may want to check your qmailctl script for any possible errors in
calling the pop3 daemon.  Also, a few times I've had problems with
different text editors leaving some trash characters in the script when
I'v entered tabs of spaces.  That especially was a problem when I used
gedit (I run redhat too)

hope that helps some

good luck

regis
 
 






RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No logging.

2002-12-30 Thread Matt Darcy


-Original Message-
From: rm [mailto:[EMAIL PROTECTED]]
Sent: 30 December 2002 06:58
Cc: [EMAIL PROTECTED]; vchkpw mailing list
Subject: RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
logging.


On Mon, 2002-12-30 at 16:34, Matt Darcy wrote:


 -Original Message-
 From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]
 Sent: 30 December 2002 07:15
 To: [EMAIL PROTECTED]
 Subject: RE: [vchkpw] qmail/vpopmail cannot auth pop3 clients. No
 logging.


 Matt Darcy wrote:

   #!/bin/sh
  exec /usr/local/bin/softlimit -m 500 \
  /usr/local/bin/tcpserver -H -R 0 pop-3
/var/qmail/bin/qmail-popup
 \
  alesi.projecthugo.co.uk /home/vpopmail/bin/vchkpw
  /var/qmail/bin/qmail-pop3d Maildir 21
 
  I can't see anything wrong with the startup script...

 Well Matt from looking at this and the fact that I also run Redhat 7.3 I
see
 one thing wrong. Your default /etc/services file has your pop-3 as pop3.
 There
 are several ways to fix this, 1) either modify the /etc/services [bad
idea],
 2) Modify your run script to say pop3 [good choice], or 3) modify your run
 script to say 110 instead of pop-3 [best choice, unless you use a
different
 port number]. Hope that helps some.

 Joe



 This the question I have just asked.I have modified the script again
as
 suggested to reference pop3 instead of pop-3.

 I still cannot get the qmail-pop3d daemon to stay up longer than 1 second.

 I need to know if 1 second is whats expected as I would not expect the
pop3
 daemon to stay up all the time just spawn when called. I could be wrong
 though.

 Thanks,

 Matt.



The pop daemon should be up all the time.

You may want to check your qmailctl script for any possible errors in
calling the pop3 daemon.  Also, a few times I've had problems with
different text editors leaving some trash characters in the script when
I'v entered tabs of spaces.  That especially was a problem when I used
gedit (I run redhat too)

hope that helps some

good luck

regis


I'll check the qmailctl script - although I am quite sure it is working well
as the PID for pop3d keeps changing.


My text editor should be fine as it was vi, and I have checked it and it
looks ok. Good advice though. Any other options / suggestions ??

Thanks,

Matt.