Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb

2005-04-19 Thread Matt MacDougall
I think I may have misled you folks by mentioning how I've fixed this issue in 
the past.  I haven't been able to solve it this time no matter what I've been 
trying.  Anyone have a clue as to why even though permissions are set 
correctly, vpopmail still won't rebuild my tcp.smtp file?

Thanks everyone,

-Matt



On Monday 18 April 2005 08:14 pm, Matt MacDougall wrote:
 Thanks Rick.  I'm not seeing any open.smtp files in the dir:

 Here's the permissions:

 drwxr-xr-x  2 vpopmail  vchkpw  512 Apr 18 15:24 etc

 and the contents:

 -rw-r--r--  1 root  vchkpw29 Apr 18 15:22 inc_deps
 -rw-r--r--  1 root  vchkpw91 Apr 18 15:22 lib_deps
 -rw-r--r--  1 vpopmail  vchkpw   131 Apr 18 13:22 tcp.smtp
 -rw-r--r--  1 vpopmail  vchkpw  2243 Apr 18 15:24 tcp.smtp.cdb
 -rw-r--r--  1 vpopmail  vchkpw  1107 Apr 18 15:22 vlimits.default
 -rw-r-  1 vpopmail  vchkpw39 Apr 18 15:23 vpopmail.mysql

 I've setup a couple qmail boxes myself, ran into this issue and just fixed
 it by changing the owner of tcp.smtp.cdb from root to vpopmail ... so I'm
 pretty stumped at this point.

 I'd hate to go with smtp auth at this point cause that would mean schooling
 hundreds of clients on how to change their mail settings ... barf.

 See anything else sticking out here?

 -Matt




Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb

2005-04-18 Thread Rick Macdougall

Matt MacDougall wrote:
Hi,
I've poked around in the archives for an answer to this but don't notice 
anyone having this particular problem.

I've configured vpopmail with:
./configure --enable-logging=p --enable-auth-module=mysql --disable-passwd 
--enable-clear-passwd --disable-many-domains --enable-auth-logging 
--enable-sql-logging --enable-valias --disable-mysql-limits 
--enable-roaming-users

created /home/vpopmail/etc/tcp.smtp with:
127.:allow,RELAYCLIENT=
and performed the following to have tcprules build my initial db:
tcprules /home/vpopmail/etc/tcp.smtp.cdb /home/vpopmail/etc/tcp.smtp.tmp 
 /home/vpopmail/etc/tcp.smtp
chown vpopmail:vchkpw /home/vpopmail/etc/tcp.smtp*
chmod 644 /home/vpopmail/etc/tcp.smtp.cdb

I've messed with this for a while, done a reinstall and yet I still can't get 
vpopmail to add entries to the tcp.smtp.cdb on pop authentication.  I feel 
like I'm missing something really stupid here.

Has anyone run into this issue and solved it?  Any help or direction is 
greatly appreciated.
Hi Matt,
What pop daemon are you using and what version ?
Regards,
Rick Macdougall
Yes, a lowercase D :)


Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb

2005-04-18 Thread Matt MacDougall
Hey Rick,

Thanks for the quick reply.  I'll just have to forgive the lowercase D ... :-)

I'm just using the popd that comes with qmail I believe.  It's qmail-pop3d 
version 1.03

Here's the output of my run file /var/qmail/supervise/qmail-pop3d/run

#!/bin/sh
PATH=/var/qmail/bin:/usr/local/bin:/usr/bin:/bin
export PATH
exec tcpserver -H -R -v -c100 0 110 qmail-popup mx1.pwim.com \
/usr/home/vpopmail/bin/vchkpw qmail-pop3d Maildir 21

Is that what you're looking for?

Thanks,

-Matt


On Monday 18 April 2005 06:24 pm, Rick Macdougall wrote:
 Matt MacDougall wrote:
  Hi,
 
  I've poked around in the archives for an answer to this but don't notice
  anyone having this particular problem.
 
  I've configured vpopmail with:
 
  ./configure --enable-logging=p --enable-auth-module=mysql
  --disable-passwd --enable-clear-passwd --disable-many-domains
  --enable-auth-logging --enable-sql-logging --enable-valias
  --disable-mysql-limits
  --enable-roaming-users
 
  created /home/vpopmail/etc/tcp.smtp with:
 
  127.:allow,RELAYCLIENT=
 
  and performed the following to have tcprules build my initial db:
 
  tcprules /home/vpopmail/etc/tcp.smtp.cdb /home/vpopmail/etc/tcp.smtp.tmp
   /home/vpopmail/etc/tcp.smtp
  chown vpopmail:vchkpw /home/vpopmail/etc/tcp.smtp*
  chmod 644 /home/vpopmail/etc/tcp.smtp.cdb
 
  I've messed with this for a while, done a reinstall and yet I still can't
  get vpopmail to add entries to the tcp.smtp.cdb on pop authentication.  I
  feel like I'm missing something really stupid here.
 
  Has anyone run into this issue and solved it?  Any help or direction is
  greatly appreciated.

 Hi Matt,

 What pop daemon are you using and what version ?

 Regards,

 Rick Macdougall

 Yes, a lowercase D :)



Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb

2005-04-18 Thread Rick Macdougall

Matt MacDougall wrote:
Hey Rick,
Thanks for the quick reply.  I'll just have to forgive the lowercase D ... :-)
I'm just using the popd that comes with qmail I believe.  It's qmail-pop3d 
version 1.03

Here's the output of my run file /var/qmail/supervise/qmail-pop3d/run
#!/bin/sh
PATH=/var/qmail/bin:/usr/local/bin:/usr/bin:/bin
export PATH
exec tcpserver -H -R -v -c100 0 110 qmail-popup mx1.pwim.com \
/usr/home/vpopmail/bin/vchkpw qmail-pop3d Maildir 21
Is that what you're looking for?
Thanks,
Hi,
Yah, thanks for forgiving the lowercase D, blame it on my great grandfather.
Yup, that qmail-popup was what I was looking for as I think the latest 
version of courier doesn't support pop-before smtp.

The only difference I can see in your setup vs the servers I setup for 
clients is the --disable-many-domains.  Other than that it's the same as 
mine and it works.

Perhaps the permissions on the /home/vpopmail/etc directory are wrong ? 
 Do you see any open.smtp files in that directory ?

Regards,
Rick


Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb

2005-04-18 Thread Matt MacDougall
Thanks Rick.  I'm not seeing any open.smtp files in the dir:

Here's the permissions:

drwxr-xr-x  2 vpopmail  vchkpw  512 Apr 18 15:24 etc

and the contents:

-rw-r--r--  1 root  vchkpw29 Apr 18 15:22 inc_deps
-rw-r--r--  1 root  vchkpw91 Apr 18 15:22 lib_deps
-rw-r--r--  1 vpopmail  vchkpw   131 Apr 18 13:22 tcp.smtp
-rw-r--r--  1 vpopmail  vchkpw  2243 Apr 18 15:24 tcp.smtp.cdb
-rw-r--r--  1 vpopmail  vchkpw  1107 Apr 18 15:22 vlimits.default
-rw-r-  1 vpopmail  vchkpw39 Apr 18 15:23 vpopmail.mysql

I've setup a couple qmail boxes myself, ran into this issue and just fixed it 
by changing the owner of tcp.smtp.cdb from root to vpopmail ... so I'm pretty 
stumped at this point.

I'd hate to go with smtp auth at this point cause that would mean schooling 
hundreds of clients on how to change their mail settings ... barf.

See anything else sticking out here?

-Matt

Original Message:

Return-Path: [EMAIL PROTECTED] Mon, 18 Apr 2005 17:07:38
Received: from www.inter7.com [65.160.227.199] by mail.pwim.com with SMTP;
   Mon, 18 Apr 2005 17:07:38 -0700
Received: (qmail 6944 invoked by uid 89); 19 Apr 2005 00:07:30 -
Mailing-List: contact [EMAIL PROTECTED]; run by ezmlm
Precedence: bulk
List-Post: mailto:vchkpw@inter7.com
List-Help: mailto:[EMAIL PROTECTED]
List-Unsubscribe: mailto:[EMAIL PROTECTED]
List-Subscribe: mailto:[EMAIL PROTECTED]
Reply-To: vchkpw@inter7.com
Delivered-To: mailing list vchkpw@inter7.com
Received: (qmail 6938 invoked by uid 0); 19 Apr 2005 00:07:30 -
Message-ID: [EMAIL PROTECTED]
Date: Mon, 18 Apr 2005 20:07:24 -0400
From: Rick Macdougall [EMAIL PROTECTED]
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To:  vchkpw@inter7.com
References: [EMAIL PROTECTED] [EMAIL PROTECTED] [EMAIL PROTECTED]
In-Reply-To: [EMAIL PROTECTED]
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Subject: Re: [vchkpw] can't get vpopmail to rebuild tcp.smtp.cdb




Matt MacDougall wrote:
 Hey Rick,
 
 Thanks for the quick reply.  I'll just have to forgive the lowercase D ... 
 :-)
 
 I'm just using the popd that comes with qmail I believe.  It's qmail-pop3d 
 version 1.03
 
 Here's the output of my run file /var/qmail/supervise/qmail-pop3d/run
 
 #!/bin/sh
 PATH=/var/qmail/bin:/usr/local/bin:/usr/bin:/bin
 export PATH
 exec tcpserver -H -R -v -c100 0 110 qmail-popup mx1.pwim.com \
 /usr/home/vpopmail/bin/vchkpw qmail-pop3d Maildir 21
 
 Is that what you're looking for?
 
 Thanks,
 

Hi,

Yah, thanks for forgiving the lowercase D, blame it on my great grandfather.

Yup, that qmail-popup was what I was looking for as I think the latest 
version of courier doesn't support pop-before smtp.

The only difference I can see in your setup vs the servers I setup for 
clients is the --disable-many-domains.  Other than that it's the same as 
mine and it works.

Perhaps the permissions on the /home/vpopmail/etc directory are wrong ? 
  Do you see any open.smtp files in that directory ?

Regards,

Rick