Author: jfthomps
Date: Fri Jul 16 17:58:12 2010
New Revision: 964890

URL: http://svn.apache.org/viewvc?rev=964890&view=rev
Log:
VCL-272

Block Reservations were renamed to Block Allocation - all modified files had 
references to block reservations changed to block allocations.

Split out all block allocation stuff from requests.php and requests.js to 
blockallocations.php and blockallocations.js

This ended up being a complete rewrite of all of the block allocation forms to 
be much more web 2.0 based.

xmlrpcWrappers.php:
-modified XMLRPCblockAllocation - changed name of 4th parameter to 
$numMachines; added status field to insert query
-modified XMLRPCprocessBlockTime - just name changes

utils.php:
-modified initGlobals - added include for appropriate states for 
blockallocations.php
-modified dbConnect - moved connecting to $accthost to before connecting to 
$vclhost so that mysql calls that default to last connected link resource will 
use vcl resource instead of accounts resource
-moved removeNoCheckout to here from requests.php
-modified getBlockRequestIDS - changed name to getBlockAllocationIDs; added 
status = 'accepted' to WHERE clause
-added hour24to12
-modified getAvailableBlockComputerids - added status = 'accepted' to WHERE 
clause
-modified getBlockTimeData - filled in more of the return info for the header 
stub; added status = 'accepted' to WHERE clause
-renamed isBlockRequestTime to isBlockAllocationTime
-modified getDojoHTML - added stuff for blockAllocations, 
requestBlockAllocation, newBlockAllocation, and editBlockAllocation; added 
default entry so that dojo.js and dojo.requires are added automatically if 
nothing specific is needed for a mode

states.php:
-changed blockRequest to blockAllocations
-added requestBlockAllocation to entry actions
-added AJblockAllocationSubmit, AJpopulateBlockStore, 
AJdeleteBlockAllocationConfirm, AJdeleteBlockAllocationSubmit, 
AJacceptBlockAllocationConfirm, AJacceptBlockAllocationSubmit, 
AJrejectBlockAllocationConfirm, and AJrejectBlockAllocationSubmit to 
noHTMLwrappers array
-changed blockReservations page name to blockAllocations
-redid almost all modes for blockAllocations

requests.php:
-removed defines for IMAGEIDERR, BLOCKCNTERR, USERGROUPIDERR, AVAILABLEERR, 
WEEKNUMERR, DAYERR, BLOCKNAMEERR, and ADMINGROUPIDERR
-commented out defines for ENDDAYERR and ENDHOURERR
-moved all block allocation functions to blockallocations.php
-moved removeNoCheckout to utils.php

errors.php:
-added "114" => "Failed to get start date in getPendingBlockHTML"

conf.php:
-added $blockNotifyUsers

themes/default/css/vcl.css:
-commented out margin for '.default #content table'

js/requests.js:
-moved updateBlockStatus and updateBlockStatusCB to blockallocations.js

initial import of the following items:
-blockallocations.php
-images/helpicon.png
-js/vcldojo
-js/vcldojo/TimeTextBoxEnd.js
-js/blockallocations.js

Added:
    incubator/vcl/trunk/web/.ht-inc/blockallocations.php
    incubator/vcl/trunk/web/images/helpicon.png   (with props)
    incubator/vcl/trunk/web/js/blockallocations.js
    incubator/vcl/trunk/web/js/vcldojo/
    incubator/vcl/trunk/web/js/vcldojo/TimeTextBoxEnd.js
Modified:
    incubator/vcl/trunk/web/.ht-inc/conf.php
    incubator/vcl/trunk/web/.ht-inc/errors.php
    incubator/vcl/trunk/web/.ht-inc/requests.php
    incubator/vcl/trunk/web/.ht-inc/states.php
    incubator/vcl/trunk/web/.ht-inc/utils.php
    incubator/vcl/trunk/web/.ht-inc/xmlrpcWrappers.php
    incubator/vcl/trunk/web/js/requests.js
    incubator/vcl/trunk/web/themes/default/css/vcl.css

Reply via email to