Re: Summarizing encoding issues

2007-10-18 Fir de Conversatie Tony Mechelynck
DervishD wrote: Hi Yongwei :) * Yongwei Wu [EMAIL PROTECTED] dixit: On 17/10/2007, Ben Schmidt [EMAIL PROTECTED] wrote: Note that because of this buggy behaviour, Vim's default value for fencs is non-sensical: it will always succeed when it gets to utf-8 when enc=utf-8 without trying

Re: Patch for VIM dosbatch syntax file

2007-10-18 Fir de Conversatie Alexei Alexandrov
On Oct 18, 2:40 am, Tony Mechelynck [EMAIL PROTECTED] wrote: Alexei, why _four_ copies (to date) of this post? If you didn't get them yourself, check your gmail spam folder. Sorry, my Thunderbird screwed it up due to a wrong SMTP server setting. Every time it would say that it failed to

Re: Patch for VIM dosbatch syntax file

2007-10-18 Fir de Conversatie Mike Williams
On 17/10/2007 20:55, Alexei Alexandrov wrote: Hi Mike, In the VIM 7.1 distribution runtime files you're listed as the maintainer of dosbatch.vim file which is a syntax file for Windows/DOS batch files. Currently this syntax file doesn't list correctly @Spell/@NoSpell attributes of

Wish: opposite to split() ...

2007-10-18 Fir de Conversatie Andy Wokula
... and I don't mean join(). I'd like to have a function like split(), except for it should collect all the _matches_ in a list. matchlist() would be a good name for it, unfortunately it's already taken. How would I do it now? -- Andy --~--~-~--~~~---~--~~

Re: Wish: opposite to split() ...

2007-10-18 Fir de Conversatie Tony Mechelynck
Andy Wokula wrote: ... and I don't mean join(). I'd like to have a function like split(), except for it should collect all the _matches_ in a list. matchlist() would be a good name for it, unfortunately it's already taken. How would I do it now? untested note: name, if not

Re: Wish: opposite to split() ...

2007-10-18 Fir de Conversatie Ben Schmidt
Andy Wokula wrote: ... and I don't mean join(). I'd like to have a function like split(), except for it should collect all the _matches_ in a list. matchlist() would be a good name for it, unfortunately it's already taken. How would I do it now? A naive and inefficient but simple

Re: Wish: opposite to split() ...

2007-10-18 Fir de Conversatie thomas
:echo ListOfMatches(abracadabra,a.) ['ab', 'ac', 'ad', 'ab'] Not so efficient, but: echo map(split('abracadabra', '\zea.'), 'matchstr(v:val, ''a.'')') Maybe, one could call such a function scan(). --~--~-~--~~~---~--~~ You received this message from the

Re: Wish: opposite to split() ...

2007-10-18 Fir de Conversatie Andy Wokula
Tony Mechelynck schrieb: Andy Wokula wrote: ... and I don't mean join(). I'd like to have a function like split(), except for it should collect all the _matches_ in a list. matchlist() would be a good name for it, unfortunately it's already taken. How would I do it now? untested

Re: Convert dot command into macro

2007-10-18 Fir de Conversatie Ben Schmidt
Here is a patch to Vim that adds a , register which is basically access to Vim's internal 'redo buffer' used when '.' is used. At a quick look, it seems to work. You can thus save your '.' commands to another register and replay them later: :let @a=@, @a I believe @, will have pretty