Re: [PATCH v2 RFC 3/3] virtio_ccw: invoke virtio_driver's notify() on CIO_GONE notification

2013-11-27 Thread Heinz Graalfs
On 21/11/13 19:31, Michael S. Tsirkin wrote: On Thu, Nov 21, 2013 at 06:12:21PM +0100, Heinz Graalfs wrote: On 21/11/13 16:15, Michael S. Tsirkin wrote: On Thu, Nov 21, 2013 at 03:45:33PM +0100, Heinz Graalfs wrote: virtio_ccw's notify() callback for the common IO layer invokes

[PATCH v3 RFC 4/4] virtio_ccw: set surprize_removal in virtio_device if a device was lost

2013-11-27 Thread Heinz Graalfs
Code is added to the notify handler to set the 'surprize_removal' flag in virtio_device in case a CIO_GONE notification occurs. The remove callback of the backend driver must check this flag in order to perform special processing for a lost device. Signed-off-by: Heinz Graalfs

[PATCH v3 RFC 2/4] virtio_blk: avoid further request queueing on device loss

2013-11-27 Thread Heinz Graalfs
Code is added to the remove callback to verify if a device was lost. In case of a device loss further request queueing should be prevented by setting appropriate queue flags prior to invoking del_gendisk(). Blocking of request queueing leads to appropriate I/O errors when data are tried to be

[PATCH v3 RFC 0/4] virtio: add 'surprize_removal' to virtio_device

2013-11-27 Thread Heinz Graalfs
Hi, here is an updated patch-set to my v2 RFC virtio: add new notify() callback to virtio_driver This RFC introduces a new virtio_device entry 'surprize_removal' instead of a new 'notify' callback in struct virtio_driver. When an active virtio block device is hot-unplugged from a KVM guest,

[PATCH v3 RFC 1/4] virtio: add surprize_removal to virtio_device

2013-11-27 Thread Heinz Graalfs
Add new entry surprize_removal to struct virtio_device. When a virtio transport driver is notified about a lost device it should set surprize_removal to true. A backend driver can test this flag in order to perform specific actions that might be appropriate wrt the device loss. Signed-off-by:

[PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Heinz Graalfs
Code is added to avoid calling blk_cleanup_queue() when the surprize_removal flag is set due to a disappeared device. It avoid hangs due to incomplete requests (e.g. in-flight requests). Such requests must be considered as lost. If the current remove callback was triggered due to an unregister

Re: [PATCH v2 RFC 3/3] virtio_ccw: invoke virtio_driver's notify() on CIO_GONE notification

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 11:32:07AM +0100, Heinz Graalfs wrote: On 21/11/13 19:31, Michael S. Tsirkin wrote: On Thu, Nov 21, 2013 at 06:12:21PM +0100, Heinz Graalfs wrote: On 21/11/13 16:15, Michael S. Tsirkin wrote: On Thu, Nov 21, 2013 at 03:45:33PM +0100, Heinz Graalfs wrote: virtio_ccw's

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added to avoid calling blk_cleanup_queue() when the surprize_removal flag is set due to a disappeared device. It avoid hangs due to incomplete requests (e.g. in-flight requests). Such requests must be considered as lost.

Re: [PATCH v3 RFC 4/4] virtio_ccw: set surprize_removal in virtio_device if a device was lost

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 11:32:40AM +0100, Heinz Graalfs wrote: Code is added to the notify handler to set the 'surprize_removal' flag in virtio_device in case a CIO_GONE notification occurs. The remove callback of the backend driver must check this flag in order to perform special processing

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Heinz Graalfs
On 27/11/13 11:47, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added to avoid calling blk_cleanup_queue() when the surprize_removal flag is set due to a disappeared device. It avoid hangs due to incomplete requests (e.g. in-flight requests).

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 12:37:02PM +0100, Heinz Graalfs wrote: On 27/11/13 11:47, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added to avoid calling blk_cleanup_queue() when the surprize_removal flag is set due to a disappeared device. It

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 12:37:02PM +0100, Heinz Graalfs wrote: On 27/11/13 11:47, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added to avoid calling blk_cleanup_queue() when the surprize_removal flag is set due to a disappeared device. It

Re: Re: Re: [PATCH -tip v3 00/23] kprobes: introduce NOKPROBE_SYMBOL() and general cleaning of kprobe blacklist

2013-11-27 Thread Ingo Molnar
* Masami Hiramatsu masami.hiramatsu...@hitachi.com wrote: (2013/11/22 11:35), Masami Hiramatsu wrote: (2013/11/21 16:29), Ingo Molnar wrote: * Masami Hiramatsu masami.hiramatsu...@hitachi.com wrote: (2013/11/21 2:36), Frank Ch. Eigler wrote: [ ... ] one needs to resort to

Re: [PATCH -tip v3 02/23] kprobes: Introduce NOKPROBE_SYMBOL() macro for blacklist

2013-11-27 Thread Ingo Molnar
* Masami Hiramatsu masami.hiramatsu...@hitachi.com wrote: +#ifdef CONFIG_KPROBES +/* + * Blacklist ganerating macro. Specify functions which is not probed + * by using this macro. + */ +#define __NOKPROBE_SYMBOL(fname) \ +static struct kprobe_blackpoint __used

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Heinz Graalfs
On 27/11/13 13:49, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 12:37:02PM +0100, Heinz Graalfs wrote: On 27/11/13 11:47, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added to avoid calling blk_cleanup_queue() when the surprize_removal

Re: [PATCH v3 RFC 3/4] virtio_blk: avoid calling blk_cleanup_queue() on device loss

2013-11-27 Thread Michael S. Tsirkin
On Wed, Nov 27, 2013 at 03:15:45PM +0100, Heinz Graalfs wrote: On 27/11/13 13:49, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 12:37:02PM +0100, Heinz Graalfs wrote: On 27/11/13 11:47, Michael S. Tsirkin wrote: On Wed, Nov 27, 2013 at 11:32:39AM +0100, Heinz Graalfs wrote: Code is added

[PATCH 2/2] virtio-net: make all RX paths handle erors consistently

2013-11-27 Thread Michael S. Tsirkin
receive mergeable now handles errors internally. Do same for big and small packet paths, otherwise the logic is too hard to follow. Signed-off-by: Michael S. Tsirkin m...@redhat.com --- While I can't point at a bug this fixes, I'm not sure there's no bug in the existing logic. So not exactly a

[PATCH 1/2] virtio_net: fix error handling for mergeable buffers

2013-11-27 Thread Michael S. Tsirkin
Eric Dumazet noticed that if we encounter an error when processing a mergeable buffer, we don't dequeue all of the buffers from this packet, the result is almost sure to be loss of networking. Jason Wang noticed that we also leak a page and that we don't decrement the rq buf count, so we won't

Re: [PATCH char-misc-linus v3 0/6] misc: mic: Fixes for 3.13-final

2013-11-27 Thread Greg Kroah-Hartman
On Wed, Nov 27, 2013 at 08:58:37AM -0800, Ashutosh Dixit wrote: These patches fix various issues which were reported or found with the MIC driver. All now applied, thanks. greg k-h ___ Virtualization mailing list

Re: [PATCH 1/2] virtio_net: fix error handling for mergeable buffers

2013-11-27 Thread Jason Wang
On 11/28/2013 12:31 AM, Michael S. Tsirkin wrote: Eric Dumazet noticed that if we encounter an error when processing a mergeable buffer, we don't dequeue all of the buffers from this packet, the result is almost sure to be loss of networking. Jason Wang noticed that we also leak a page and

Re: [PATCH 2/2] virtio-net: make all RX paths handle erors consistently

2013-11-27 Thread Jason Wang
On 11/28/2013 12:31 AM, Michael S. Tsirkin wrote: receive mergeable now handles errors internally. Do same for big and small packet paths, otherwise the logic is too hard to follow. Signed-off-by: Michael S. Tsirkin m...@redhat.com --- While I can't point at a bug this fixes, I'm not sure

Re: [PATCH -tip v3 02/23] kprobes: Introduce NOKPROBE_SYMBOL() macro for blacklist

2013-11-27 Thread Masami Hiramatsu
(2013/11/27 22:32), Ingo Molnar wrote: * Masami Hiramatsu masami.hiramatsu...@hitachi.com wrote: +#ifdef CONFIG_KPROBES +/* + * Blacklist ganerating macro. Specify functions which is not probed + * by using this macro. + */ +#define __NOKPROBE_SYMBOL(fname)\