[PATCH v1] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Tiwei Bie
This patch introduces the support for VIRTIO_F_IO_BARRIER. When this feature is negotiated, driver will use the barriers suitable for hardware devices. Signed-off-by: Tiwei Bie --- This patch depends on below proposal for virtio-spec:

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Tiwei Bie
On Thu, May 03, 2018 at 08:57:20PM +0300, Michael S. Tsirkin wrote: > On Thu, May 03, 2018 at 10:59:55AM +0800, Tiwei Bie wrote: > > This patch introduces the support for VIRTIO_F_IO_BARRIER. > > When this feature is negotiated, driver will use the barriers > > suitable for hardware devices. > >

Re: [PATCH 0/6] virtio-console: spec compliance fixes

2018-05-03 Thread Michael S. Tsirkin
On Thu, May 03, 2018 at 05:45:29AM +0200, Amit Shah wrote: > (apologies if you received a dup) > > On (Tue) 24 Apr 2018 [21:41:29], Michael S. Tsirkin wrote: > > On Fri, Apr 20, 2018 at 09:17:59PM +0300, Michael S. Tsirkin wrote: > > > Turns out virtio console tries to take a buffer out of an

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Michael S. Tsirkin
On Thu, May 03, 2018 at 10:59:55AM +0800, Tiwei Bie wrote: > This patch introduces the support for VIRTIO_F_IO_BARRIER. > When this feature is negotiated, driver will use the barriers > suitable for hardware devices. > > Signed-off-by: Tiwei Bie Thanks! > --- >

Re: [dm-devel] [PATCH v5] fault-injection: introduce kvmalloc fallback options

2018-05-03 Thread Mikulas Patocka
On Wed, 2 May 2018, John Stoffel wrote: > You miss my point, which is that there's no explanation of what the > difference is between SLAB and SLUB and which I should choose. The > same goes here. If the KConfig option doesn't give useful info, it's > useless. So what, we could write

Re: [PATCH] kvmalloc: always use vmalloc if CONFIG_DEBUG_VM

2018-05-03 Thread Mikulas Patocka
On Tue, 1 May 2018, Andrew Morton wrote: > On Tue, 24 Apr 2018 12:33:01 -0400 (EDT) Mikulas Patocka > wrote: > > > > > > > On Tue, 24 Apr 2018, Michal Hocko wrote: > > > > > On Tue 24-04-18 11:30:40, Mikulas Patocka wrote: > > > > > > > > > > > > On Tue, 24 Apr

[PATCH 11/15] drm/qxl: Remove unecessary dma_fence_ops

2018-05-03 Thread Daniel Vetter
The trivial enable_signaling implementation matches the default code. v2: Fix up commit message to match patch better (Eric). Cc: Eric Anholt Reviewed-by: Eric Anholt Signed-off-by: Daniel Vetter Cc: Dave Airlie

[PATCH 14/15] drm/virtio: Remove unecessary dma_fence_ops

2018-05-03 Thread Daniel Vetter
dma_fence_default_wait is the default now, same for the trivial enable_signaling implementation. Reviewed-by: Eric Anholt Signed-off-by: Daniel Vetter Cc: David Airlie Cc: Gerd Hoffmann Cc:

Re: [RFC v3 4/5] virtio_ring: add event idx support in packed ring

2018-05-03 Thread Tiwei Bie
On Thu, May 03, 2018 at 03:25:29PM +0800, Jason Wang wrote: > On 2018年05月03日 10:09, Tiwei Bie wrote: > > > > > So how about we use the straightforward way then? > > > > You mean we do new += vq->vring_packed.num instead > > > > of event_idx -= vq->vring_packed.num before calling > > > >

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Stefan Hajnoczi
On Thu, May 3, 2018 at 2:26 PM, Tiwei Bie wrote: > On Thu, May 03, 2018 at 10:06:52AM +0100, Stefan Hajnoczi wrote: >> On Thu, May 03, 2018 at 10:59:55AM +0800, Tiwei Bie wrote: >> > This patch introduces the support for VIRTIO_F_IO_BARRIER. >> > When this feature is

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Tiwei Bie
On Thu, May 03, 2018 at 10:06:52AM +0100, Stefan Hajnoczi wrote: > On Thu, May 03, 2018 at 10:59:55AM +0800, Tiwei Bie wrote: > > This patch introduces the support for VIRTIO_F_IO_BARRIER. > > When this feature is negotiated, driver will use the barriers > > suitable for hardware devices. > > > >

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Jason Wang
On 2018年05月03日 17:58, Tiwei Bie wrote: On Thu, May 03, 2018 at 05:09:44PM +0800, Jason Wang wrote: On 2018年05月03日 16:30, Tiwei Bie wrote: On Thu, May 03, 2018 at 03:30:03PM +0800, Jason Wang wrote: On 2018年05月03日 10:59, Tiwei Bie wrote: This patch introduces the support for

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Stefan Hajnoczi
On Thu, May 03, 2018 at 10:59:55AM +0800, Tiwei Bie wrote: > This patch introduces the support for VIRTIO_F_IO_BARRIER. > When this feature is negotiated, driver will use the barriers > suitable for hardware devices. > > Signed-off-by: Tiwei Bie I should have thought of

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Tiwei Bie
On Thu, May 03, 2018 at 05:09:44PM +0800, Jason Wang wrote: > On 2018年05月03日 16:30, Tiwei Bie wrote: > > On Thu, May 03, 2018 at 03:30:03PM +0800, Jason Wang wrote: > > > On 2018年05月03日 10:59, Tiwei Bie wrote: > > > > This patch introduces the support for VIRTIO_F_IO_BARRIER. > > > > When this

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Jason Wang
On 2018年05月03日 16:30, Tiwei Bie wrote: On Thu, May 03, 2018 at 03:30:03PM +0800, Jason Wang wrote: On 2018年05月03日 10:59, Tiwei Bie wrote: This patch introduces the support for VIRTIO_F_IO_BARRIER. When this feature is negotiated, driver will use the barriers suitable for hardware devices.

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Tiwei Bie
On Thu, May 03, 2018 at 03:30:03PM +0800, Jason Wang wrote: > On 2018年05月03日 10:59, Tiwei Bie wrote: > > This patch introduces the support for VIRTIO_F_IO_BARRIER. > > When this feature is negotiated, driver will use the barriers > > suitable for hardware devices. > > > > Signed-off-by: Tiwei Bie

Re: [RFC] virtio: support VIRTIO_F_IO_BARRIER

2018-05-03 Thread Jason Wang
On 2018年05月03日 10:59, Tiwei Bie wrote: This patch introduces the support for VIRTIO_F_IO_BARRIER. When this feature is negotiated, driver will use the barriers suitable for hardware devices. Signed-off-by: Tiwei Bie --- drivers/virtio/virtio_ring.c | 5 +

Re: [RFC v3 4/5] virtio_ring: add event idx support in packed ring

2018-05-03 Thread Jason Wang
On 2018年05月03日 10:09, Tiwei Bie wrote: So how about we use the straightforward way then? You mean we do new += vq->vring_packed.num instead of event_idx -= vq->vring_packed.num before calling vring_need_event()? The problem is that, the second param (new_idx) of vring_need_event() will be

Re: [RFC V3 PATCH 1/8] vhost: move get_rx_bufs to vhost.c

2018-05-03 Thread Jason Wang
On 2018年05月02日 16:05, Tiwei Bie wrote: On Mon, Apr 23, 2018 at 01:34:53PM +0800, Jason Wang wrote: Move get_rx_bufs() to vhost.c and rename it to vhost_get_rx_bufs(). This helps to hide vring internal layout from A small typo. Based on the code change in this patch, it seems that this