Re: [PATCH v7 net-next 2/4] net: Introduce generic failover module

2018-04-22 Thread Michael S. Tsirkin
On Thu, Apr 19, 2018 at 06:42:02PM -0700, Sridhar Samudrala wrote: > +#if IS_ENABLED(CONFIG_NET_FAILOVER) > + > +int failover_create(struct net_device *standby_dev, > + struct failover **pfailover); Should we rename all these structs net_failover? It's possible to extend the

Re: [PATCH v7 net-next 2/4] net: Introduce generic failover module

2018-04-22 Thread kbuild test robot
] url: https://github.com/0day-ci/linux/commits/Sridhar-Samudrala/Enable-virtio_net-to-act-as-a-standby-for-a-passthru-device/20180422-210557 reproduce: # apt-get install sparse make ARCH=x86_64 allmodconfig make C=1 CF=-D__CHECK_ENDIAN__ sparse warnings: (new ones

Re: [RFC v2] virtio: support packed ring

2018-04-22 Thread Jason Wang
On 2018年04月01日 22:12, Tiwei Bie wrote: Hello everyone, This RFC implements packed ring support for virtio driver. The code was tested with DPDK vhost (testpmd/vhost-PMD) implemented by Jens at http://dpdk.org/ml/archives/dev/2018-January/089417.html Minor changes are needed for the vhost

[RFC V3 PATCH 5/8] vhost: vhost_put_user() can accept metadata type

2018-04-22 Thread Jason Wang
We assumes used ring update is the only user for vhost_put_user() in the past. This may not be the case for the incoming packed ring which may update the descriptor ring for used. So introduce a new type parameter. Signed-off-by: Jason Wang --- drivers/vhost/vhost.c | 14

[RFC V3 PATCH 3/8] vhost: do not use vring_used_elem

2018-04-22 Thread Jason Wang
Instead of depending on the exported vring_used_elem, this patch switches to use a new internal structure vhost_used_elem which embed vring_used_elem in itself. This could be used to let vhost to record extra metadata for the incoming packed ring layout. Signed-off-by: Jason Wang

[RFC V3 PATCH 2/8] vhost: hide used ring layout from device

2018-04-22 Thread Jason Wang
We used to return descriptor head by vhost_get_vq_desc() to device and pass it back to vhost_add_used() and its friends. This exposes the internal used ring layout to device which makes it hard to be extended for e.g packed ring layout. So this patch tries to hide the used ring layout by -

[RFC V3 PATCH 4/8] vhost_net: do not explicitly manipulate vhost_used_elem

2018-04-22 Thread Jason Wang
Two helpers of setting/getting used len were introduced to avoid explicitly manipulating vhost_used_elem in zerocopy code. This will be used to hide used_elem internals and simplify packed ring implementation. Signed-off-by: Jason Wang --- drivers/vhost/net.c | 11

[RFC V3 PATCH 1/8] vhost: move get_rx_bufs to vhost.c

2018-04-22 Thread Jason Wang
Move get_rx_bufs() to vhost.c and rename it to vhost_get_rx_bufs(). This helps to hide vring internal layout from specific device implementation. Packed ring implementation will benefit from this. Signed-off-by: Jason Wang --- drivers/vhost/net.c | 83

[RFC V3 PATCH 0/8] Packed ring for vhost

2018-04-22 Thread Jason Wang
Hi all: This RFC implement packed ring layout. The code were tested with Tiwei's RFC V2 a thttps://lkml.org/lkml/2018/4/1/48. Some fixups and tweaks were needed on top of Tiwei's code to make it run. TCP stream and pktgen does not show obvious difference compared with split ring. Changes from

Re: [PATCH] drm/virtio: fix vq wait_event condition

2018-04-22 Thread Dave Airlie
On 20 April 2018 at 17:22, Gerd Hoffmann wrote: > On Tue, Apr 03, 2018 at 11:59:04AM +0200, Gerd Hoffmann wrote: >> Wait until we have enough space in the virt queue to actually queue up >> our request. Avoids the guest spinning in case we have a non-zero >> amount of free

[RFC V3 PATCH 6/8] virtio: introduce packed ring defines

2018-04-22 Thread Jason Wang
Signed-off-by: Jason Wang --- include/uapi/linux/virtio_config.h | 9 + include/uapi/linux/virtio_ring.h | 13 + 2 files changed, 22 insertions(+) diff --git a/include/uapi/linux/virtio_config.h b/include/uapi/linux/virtio_config.h index

[RFC V3 PATCH 7/8] vhost: packed ring support

2018-04-22 Thread Jason Wang
Signed-off-by: Jason Wang --- drivers/vhost/net.c | 3 +- drivers/vhost/vhost.c | 535 ++ drivers/vhost/vhost.h | 8 +- 3 files changed, 509 insertions(+), 37 deletions(-) diff --git a/drivers/vhost/net.c

[RFC V3 PATCH 8/8] vhost: event suppression for packed ring

2018-04-22 Thread Jason Wang
This patch introduces basic support for event suppression aka driver and device area. Signed-off-by: Jason Wang --- drivers/vhost/vhost.c| 170 --- drivers/vhost/vhost.h| 10 ++- include/uapi/linux/virtio_ring.h |

Re: [PATCH v7 net-next 4/4] netvsc: refactor notifier/event handling code to use the failover framework

2018-04-22 Thread kbuild test robot
: https://github.com/0day-ci/linux/commits/Sridhar-Samudrala/Enable-virtio_net-to-act-as-a-standby-for-a-passthru-device/20180422-210557 config: x86_64-allyesdebian (attached as .config) compiler: gcc-7 (Debian 7.3.0-16) 7.3.0 reproduce: # save the attached .config to linux build tree

Re: [PATCH v7 net-next 3/4] virtio_net: Extend virtio to use VF datapath when available

2018-04-22 Thread kbuild test robot
: https://github.com/0day-ci/linux/commits/Sridhar-Samudrala/Enable-virtio_net-to-act-as-a-standby-for-a-passthru-device/20180422-210557 config: i386-randconfig-x071-201816 (attached as .config) compiler: gcc-7 (Debian 7.3.0-16) 7.3.0 reproduce: # save the attached .config to linux build tree

Re: [PATCH v7 net-next 3/4] virtio_net: Extend virtio to use VF datapath when available

2018-04-22 Thread kbuild test robot
] url: https://github.com/0day-ci/linux/commits/Sridhar-Samudrala/Enable-virtio_net-to-act-as-a-standby-for-a-passthru-device/20180422-210557 config: i386-randconfig-a1-04221429 (attached as .config) compiler: gcc-4.9 (Debian 4.9.4-2) 4.9.4 reproduce: # save the attached .config to linux

Re: [PATCH] kvmalloc: always use vmalloc if CONFIG_DEBUG_VM

2018-04-22 Thread Michal Hocko
On Sat 21-04-18 07:47:57, Matthew Wilcox wrote: > On Fri, Apr 20, 2018 at 05:21:26PM -0400, Mikulas Patocka wrote: > > On Fri, 20 Apr 2018, Matthew Wilcox wrote: > > > On Fri, Apr 20, 2018 at 04:54:53PM -0400, Mikulas Patocka wrote: > > > > On Fri, 20 Apr 2018, Michal Hocko wrote: > > > > > No