Re: [PATCH v6 2/4] rpmsg: move common structures and defines to headers

2020-09-01 Thread Guennadi Liakhovetski
Hi Mathew, On Tue, Sep 01, 2020 at 11:23:21AM -0600, Mathieu Poirier wrote: > On Tue, Sep 01, 2020 at 05:11:51PM +0200, Guennadi Liakhovetski wrote: > > virtio_rpmsg_bus.c keeps RPMsg protocol structure declarations and > > common defines like the ones, needed for name-space announcements, > > int

Re: [PATCH net-next] vhost: fix typo in error message

2020-09-01 Thread David Miller
From: Yunsheng Lin Date: Tue, 1 Sep 2020 10:39:09 +0800 > "enable" should be "disable" when the function name is > vhost_disable_notify(), which does the disabling work. > > Signed-off-by: Yunsheng Lin Applied to 'net'. ___ Virtualization mailing lis

[PATCH 8/9] nvdimm: simplify revalidate_disk handling

2020-09-01 Thread Christoph Hellwig
The nvdimm block driver abuse revalidate_disk in a strange way, and totally unrelated to what other drivers do. Simplify this by just calling nvdimm_revalidate_disk (which seems rather misnamed) from the probe routines, as the additional bdev size revalidation is pointless at this point, and remov

[PATCH 9/9] block: remove revalidate_disk()

2020-09-01 Thread Christoph Hellwig
Remove the now unused helper. Signed-off-by: Christoph Hellwig --- drivers/md/md.h | 2 +- fs/block_dev.c| 19 --- include/linux/genhd.h | 1 - 3 files changed, 1 insertion(+), 21 deletions(-) diff --git a/drivers/md/md.h b/drivers/md/md.h index d9c4e6b7e9398d..f

[PATCH 6/9] nvme: opencode revalidate_disk in nvme_validate_ns

2020-09-01 Thread Christoph Hellwig
Keep control in the NVMe driver instead of going through an indirect call back into ->revalidate_disk. Also reorder the function a bit to be easier to follow with the additional code. And now that we have removed all callers of revalidate_disk() in the nvme code, ->revalidate_disk is only called

[PATCH 5/9] block: use revalidate_disk_size in set_capacity_revalidate_and_notify

2020-09-01 Thread Christoph Hellwig
Only virtio_blk and xen-blkfront set the revalidate argument to true, and both do not implement the ->revalidate_disk method. So switch to the helper that just updates the size instead. Signed-off-by: Christoph Hellwig --- block/genhd.c | 7 +++ include/linux/genhd.h | 4 ++-- 2 fil

[PATCH 2/9] block: don't clear bd_invalidated in check_disk_size_change

2020-09-01 Thread Christoph Hellwig
bd_invalidated is set by check_disk_change or in add_disk to initiate a partition scan. Move it from check_disk_size_change which is called from both revalidate_disk() and bdev_disk_changed() to only the latter, as that is what is called from the block device open code (and nbd) to deal with the b

remove revalidate_disk()

2020-09-01 Thread Christoph Hellwig
Hi Jens, this series removes the revalidate_disk() function, which has been a really odd duck in the last years. The prime reason why most people use it is because it propagates a size change from the gendisk to the block_device structure. But it also calls into the rather ill defined ->revalida

[PATCH 3/9] block: rename bd_invalidated

2020-09-01 Thread Christoph Hellwig
Replace bd_invalidate with a new BDEV_NEED_PART_SCAN flag in a bd_flags variable to better describe the condition. Signed-off-by: Christoph Hellwig --- block/genhd.c | 2 +- drivers/block/nbd.c | 8 fs/block_dev.c| 10 +- include/linux/blk_types.h

[PATCH 1/9] Documentation/filesystems/locking.rst: remove an incorrect sentence

2020-09-01 Thread Christoph Hellwig
unlock_native_capacity is never called from check_disk_change(), and while revalidate_disk can be called from it, it can also be called from two other places at the moment. Signed-off-by: Christoph Hellwig --- Documentation/filesystems/locking.rst | 3 --- 1 file changed, 3 deletions(-) diff --

[PATCH 4/9] block: add a new revalidate_disk_size helper

2020-09-01 Thread Christoph Hellwig
revalidate_disk is a relative awkward helper for driver use, as it first calls an optional driver method and then updates the block device size, while most callers either don't need the method call at all, or want to keep state between the caller and the called method. Add a revalidate_disk_size h

[PATCH 7/9] sd: open code revalidate_disk

2020-09-01 Thread Christoph Hellwig
Instead of calling revalidate_disk just do the work directly by calling sd_revalidate_disk, and revalidate_disk_size where needed. Signed-off-by: Christoph Hellwig --- drivers/scsi/sd.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.

[PATCH v6 3/4] rpmsg: update documentation

2020-09-01 Thread Guennadi Liakhovetski
rpmsg_create_ept() takes struct rpmsg_channel_info chinfo as its last argument, not a u32 value. The first two arguments are also updated. Signed-off-by: Guennadi Liakhovetski --- Documentation/rpmsg.txt | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/Documentation/rpms

[PATCH v6 2/4] rpmsg: move common structures and defines to headers

2020-09-01 Thread Guennadi Liakhovetski
virtio_rpmsg_bus.c keeps RPMsg protocol structure declarations and common defines like the ones, needed for name-space announcements, internal. Move them to common headers instead. Signed-off-by: Guennadi Liakhovetski --- drivers/rpmsg/virtio_rpmsg_bus.c | 78 +- incl

[PATCH v6 4/4] vhost: add an RPMsg API

2020-09-01 Thread Guennadi Liakhovetski
Linux supports running the RPMsg protocol over the VirtIO transport protocol, but currently there is only support for VirtIO clients and no support for a VirtIO server. This patch adds a vhost-based RPMsg server implementation. Signed-off-by: Guennadi Liakhovetski --- drivers/vhost/Kconfig

[PATCH v6 1/4] vhost: convert VHOST_VSOCK_SET_RUNNING to a generic ioctl

2020-09-01 Thread Guennadi Liakhovetski
VHOST_VSOCK_SET_RUNNING is used by the vhost vsock driver to perform crucial VirtQueue initialisation, like assigning .private fields and calling vhost_vq_init_access(), and clean up. However, this ioctl is actually extremely useful for any vhost driver, that doesn't have a side channel to inform i

[PATCH v6 0/4] Add a vhost RPMsg API

2020-09-01 Thread Guennadi Liakhovetski
Hi, Next update: v6: - rename include/linux/virtio_rpmsg.h -> include/linux/rpmsg/virtio.h v5: - don't hard-code message layout v4: - add endianness conversions to comply with the VirtIO standard v3: - address several checkpatch warnings - address comments from Mathieu Poirier v2: - update pa

Re: [PATCH v6 69/76] x86/realmode: Setup AP jump table

2020-09-01 Thread Joerg Roedel
On Mon, Aug 31, 2020 at 07:09:37PM +0200, Borislav Petkov wrote: > On Mon, Aug 24, 2020 at 10:55:04AM +0200, Joerg Roedel wrote: > > + /* Check if AP Jump Table is non-zero and page-aligned */ > > + if (!jump_table_addr || jump_table_addr & ~PAGE_MASK) > > + return 0; > > I think you

Re: [PATCH v6 42/76] x86/sev-es: Setup early #VC handler

2020-09-01 Thread Borislav Petkov
On Tue, Sep 01, 2020 at 02:59:22PM +0200, Joerg Roedel wrote: > True, but having a separate function might be handy when support for #VE > and #HV is developed. Those might also need to setup their early > handlers here, no? Ok. -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-

Re: [PATCH v6 48/76] x86/entry/64: Add entry code for #VC handler

2020-09-01 Thread Joerg Roedel
On Mon, Aug 31, 2020 at 01:30:02PM +0200, Borislav Petkov wrote: > AFAICT, that STACK_TYPE_UNKNOWN gets set only by the plain > get_stack_info() function - not by the _noinstr() variant so you'd need > to check the return value of latter... You are right, it needs to check the return value of get_

Re: [PATCH v6 42/76] x86/sev-es: Setup early #VC handler

2020-09-01 Thread Joerg Roedel
On Mon, Aug 31, 2020 at 11:45:41AM +0200, Borislav Petkov wrote: > On Mon, Aug 24, 2020 at 10:54:37AM +0200, Joerg Roedel wrote: > > +#ifdef CONFIG_AMD_MEM_ENCRYPT > > + /* VMM Communication Exception */ > > + handler = fixup_pointer(vc_no_ghcb, physbase); > > + set_early_idt_handler(idt, X86

Re: [PATCH v6 36/76] x86/head/64: Load IDT earlier

2020-09-01 Thread Joerg Roedel
On Sat, Aug 29, 2020 at 12:24:05PM +0200, Borislav Petkov wrote: > On Mon, Aug 24, 2020 at 10:54:31AM +0200, Joerg Roedel wrote: > > @@ -385,3 +386,25 @@ void __init alloc_intr_gate(unsigned int n, const void > > *addr) > > if (!WARN_ON(test_and_set_bit(n, system_vectors))) > > set

Re: [PATCH v6 31/76] x86/head/64: Setup MSR_GS_BASE before calling into C code

2020-09-01 Thread Joerg Roedel
On Fri, Aug 28, 2020 at 08:13:46PM +0200, Borislav Petkov wrote: > On Mon, Aug 24, 2020 at 10:54:26AM +0200, Joerg Roedel wrote: > > + movl$MSR_GS_BASE,%ecx > > I'm confused: is this missing those three lines: > > movlinitial_gs(%rip),%eax > movlinitial_gs+4(%rip),%e

Re: [PATCH net-next] vhost: fix typo in error message

2020-09-01 Thread Michael S. Tsirkin
On Tue, Sep 01, 2020 at 10:39:09AM +0800, Yunsheng Lin wrote: > "enable" should be "disable" when the function name is > vhost_disable_notify(), which does the disabling work. > > Signed-off-by: Yunsheng Lin Acked-by: Michael S. Tsirkin Why net-next though? It's a bugfix, can go into net. >

Re: [PATCH 1/2] drm/virtio: fix unblank

2020-09-01 Thread Daniel Vetter
On Tue, Aug 18, 2020 at 09:25:10AM +0200, Gerd Hoffmann wrote: > When going through a disable/enable cycle without changing the > framebuffer the optimization added by commit 3954ff10e06e ("drm/virtio: > skip set_scanout if framebuffer didn't change") causes the screen stay > blank. Add a bool to

Re: [RFC PATCH 00/22] Enhance VHOST to enable SoC-to-SoC communication

2020-09-01 Thread Jason Wang
On 2020/9/1 下午1:24, Kishon Vijay Abraham I wrote: Hi, On 28/08/20 4:04 pm, Cornelia Huck wrote: On Thu, 9 Jul 2020 14:26:53 +0800 Jason Wang wrote: [Let me note right at the beginning that I first noted this while listening to Kishon's talk at LPC on Wednesday. I might be very confused about

Re: [PATCH 1/2] drm/virtio: fix unblank

2020-09-01 Thread Daniel Vetter
On Fri, Aug 28, 2020 at 01:27:59PM +0200, Gerd Hoffmann wrote: > On Mon, Aug 24, 2020 at 09:24:40AM +0200, Jiri Slaby wrote: > > On 18. 08. 20, 9:25, Gerd Hoffmann wrote: > > > When going through a disable/enable cycle without changing the > > > framebuffer the optimization added by commit 3954ff10