Re: [PATCH 0/3] Use sbitmap instead of percpu_ida

2018-06-18 Thread Martin K. Petersen
Matthew, >> Since most of the changes are in scsi or target, should I take this >> series through my tree? > > I'd welcome that. Nick seems to be inactive as target maintainer; > his tree on kernel.org hasn't seen any updates in five months. Applied to 4.19/scsi-queue,

Re: [PATCH 0/3] Use sbitmap instead of percpu_ida

2018-06-14 Thread Martin K. Petersen
Matthew, > Removing the percpu_ida code nets over 400 lines of removal. It's not > as spectacular as deleting an entire architecture, but it's still a > worthy reduction in lines of code. Since most of the changes are in scsi or target, should I take this series through my tree? --

Re: [PATCH v2 0/2] virtio_scsi: Set can_queue based on size of virtqueue.

2017-10-26 Thread Martin K. Petersen
Richard, > v1 was here: > > https://lkml.org/lkml/2017/8/10/689 > > v1 -> v2: > > Remove .can_queue field from the templates. Applied to 4.14/scsi-queue. Thank you! -- Martin K. Petersen Oracle Linux Engineering __

Re: [PATCH] virtio_scsi: let host do exception handling

2017-10-26 Thread Martin K. Petersen
tems > going offline. > > Disable the 'sd' timeout and allow the host to do exception handling, > following the precedent of the storvsc driver. Applied to 4.13/scsi-queue. Thank you! -- Martin K. Petersen Oracle Linux Engineering ___ Vir

Re: [RFC PATCH 0/2] use larger max_request_size for virtio_blk

2018-04-05 Thread Martin K. Petersen
bandwidth. It sets an upper bound for filesystem requests only. Regardless of the capabilities of the block device driver and underlying hardware. You can override the limit on a per-device basis via max_sectors_kb in sysfs. People generally do it via a udev rule. -- Martin K. Petersen

Re: [PATCH 1/1] scsi: virtio_scsi: remove unused 'affinity_hint_set'

2019-06-20 Thread Martin K. Petersen
Dongli, > The 'affinity_hint_set' is not used any longer since > commit 0d9f0a52c8b9 ("virtio_scsi: use virtio IRQ affinity"). Applied to 5.3/scsi-queue. Thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtualizat

Re: [PATCH] scsi: virtio_scsi: Use struct_size() helper

2019-07-11 Thread Martin K. Petersen
Gustavo, > One of the more common cases of allocation size calculations is finding > the size of a structure that has a zero-sized array at the end, along > with memory for some number of elements for that array. For example: Applied to 5.4/scsi-queue, thanks! -- Martin K.

Re: [PATCH v2] scsi: virtio_scsi: unplug LUNs when events missed

2019-09-10 Thread Martin K. Petersen
t; (currently 8). > > Scan existing LUNs when events are missed to check if they are still > present. If not, remove them. Applied to 5.4/scsi-queue, thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Vi

Re: [PATCH] Rescan the entire target on transport reset when LUN is 0

2020-09-15 Thread Martin K. Petersen
thout having to > request a RESCAN for each one of them. Applied to 5.10/scsi-staging, thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundat

Re: [PATCH] Rescan the entire target on transport reset when LUN is 0

2020-09-21 Thread Martin K. Petersen
a RESCAN for each one of them. Applied to 5.10/scsi-queue, thanks! [1/1] scsi: virtio_scsi: Rescan the entire target on transport reset when LUN is 0 https://git.kernel.org/mkp/scsi/c/beef6fd02b90 -- Martin K. Petersen Oracle Linux Engineering

Re: [PATCH 02/10] block: virtio-blk: check logical block size

2020-07-21 Thread Martin K. Petersen
Christoph, > Hmm, I wonder if we should simply add the check and warning to > blk_queue_logical_block_size and add an error in that case. Then > drivers only have to check the error return, which might add a lot > less boiler plate code. Yep, I agree. -- Martin K. Petersen

Re: [PATCH 0/1] virtio-scsi: fix missing unplug events when all LUNs are unplugged at the same time

2020-07-29 Thread Martin K. Petersen
> Fixed this by checking the 'event overflow' bit and manually scanned the bus > to see which LUNs are still there. > > [...] Applied to 5.9/scsi-queue, thanks! [1/1] scsi: virtio-scsi: Correctly handle the case where all LUNs are unplugged https://git.kernel.org/mkp/scsi/c/b12149f2698

Re: [PATCH] scsi: virtio_scsi: remove unnecessary condition check

2020-07-13 Thread Martin K. Petersen
thanks! [1/1] scsi: virtio_scsi: Remove unnecessary condition check https://git.kernel.org/mkp/scsi/c/92e8d0323a51 -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundati

Re: [PATCH 00/17] spelling.txt: /decriptors/descriptors/

2020-06-15 Thread Martin K. Petersen
ith an addition in > scripts/spelling.txt so it shouldn't re-appear ;-) > > [...] Applied to 5.9/scsi-queue, thanks! [06/17] scsi: Fix trivial spelling https://git.kernel.org/mkp/scsi/c/0a19a725c0ed -- Martin K. Petersen

Re: [PATCH 02/10] block: virtio-blk: check logical block size

2020-07-28 Thread Martin K. Petersen
where possible, drivers should be updated to check the return value of that. -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: (subset) [PATCH 000/141] Fix fall-through warnings for Clang

2020-12-07 Thread Martin K. Petersen
eak/goto/return/fallthrough statements instead of just > letting the code fall through to the next case. > > [...] Applied to 5.11/scsi-queue, thanks! [054/141] target: Fix fall-through warnings for Clang https://git.kernel.org/mkp/scsi/c/492096ecfa39 -- Martin K. Petersen

Re: [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-30 Thread Martin K. Petersen
Gustavo, > This series aims to fix almost all remaining fall-through warnings in > order to enable -Wimplicit-fallthrough for Clang. Applied 20-22,54,120-124 to 5.11/scsi-staging, thanks. -- Martin K. Petersen Oracle Linux Engin

Re: [PATCH v2] virtio_scsi: Add validation for residual bytes from response

2021-06-29 Thread Martin K. Petersen
Xie, > This ensures that the residual bytes in response (might come > from an untrusted device) will not exceed the data buffer length. Applied to 5.14/scsi-staging, thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtuali

Re: [PATCH 01/15] bvec: add a bvec_virt helper

2021-08-05 Thread Martin K. Petersen
Christoph, > Add a helper to get the virtual address for a bvec. This avoids that > all callers need to know about the page + offset representation. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [PATCH 10/15] sd: use bvec_virt

2021-08-05 Thread Martin K. Petersen
Christoph, > Use bvec_virt instead of open coding it. bv_offset is set to 0 right above but I'm OK with bvec_virt() for the sake of consistency. Acked-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualizat

Re: [PATCH 02/15] block: use bvec_virt in bio_integrity_{process, free}

2021-08-05 Thread Martin K. Petersen
Christoph, > Use the bvec_virt helper to clean up the bio integrity processing a > little bit. Acked-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists

Re: [PATCH] scsi: virtio_scsi: Fix spelling mistake "Unsupport" -> "Unsupported"

2021-09-28 Thread Martin K. Petersen
-> "Unsupported" https://git.kernel.org/mkp/scsi/c/cced4c0ec7c0 -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [PATCH v5] virtio-blk: Add validation for block size in config space

2021-10-05 Thread Martin K. Petersen
at change. -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [PATCH] virtio-blk: Assign discard_granularity

2022-03-01 Thread Martin K. Petersen
hat we have to deal with two distinct types of alignment in the stack but that is the reality of the hardware we have to support. -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-f

Re: [PATCH 5/9] virtio-scsi: eliminate anonymous module_init & module_exit

2022-03-29 Thread Martin K. Petersen
Randy, > Eliminate anonymous module_init() and module_exit(), which can lead to > confusion or ambiguity when reading System.map, crashes/oops/bugs, or > an initcall_debug log. Applied to 5.18/scsi-staging, thanks! -- Martin K. Petersen Oracle Linux En

Re: fix and cleanup discard_alignment handling

2022-04-25 Thread Martin K. Petersen
w I ended up with "discard_alignment" when I called the corresponding I/O parameter "alignment_offset". Anyway. All this looks good to me. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing

Re: [dm-devel] [PATCH 01/27] target: remove an incorrect unmap zeroes data deduction

2022-04-06 Thread Martin K. Petersen
iewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [Ocfs2-devel] [PATCH 12/27] block: add a bdev_fua helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Add a helper to check the FUA flag based on the block_device instead > of having to poke into the block layer internal request_queue. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [Ocfs2-devel] [PATCH 11/27] block: add a bdev_write_cache helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Add a helper to check the write cache flag based on the block_device > instead of having to poke into the block layer internal request_queue. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [dm-devel] [PATCH 03/27] target: fix discard alignment on partitions

2022-04-06 Thread Martin K. Petersen
Christoph, > Use the proper bdev_discard_alignment helper that accounts for partition > offsets. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists

Re: [Ocfs2-devel] [PATCH 15/27] block: use bdev_alignment_offset in part_alignment_offset_show

2022-04-06 Thread Martin K. Petersen
by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [Ocfs2-devel] [PATCH 21/27] block: move {bdev, queue_limit}_discard_alignment out of line

2022-04-06 Thread Martin K. Petersen
ligned flag. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [Ocfs2-devel] [PATCH 24/27] block: add a bdev_discard_granularity helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Abstract away implementation details from file systems by providing a > block_device based helper to retreive the discard granularity. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [Ocfs2-devel] [PATCH 23/27] block: add a bdev_max_discard_sectors helper

2022-04-06 Thread Martin K. Petersen
for > write zeroes as well. Nicer! Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [Ocfs2-devel] [PATCH 26/27] block: uncouple REQ_OP_SECURE_ERASE from REQ_OP_DISCARD

2022-04-06 Thread Martin K. Petersen
Christoph, > Secure erase is a very different operation from discard in that it is > a data integrity operation vs hint. Fully split the limits and helper > infrastructure to make the separation more clear. Great! Reviewed-by: Martin K. Petersen -- Martin K. Petersen Ora

Re: [dm-devel] [PATCH 01/27] target: remove an incorrect unmap zeroes data deduction

2022-04-06 Thread Martin K. Petersen
> Fixes: 2237498f0b5c ("target/iblock: Convert WRITE_SAME to > blkdev_issue_zeroout") > Signed-off-by: Christoph Hellwig -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtual

Re: [PATCH 02/27] target: pass a block_device to target_configure_unmap_from_queue

2022-04-06 Thread Martin K. Petersen
Christoph, > The target code is a consumer of the block layer and should generally > work on struct block_device. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtuali

Re: [dm-devel] [PATCH 14/27] block: add a bdev_max_zone_append_sectors helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Add a helper to check the max supported sectors for zone append based > on the block_device instead of having to poke into the block layer > internal request_queue. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux En

Re: [Ocfs2-devel] [PATCH 13/27] block: add a bdev_stable_writes helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Add a helper to check the stable writes flag based on the block_device > instead of having to poke into the block layer internal request_queue. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [Ocfs2-devel] [PATCH 10/27] block: add a bdev_nonrot helper

2022-04-06 Thread Martin K. Petersen
Christoph, > Add a helper to check the nonrot flag based on the block_device > instead of having to poke into the block layer internal request_queue. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [Ocfs2-devel] [PATCH 17/27] block: use bdev_alignment_offset in disk_alignment_offset_show

2022-04-06 Thread Martin K. Petersen
Christoph, > This does the same as the open coded variant except for an extra > branch, and allows to remove queue_alignment_offset entirely. Also fine. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: [Ocfs2-devel] [PATCH 19/27] block: remove queue_discard_alignment

2022-04-06 Thread Martin K. Petersen
Christoph, > Just use bdev_alignment_offset in disk_discard_alignment_show instead. > That helpers is the same except for an always false branch that > doesn't matter in this slow path. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux En

Re: [Ocfs2-devel] [PATCH 18/27] block: move bdev_alignment_offset and queue_limit_alignment_offset out of line

2022-04-06 Thread Martin K. Petersen
Christoph, > No need to inline these fairly larger helpers. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org ht

Re: [Ocfs2-devel] [PATCH 20/27] block: use bdev_discard_alignment in part_discard_alignment_show

2022-04-06 Thread Martin K. Petersen
Christoph, > Use the bdev based alignment helper instead of open coding it. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org ht

Re: [Ocfs2-devel] [PATCH 22/27] block: refactor discard bio size limiting

2022-04-06 Thread Martin K. Petersen
Christoph, > Move all the logic to limit the discard bio size into a common helper > so that it is better documented. Looks OK. Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailin

Re: [Ocfs2-devel] [PATCH 25/27] block: remove QUEUE_FLAG_DISCARD

2022-04-06 Thread Martin K. Petersen
Christoph, > Just use a non-zero max_discard_sectors as an indicator for discard > support, similar to what is done for write zeroes. Very happy to finally see this flag removed! Reviewed-by: Martin K. Petersen -- Martin K. Petersen Oracle Linux Engin

Re: (subset) [PATCH v2 00/24] use vmalloc_array and vcalloc

2023-07-11 Thread Martin K. Petersen
kp/scsi/c/04d91b783acf -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [PATCH v2 00/24] use vmalloc_array and vcalloc

2023-07-05 Thread Martin K. Petersen
erflows. Applied #7 and #24 to 6.5/scsi-staging, thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization

Re: [PATCH] scsi: virtio_scsi: Remove a useless function call

2023-05-31 Thread Martin K. Petersen
Christophe, > 'inq_result' is known to be NULL. There is no point calling kfree(). Applied to 6.5/scsi-staging, thanks! -- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.

Re: [PATCH] scsi: virtio_scsi: Remove a useless function call

2023-06-07 Thread Martin K. Petersen
- Martin K. Petersen Oracle Linux Engineering ___ Virtualization mailing list Virtualization@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/virtualization