Re: [PATCH libinput 1/6] filter: rename motion_filter_destroy to filter_destroy

2014-07-08 Thread Hans de Goede
Hi, On 07/08/2014 01:21 AM, Peter Hutterer wrote: For better consistency with filter_dispatch(). And move the things around to keep the consumable API together. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net Looks good, you may add my Reviewed-by for patches 1-3. Regards, Hans

RE: Global shortkeys and keyboard focus

2014-07-08 Thread Dodier-Lazaro, Steve
A couple of notes on the previous emails, Fabrice, so long as your app ensures that no third-party code can programmatically grab a shortcut without user agreement, it would make sense to let it have a privilege. Quite obviously a compo should have the last word and be able to refuse a

[PATCH 06/11] weston-terminal --help and other command-line options

2014-07-08 Thread Bill Spitzak
Option array existed but was unused. Added --font-size. --- clients/terminal.c | 11 +++ 1 file changed, 11 insertions(+) diff --git a/clients/terminal.c b/clients/terminal.c index eb133cd..1915c9f 100644 --- a/clients/terminal.c +++ b/clients/terminal.c @@ -2991,6 +2991,7 @@

[PATCH 05/11] Made weston-screensaver --help work

2014-07-08 Thread Bill Spitzak
--- clients/wscreensaver.c |8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff --git a/clients/wscreensaver.c b/clients/wscreensaver.c index 47f6c8a..f75d0d8 100644 --- a/clients/wscreensaver.c +++ b/clients/wscreensaver.c @@ -310,8 +310,12 @@ int main(int argc, char *argv[])

[PATCH 10/11] weston-image --help works. Also help if no filename is given

2014-07-08 Thread Bill Spitzak
--- clients/image.c |5 + 1 file changed, 5 insertions(+) diff --git a/clients/image.c b/clients/image.c index 112b93d..573117c 100644 --- a/clients/image.c +++ b/clients/image.c @@ -412,6 +412,11 @@ main(int argc, char *argv[]) int i; int image_counter = 0; + if

[PATCH 01/11] Fixes to parse_options

2014-07-08 Thread Bill Spitzak
Fail on malformed numbers, such as --width=100mm Fail on = after booleans, such as --flag=false Multiple single-letter booleans in one switch allowed, ie -xyz is the same as -x -y -z. For wayland modules they all have to belong to the same module. Previous version could use text after the null

[PATCH 07/11] weston-cliptest --help works. You must use -b to run benchmark

2014-07-08 Thread Bill Spitzak
--- clients/cliptest.c |8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff --git a/clients/cliptest.c b/clients/cliptest.c index a1928f4..51a4075 100644 --- a/clients/cliptest.c +++ b/clients/cliptest.c @@ -893,8 +893,12 @@ main(int argc, char *argv[]) struct display

[PATCH 00/11] Fix parse_options, add --help to many clients

2014-07-08 Thread Bill Spitzak
This replaces my previous single patch. This version does not change parse_options return value, and discards the attempt to print automatic help from the option list, as that was rarely used. Also split all the client changes into individual patches. Bill Spitzak (11): Fixes to parse_options

[PATCH 03/11] Made weston-nested --help work

2014-07-08 Thread Bill Spitzak
--- clients/nested.c |7 +-- 1 file changed, 5 insertions(+), 2 deletions(-) diff --git a/clients/nested.c b/clients/nested.c index 2a952be..f094237 100644 --- a/clients/nested.c +++ b/clients/nested.c @@ -1115,8 +1115,11 @@ main(int argc, char *argv[]) struct display *display;

[PATCH 02/11] weston-eventdemo --help works

2014-07-08 Thread Bill Spitzak
Also defaults to printing all events if you specify none. Removed incorrect -0 switch which would turn on one of them. --- clients/eventdemo.c | 42 +- 1 file changed, 33 insertions(+), 9 deletions(-) diff --git a/clients/eventdemo.c

[PATCH 04/11] Made weston-subsurfaces --help work

2014-07-08 Thread Bill Spitzak
--- clients/subsurfaces.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/clients/subsurfaces.c b/clients/subsurfaces.c index 66a10f2..833030f 100644 --- a/clients/subsurfaces.c +++ b/clients/subsurfaces.c @@ -775,8 +775,8 @@ main(int argc, char *argv[]) struct

[PATCH libinput] tablet: Rename TILT_VERTICAL and TILT_HORIZONTAL to TILT_X and TILT_Y

2014-07-08 Thread Stephen Chandler Paul
Since the orientation of the tablet can potentially change, this naming scheme makes a lot more sense then VERTICAL and HORIZONTAL does since they don't reflect the actual physical movement. Signed-off-by: Stephen Chandler Paul thatsly...@gmail.com --- src/evdev-tablet.c | 4 ++--