Re: [PATCH wayland v2] scanner: Add version argument to wayland-scanner

2016-05-05 Thread Bryce Harrington
On Thu, May 05, 2016 at 06:34:54PM -0500, Yong Bakos wrote: > On May 5, 2016, at 10:27 AM, Armin Krezović wrote: > > > > This adds a command line argument to print wayland-scanner version. > > > > It also makes wayland-scanner emit a comment with wayland library > >

Re: [PATCH weston v3 03/17] compositor-wayland: rename wayland_output_init_from_config

2016-05-05 Thread Yong Bakos
On May 5, 2016, at 6:12 PM, Yong Bakos wrote: > > Hi Benoit, > > On May 5, 2016, at 3:45 PM, Benoit Gschwind wrote: >> >> Rename wayland_output_init_from_config to wayland_output_config_init. >> >> Signed-off-by: Benoit Gschwind

Re: [PATCH weston v3 03/17] compositor-wayland: rename wayland_output_init_from_config

2016-05-05 Thread Yong Bakos
Hi Benoit, On May 5, 2016, at 3:45 PM, Benoit Gschwind wrote: > > Rename wayland_output_init_from_config to wayland_output_config_init. > > Signed-off-by: Benoit Gschwind > --- > src/compositor-wayland.c | 4 ++-- > 1 file changed, 2 insertions(+), 2

Re: [PATCH wayland-protocols, weston v3 0/17] Stabilize wl_scaler as wp_viewporter

2016-05-05 Thread Bryce Harrington
On Wed, May 04, 2016 at 05:33:10PM -0700, Bryce Harrington wrote: > On Tue, Apr 26, 2016 at 03:50:52PM +0300, Pekka Paalanen wrote: > > From: Pekka Paalanen > > > > Hi, > > > > here is the v3 of the stabilization series, which I hope to the final to be > >

Re: [PATCH weston v2 9/9] wayland-backend: move all parsing functions to weston

2016-05-05 Thread Benoit Gschwind
Hello Pekka, I submitted a patches set (v3) to address all comments. Best regards. On 04/05/2016 15:41, Pekka Paalanen wrote: > On Thu, 28 Apr 2016 20:33:16 +0200 > Benoit Gschwind wrote: > >> Move all parsing functions from the wayland backend and put >> them into the

[PATCH weston v3 00/17] compositor-wayland: refactor the configuration API

2016-05-05 Thread Benoit Gschwind
v3: - rebase to master - heavy patches spliting to help review as suggested by Pekka - fix typo. - rename functions and variables as suggested by Pekka Benoit Gschwind (17): compositor-wayland: fix misc. typo compositor-wayland: add versionning to config structure compositor-wayland:

[PATCH weston v3 06/17] compositor-wayland: refactor load_wayland_backend

2016-05-05 Thread Benoit Gschwind
Rename compositor to c in load_wayland_backend function. Signed-off-by: Benoit Gschwind --- src/main.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/main.c b/src/main.c index 92b7ac2..a84bdeb 100644 --- a/src/main.c +++ b/src/main.c @@

[PATCH weston v3 05/17] compositor-wayland: move configuration parsing to main.c

2016-05-05 Thread Benoit Gschwind
Move function load_wayland_backend_config, wayland_backend_config_add_new_output, wayland_backend_config_release, wayland_output_config_init from compositor-wayland.c to main.c. Rename load_wayland_backend_config to load_wayland_backend ad update the signature to match other backend load

[PATCH weston v3 07/17] compositor-wayland: refactor load_wayland_backend

2016-05-05 Thread Benoit Gschwind
Rename config to wc in load_wayland_backend function. Signed-off-by: Benoit Gschwind --- src/main.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/src/main.c b/src/main.c index a84bdeb..2ff8cd7 100644 --- a/src/main.c +++ b/src/main.c @@ -1041,7

[PATCH weston v3 12/17] compositor-wayland: refactor wayland_backend_create

2016-05-05 Thread Benoit Gschwind
Rename new_config to config in wayland_backend_create function. Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index

[PATCH weston v3 01/17] compositor-wayland: fix misc. typo

2016-05-05 Thread Benoit Gschwind
Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index d0d1082..83f31de 100644 --- a/src/compositor-wayland.c +++

[PATCH weston v3 15/17] compositor-wayland: rename wayland_backend_config_release

2016-05-05 Thread Benoit Gschwind
Rename wayland_backend_config_release to weston_wayland_backend_config_release. Signed-off-by: Benoit Gschwind --- src/main.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/src/main.c b/src/main.c index 5b8eb80..adaebf7 100644 ---

[PATCH weston v3 13/17] compositor-wayland: refactor backend_init

2016-05-05 Thread Benoit Gschwind
Rename unused variable config to wc in backend_init function. Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index 133bd37..67d20d0 100644

[PATCH weston v3 17/17] compositor-wayland: rename wayland_backend_config_add_new_output

2016-05-05 Thread Benoit Gschwind
Rename wayland_backend_config_add_new_output to weston_wayland_backend_config_add_new_output. Signed-off-by: Benoit Gschwind --- src/main.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/main.c b/src/main.c index 55ecc08..2e5c743 100644 ---

[PATCH weston v3 14/17] compositor-wayland: refactor backend_init

2016-05-05 Thread Benoit Gschwind
Rename new_config to config in backend_init function. Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index

[PATCH weston v3 02/17] compositor-wayland: add versionning to config structure

2016-05-05 Thread Benoit Gschwind
Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 27 --- src/compositor-wayland.h | 3 +++ 2 files changed, 27 insertions(+), 3 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index 83f31de..b51467d 100644

[PATCH weston v3 16/17] compositor-wayland: rename wayland_output_config_init

2016-05-05 Thread Benoit Gschwind
Rename wayland_output_config_init to weston_wayland_output_config_init. Signed-off-by: Benoit Gschwind --- src/main.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/main.c b/src/main.c index adaebf7..55ecc08 100644 --- a/src/main.c +++

[PATCH weston v3 09/17] compositor-wayland: refactor wayland_backend_config_add_new_output

2016-05-05 Thread Benoit Gschwind
Rename new_config to config in wayland_backend_config_add_new_output function. Signed-off-by: Benoit Gschwind --- src/main.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/src/main.c b/src/main.c index 8d42ec5..3d643f1 100644 ---

[PATCH weston v3 08/17] compositor-wayland: refactor load_wayland_backend

2016-05-05 Thread Benoit Gschwind
Rename variable new_config to config in load_wayland_backend function. Signed-off-by: Benoit Gschwind --- src/main.c | 54 +++--- 1 file changed, 27 insertions(+), 27 deletions(-) diff --git a/src/main.c b/src/main.c index

[PATCH weston v3 11/17] compositor-wayland: refactor wayland_backend_create

2016-05-05 Thread Benoit Gschwind
Remove argv, argc and weston_config from wayland_backend_create function. Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index

[PATCH weston v3 03/17] compositor-wayland: rename wayland_output_init_from_config

2016-05-05 Thread Benoit Gschwind
Rename wayland_output_init_from_config to wayland_output_config_init. Signed-off-by: Benoit Gschwind --- src/compositor-wayland.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c index

[PATCH wayland v2] scanner: Add version argument to wayland-scanner

2016-05-05 Thread Armin Krezović
This adds a command line argument to print wayland-scanner version. It also makes wayland-scanner emit a comment with wayland library version to every file it generates. v2: separate variable definitions into their own lines and remove old style "version" argument Reviewed-by: Bryce