Re: [PATCH weston 01/21] libweston: move weston_output::mode_list init to core

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.32, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Initialize the list in weston_output_init() instead of doing it > separately in each backend. > > One would expect weston_output_init() to initialize all weston_output > members, at least th

Re: [PATCH weston 16/21] compositor-fbdev: always destroy renderer-output on disable

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > If we pass the base->enabled test, then the renderer output is > guaranteed to be there, so we can just destroy it. > > Destroying it before unmap makes the sequence match better the enable

Re: [PATCH weston 15/21] compositor-fbdev: simplify FB destroy/unmap/disable

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Rename fbdev_frame_buffer_destroy() to fbdev_frame_buffer_unmap() > because that is what it does. Adding the destruction of hw_surface in it > makes it the perfect counterpart to fbdev_frame_

Re: [PATCH weston 12/21] libweston: set backend pointer earlier

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Change all backends to set the core backend pointer early. > > This is necessary for libweston core to be able to access the backend > vfuncs before the backend init function returns. Partic

Re: [PATCH weston 11/21] libweston: ensure backend is not loaded twice

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Check and ensure that a compositor can only load one backend > successfully. If a backend fails to load, it is theoretically possible > to try another backend. Once loading succeeds, only des

Re: [PATCH weston 10/21] libweston: rename weston_output_destroy() to weston_output_release()

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > 'release' is a more appropriate name because the function does not free > the underlying memory. The main reason for this is that we need the name > weston_output_destroy() for new API that a

Re: [PATCH weston 09/21] libweston: send more wl_surface.enter/leave events

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > A client may have bound the same wl_output multiple times, for who knows > what reason. As the server cannot know which wl_output resource to use > for which wl_surface, send enter/leave even

Re: [PATCH weston 08/21] compositor-drm: set all properties in create_output_for_connector

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Move the remaining scattered setup of the fixed properties into > create_output_for_connector(). All these are already known and they > cannot change. > > This helps future refactoring. > >

Re: [PATCH weston 07/21] compositor-drm: set output make/model/serial once

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > This fixes a regression where monitor make and model would always be > advertised as "unknown" to Wayland clients. The EDID strings were parsed > at create_output_for_connector() time, but th

Re: [PATCH weston 06/21] compositor-wayland: move output init into common, fix error path

2017-09-25 Thread Ray, Ian (GE Healthcare)
On 22/09/2017, 17.33, "wayland-devel on behalf of Pekka Paalanen" wrote: > > From: Pekka Paalanen > > Move the weston_output_init() call into wayland_output_create_common(). > This avoids passing the name twice to different functions, and follows > the precedent set in "libweston: weston_outp

Re: [PATCH wayland-protocols] Add zwp_linux_explicit_synchronization_v1

2017-09-25 Thread Matt Hoosier
On Fri, Sep 22, 2017 at 6:18 PM, Matt Hoosier wrote: > On Fri, Sep 22, 2017 at 10:24 AM, Pekka Paalanen wrote: >> On Wed, 20 Sep 2017 07:11:57 -0700 >> Daniel Stone wrote: >> >>> Hi Matt, >>> >>> On 20 September 2017 at 05:48, Matt Hoosier wrote: >>> > On a related subject, there was discussion

[PATCH] compositor: fix starvation of wl_buffer::release

2017-09-25 Thread Matt Hoosier
This change replaces a queued emission of buffer-release events (which is prone to starvation) with a regular event emission. This means that client programs no longer need to secretly install surface frame listeners just to guarantee that they get correctly notified of buffer lifecycle events. Si

Re: [PATCH] Fix API troubles with FreeRDP 2.0

2017-09-25 Thread Hardening
Le 25/09/2017 à 10:49, Pekka Paalanen a écrit : > On Fri, 22 Sep 2017 11:17:41 +0200 > David Fort wrote: > >> With FreeRDP 2.0 the crypto needs to be initialized or we fail as soon as we >> try to >> compute a md5. The API also changed for the suppress output callback. >> --- >> libweston/compo

Re: [weston,13/21] compositor-fbdev: remove unused output arguments

2017-09-25 Thread xerpi . g . 12
On Fri, 2017-09-22 at 17:31 +0300, Pekka Paalanen wrote: > From: Pekka Paalanen > > A few functions had argument 'output' which was not used at all. Remove > such unused arguments. > > The coming migration to the head-based output API would have made it > awkward to come up with the output argum

Re: [PATCH weston v2 4/4] gl-renderer: Emit GPU rendering begin and end timeline timepoints

2017-09-25 Thread Pekka Paalanen
On Tue, 19 Sep 2017 14:59:11 +0300 Alexandros Frantzis wrote: > Use EGL fence sync objects to emit timepoints for the beginning and the > end of rendering on the GPU. The timepoints are emitted asynchronously > using the sync file fds associated with the fence sync objects. The sync > file fds ar

Re: [PATCH] Add aspect-ratio support in wayland layer.

2017-09-25 Thread Pekka Paalanen
On Wed, 20 Sep 2017 11:38:15 +0530 "Sharma, Shashank" wrote: > Hello Pekka, > > Sorry for the delay in response, I was OOO. I had a quick syncup with > Ankit, where he told me about the discussions you guys had, over this > topic. > Please find my comments inline. > > On 9/12/2017 2:49 PM, Pe

RE: [PATCH weston 04/21] tests: ensure output dependent IVI tests run

2017-09-25 Thread Ucan, Emre (ADITG/ESB)
Hi Pekka, This patch is: Reviewed-by: Emre Ucan Best regards Emre Ucan Engineering Software Base (ADITG/ESB) Tel. +49 5121 49 6937 > -Original Message- > From: wayland-devel [mailto:wayland-devel- > boun...@lists.freedesktop.org] On Behalf Of Pekka Paalanen > Sent: Freitag, 22. Septem

[PATCH weston] compositor-wayland: destroy the appropriate output instead of exiting when receiving an xdg_toplevel::close event

2017-09-25 Thread Sergi Granell
Signed-off-by: Sergi Granell --- libweston/compositor-wayland.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/libweston/compositor-wayland.c b/libweston/compositor-wayland.c index a99d4a5c..17b5dbfd 100644 --- a/libweston/compositor-wayland.c +++ b/libweston/compositor-w

[PATCH] compositor-wayland: use input region instead of opaque region to zxdg_shell_v6::set_window_geometry

2017-09-25 Thread Sergi Granell
The opaque region is a few pixels off due to the rounded corners of the frame decorations, and, therefore, the input region matches the window's geometry more closely. Signed-off-by: Sergi Granell --- libweston/compositor-wayland.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(

Re: [PATCH weston 00/21] Fixes and reorganization, clone mode prep

2017-09-25 Thread Pekka Paalanen
On Fri, 22 Sep 2017 17:31:08 +0300 Pekka Paalanen wrote: > From: Pekka Paalanen > > Hi, > > I have been working towards clone mode[1] and thought it would be a time to > shorten my patch series. This series here is a selection of patches from my > clone mode preparations. > Pekka Paalanen (21

Re: [PATCH] Fix API troubles with FreeRDP 2.0

2017-09-25 Thread Pekka Paalanen
On Fri, 22 Sep 2017 11:17:41 +0200 David Fort wrote: > With FreeRDP 2.0 the crypto needs to be initialized or we fail as soon as we > try to > compute a md5. The API also changed for the suppress output callback. > --- > libweston/compositor-rdp.c | 15 ++- > 1 file changed, 14 inse