Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-04 Thread Bill Spitzak
On Wed, Feb 3, 2016 at 11:36 AM, Jasper St. Pierre wrote: > set_parent was moved to xdg_toplevel. Perhaps that's a good idea, > perhaps it's not. This does mean that a tooltip's parent can never > change, and a popup's parent can never change. That can help for > getting

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-04 Thread Bill Spitzak
On Wed, Feb 3, 2016 at 1:05 PM, Jasper St. Pierre wrote: > On Wed, Feb 3, 2016 at 1:00 PM, Bill Spitzak wrote: > > > > > > On Wed, Feb 3, 2016 at 11:36 AM, Jasper St. Pierre < > jstpie...@mecheye.net> > > wrote: > >> > >> set_parent was moved to

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jasper St. Pierre
The existing surface. Perhaps this "get_" naming is a bit confusing, and should be renamed to "create_tooltip" or "make_tooltip" or similar. The intended client flow is: toplevel_wl_surface = wl_compositor.create_surface() toplevel_xdg_surface = xdg_shell.get_xdg_surface(toplevel_wl_surface)

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jonas Ådahl
On Wed, Feb 03, 2016 at 11:02:14AM +0200, Giulio Camuffo wrote: > 2016-02-03 11:00 GMT+02:00 Jasper St. Pierre : > > No? The parent is the surface the tooltip is laid on top of. > > So where do the contents of the tooltip come from? The tooltip is created from an

[PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jonas Ådahl
An xdg_tooltip is a new window type used to implement tooltip like surfaces. See the interface documentation for details. Signed-off-by: Jonas Ådahl --- Changes since v1: Various wording changes as suggested by Mike. Added missing version attribute and .

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Giulio Camuffo
2016-02-03 11:00 GMT+02:00 Jasper St. Pierre : > No? The parent is the surface the tooltip is laid on top of. So where do the contents of the tooltip come from? > > On Wed, Feb 3, 2016 at 12:59 AM, Giulio Camuffo > wrote: >> 2016-02-03 10:39

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Giulio Camuffo
2016-02-03 10:39 GMT+02:00 Jonas Ådahl : > An xdg_tooltip is a new window type used to implement tooltip like > surfaces. See the interface documentation for details. > > Signed-off-by: Jonas Ådahl > --- > > Changes since v1: > > Various wording changes as

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jasper St. Pierre
No? The parent is the surface the tooltip is laid on top of. On Wed, Feb 3, 2016 at 12:59 AM, Giulio Camuffo wrote: > 2016-02-03 10:39 GMT+02:00 Jonas Ådahl : >> An xdg_tooltip is a new window type used to implement tooltip like >> surfaces. See the

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Giulio Camuffo
2016-02-03 11:07 GMT+02:00 Jonas Ådahl : > On Wed, Feb 03, 2016 at 11:02:14AM +0200, Giulio Camuffo wrote: >> 2016-02-03 11:00 GMT+02:00 Jasper St. Pierre : >> > No? The parent is the surface the tooltip is laid on top of. >> >> So where do the contents of

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Marek Chalupa
On 02/03/16 09:39, Jonas Ådahl wrote: An xdg_tooltip is a new window type used to implement tooltip like surfaces. See the interface documentation for details. Signed-off-by: Jonas Ådahl --- Changes since v1: Various wording changes as suggested by Mike. Added missing

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jasper St. Pierre
On Wed, Feb 3, 2016 at 1:00 PM, Bill Spitzak wrote: > > > On Wed, Feb 3, 2016 at 11:36 AM, Jasper St. Pierre > wrote: >> >> set_parent was moved to xdg_toplevel. Perhaps that's a good idea, >> perhaps it's not. This does mean that a tooltip's parent can

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jonas Ådahl
On Wed, Feb 03, 2016 at 07:24:10PM -0800, Bill Spitzak wrote: > On Wed, Feb 3, 2016 at 1:05 PM, Jasper St. Pierre > wrote: > > > On Wed, Feb 3, 2016 at 1:00 PM, Bill Spitzak wrote: > > > > > > > > > On Wed, Feb 3, 2016 at 11:36 AM, Jasper St. Pierre < >

Re: [PATCH wayland-protocols v2] xdg-shell: Introduce xdg_tooltip

2016-02-03 Thread Jasper St. Pierre
set_parent was moved to xdg_toplevel. Perhaps that's a good idea, perhaps it's not. This does mean that a tooltip's parent can never change, and a popup's parent can never change. That can help for getting grab semantics right, though it might be an idea if we say that set_parent on a popup /