Re: [PATCH libinput 9/9] touchpad: drop fake resolution handling

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Now that we have all devices init a fixed resolution we don't need code to handle custom cases anymore. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net LGTM: Reviewed-by: Hans de Goede hdego...@redhat.com Regards, Hans ---

Re: [PATCH libinput 8/9] touchpad: default to a 69x50mm sized touchpad

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: The previous approach of using the axis ranges and approximating parameters based on the x/y axis range clutters up the code and is generally unreliable. If we look at Synaptics touchpads, the resolution ranges from 42 to 130 while the axes stay the

Re: [PATCH weston] input: pass the global touch coordinates to the touch grab

2015-07-08 Thread Daniel Stone
Hi, On 8 July 2015 at 09:55, Giulio Camuffo giuliocamu...@gmail.com wrote: @@ -1552,10 +1558,7 @@ notify_touch(struct weston_seat *seat, uint32_t time, int touch_id, if (touch-num_tp == 1) { ev = weston_compositor_pick_view(ec, x, y, sx, sy);

Re: [PATCH] screenshooter: Add missing field initializers for wl_output_listener

2015-07-08 Thread Daniel Stone
On 7 July 2015 at 19:48, Bill Spitzak spit...@gmail.com wrote: On Tue, Jul 7, 2015 at 11:11 AM, Daniel Stone dan...@fooishbar.org wrote: More correctly, they are never called (which would happen on receipt of a server event) because it only ever binds wl_output v1, where the done/scale events

Re: [PATCH libinput 7/9] udev: add size hint for apple touchpads

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Signed-off-by: Peter Hutterer peter.hutte...@who-t.net LGTM: Reviewed-by: Hans de Goede hdego...@redhat.com Regards, Hans --- udev/90-libinput-model-quirks.hwdb | 1 + 1 file changed, 1 insertion(+) diff --git

Re: [PATCH libinput 6/9] udev: add ALPS firmware detection and size properties

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Signed-off-by: Peter Hutterer peter.hutte...@who-t.net LGTM: Reviewed-by: Hans de Goede hdego...@redhat.com Regards, Hans --- udev/90-libinput-model-quirks.hwdb | 4 udev/libinput-model-quirks.c | 20 2

Re: [PATCH libinput 1/9] udev: make sure the udev callout path is valid for a test run

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: udev requires callout binaries to sit in /lib/udev or otherwise provide an absolute path. The test suite should work without installing everything first, so create two rule files - one to install, one with the path to the $builddir/test

Re: [PATCH libinput 5/9] udev: add Elantech touchpad firmware detection

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Only firmware v4 (and probably whatever comes in the future) have resolution set, for the first couple of touchpads we need size hints. Add a callout that looks at the properties on the touchpad and decides the firmware version. The udev/hwdb is

Re: cross-client surface references

2015-07-08 Thread Daniel Stone
Hi, On 7 July 2015 at 21:15, Bill Spitzak spit...@gmail.com wrote: On Mon, Jul 6, 2015 at 11:53 PM, Pekka Paalanen ppaala...@gmail.com wrote: Multiple handles to the same underlying server-side object from completely asynchronous contexts (different processes). I can't see that ending well at

Re: [PATCH libinput 4/9] evdev: use LIBINPUT_ATTR_SIZE_HINT for resolutions

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Touchpads, notably Elantech, ALPS and bcm5974 don't provide x/y resolution until recent generations. Add a new property, LIBINPUT_ATTR_SIZE_HINT, that provides size information to libinput. Note that this property *does not* override true resolution

Re: [PATCH libinput 3/9] util: add a helper function to parse a WIDTHxHEIGHT property

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: Signed-off-by: Peter Hutterer peter.hutte...@who-t.net LGTM: Reviewed-by: Hans de Goede hdego...@redhat.com Regards, Hans --- src/libinput-util.c | 30 ++ src/libinput-util.h | 2 ++ test/misc.c | 47

Re: [PATCH libinput 2/9] evdev: simplify setting a fake resolution

2015-07-08 Thread Hans de Goede
Hi, On 01-07-15 08:08, Peter Hutterer wrote: The only two callers passed in the fake resolution anyway, so we don't need extra parameters here. We don't allow devices with only x or y resolution set, either both or none. And we can use libevdev_set_abs_resolution() rather than handling absinfo

Re: [PATCH weston v2 1/8] protocol: add linux_dmabuf extension (v2)

2015-07-08 Thread Daniel Vetter
On Wed, Jul 01, 2015 at 05:56:13PM +0300, Pekka Paalanen wrote: From: Pekka Paalanen pekka.paala...@collabora.co.uk An experimental (hence the 'z' prefix) linux_dmabuf Wayland protocol extension for creating dmabuf-based wl_buffers in a generic manner. This does not include proper dmabuf

[PATCH weston] input: pass the global touch coordinates to the touch grab

2015-07-08 Thread Giulio Camuffo
This makes it consistent with the pointer grab, which also gets global coordinates and not surface relative ones, and allows to easily filter out gestures based on compositor global hotspots. --- desktop-shell/shell.c | 14 ++ src/data-device.c | 2 +- src/input.c | 20

Re: [PATCH libinput] touchpad: be smarter about clickfinger thumb detection

2015-07-08 Thread Hans de Goede
Hi, On 06-07-15 06:34, Peter Hutterer wrote: Watching a colleague try clickfinger right-click after enabling it the first time showed that the vertical distance is too small. Increase it to 30mm instead. Increase the allowed spread between fingers to 40x30mm, but check if one of the fingers is

Re: [PATCH libinput 1/4] test: allow for a default value on LITEST_AUTO_ASSIGNS

2015-07-08 Thread Hans de Goede
Hi, On 08-07-15 08:56, Peter Hutterer wrote: The touchpads currently all send a default value of 30 for ABS_PRESSURE. For some tests we want to have a custom pressure but changing all tests isn't sensible. So hook each device up to send a default value of 30 if it isn't overridden in the test

Re: [PATCH libinput 1/4] test: allow for a default value on LITEST_AUTO_ASSIGNS

2015-07-08 Thread Hans de Goede
Hi, On 08-07-15 15:11, Hans de Goede wrote: Hi, On 08-07-15 08:56, Peter Hutterer wrote: The touchpads currently all send a default value of 30 for ABS_PRESSURE. For some tests we want to have a custom pressure but changing all tests isn't sensible. So hook each device up to send a default

Re: [PATCH weston 02/11] compositor: add API to manage compositor instances

2015-07-08 Thread Pekka Paalanen
On Tue, 23 Jun 2015 18:19:38 -0700 Jon A. Cruz j...@osg.samsung.com wrote: Oh I forgot an item on the placement of comments. On 06/23/2015 04:31 PM, Jon A. Cruz wrote: Minor doxygen note: the explicit \brief is not needed, and the brief description should end with a '.' to allow

Re: [PATCH libinput 1/3] test: move enable_edge_scroll up

2015-07-08 Thread Hans de Goede
Hi, On 06-07-15 06:26, Peter Hutterer wrote: No functional changes, just so we can group those helpers together. Signed-off-by: Peter Hutterer peter.hutte...@who-t.net The entire series LGTM: Reviewed-by: Hans de Goede hdego...@redhat.com Regards, Hans --- test/touchpad.c | 26

[PATCH] documentation: Update documentation for calling wl_display_sync

2015-07-08 Thread Christopher Michael
The documentation for the wl_registry global object is partially incorrect. It stated that clients can use wl_display_sync immediately after calling wl_display.get_registry however this is misleading. If a client calls wl_display_sync without first setting up a registry listener, then clients

Re: cross-client surface references

2015-07-08 Thread Bill Spitzak
All your objections sounds like you are confusing the implementation with the abstraction that the client program sees. A few examples: On Wed, Jul 8, 2015 at 4:47 AM, Daniel Stone dan...@fooishbar.org wrote: Yes this also creates multiple C structures in the server, to keep track of the

[PATCH libinput 2/4] touchpad: add pressure-based thumb-detection

2015-07-08 Thread Peter Hutterer
All touchpad recordings seen so far show that a value above 100 is definitely a thumb or a palm. Values below are harder to discern, and the same isn't true for touchpads supporting ABS_PRESSURE instead of ABS_MT_PRESSURE. The handling of a touch is as outlined in tp_thumb_detect: * thumbs are

[PATCH libinput 3/4] touchpad: work thumb detection into the tap state machine

2015-07-08 Thread Peter Hutterer
Most thumbs are detected a few events into the sequence. Work this into parts of the tapping state machine. Only the most common use-case is handled here - if the first finger ends up being marked as a thumb, we return to the idle state and ignore that touch sequence. At any other state, we

[PATCH libinput 4/4] test: add touchpad thumb detection tests

2015-07-08 Thread Peter Hutterer
Signed-off-by: Peter Hutterer peter.hutte...@who-t.net --- test/touchpad.c | 389 1 file changed, 389 insertions(+) diff --git a/test/touchpad.c b/test/touchpad.c index a9e9e4e..1c75676 100644 --- a/test/touchpad.c +++ b/test/touchpad.c @@

[PATCH libinput 1/4] test: allow for a default value on LITEST_AUTO_ASSIGNS

2015-07-08 Thread Peter Hutterer
The touchpads currently all send a default value of 30 for ABS_PRESSURE. For some tests we want to have a custom pressure but changing all tests isn't sensible. So hook each device up to send a default value of 30 if it isn't overridden in the test itself. Signed-off-by: Peter Hutterer

Re: [PATCH libinput 5/9] udev: add Elantech touchpad firmware detection

2015-07-08 Thread Peter Hutterer
On Wed, Jul 08, 2015 at 02:34:43PM +0200, Hans de Goede wrote: Hi, On 01-07-15 08:08, Peter Hutterer wrote: Only firmware v4 (and probably whatever comes in the future) have resolution set, for the first couple of touchpads we need size hints. Add a callout that looks at the properties on

[PATCH v2 libinput 5.5/9] udev: add a model-quirks callout

2015-07-08 Thread Peter Hutterer
Some model-specific information isn't available through udev properties. This callout is used to query the device directly and set a property that we can then match on for the hwdb entries. This is geared for Elantech and ALPS touchpads where the firmware version is the interesting bit. The udev