Re: [PATCH libinput 1/3] test: skip manually setting uinput resolution if it's already set

2016-05-18 Thread Peter Hutterer
On Wed, May 18, 2016 at 10:48:45AM +0200, Hans de Goede wrote: > Hi, > > On 18-05-16 09:02, Peter Hutterer wrote: > > If we have libevdev 1.5 or later, the resolution is already set, no need to > > change it again. Let's rely on libevdev to do the right thing and simply > > skip > > the rest if

Re: writing Was: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Yong Bakos
Hi, I'm partly to blame for the bikeshedding on writing, yet believe me, I'm always asking "is this worth it?", prioritizing corrections/clarity over mere style judgements, and am definitely sensitive to everyone's cognitive bandwidth. My goal is high quality documentation for Wayland, and I am

Re: [PATCH wayland-protocols v2 1/7] xdg-shell: Turn xdg_surface into a generic base interface

2016-05-18 Thread Yong Bakos
On May 17, 2016, at 10:48 PM, Jonas Ådahl wrote: > > On Tue, May 17, 2016 at 01:35:43PM -0500, Yong Bakos wrote: >> On May 11, 2016, at 12:49 AM, Jonas Ådahl wrote: >>> >>> Split out toplevel window like requests and events into a new interface >>> called

[PATCH weston v2 1/3] compositor-x11: add assert to avoid misuse of x11_backend_deliver_button_event

2016-05-18 Thread Benoit Gschwind
The x11_backend_deliver_button_event can be called with any xcb_generic_event. The assert check if the call is done with the expected events. Signed-off-by: Benoit Gschwind --- src/compositor-x11.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/src/compositor-x11.c

[PATCH weston v2 3/3] compositor-x11: remove manual mouse button grab/ungrab

2016-05-18 Thread Benoit Gschwind
In current compositor-x11, the mouse buttons are grabbed and ungrabbed manually that may produce weird cases like starting a grab while the buttons are already released, due to asynchronous X11 events dispatching. The patch avoid the issue by using the better passive button grab, that

[PATCH weston v2 2/3] compositor-x11: remove redundant state arg of x11_backend_deliver_button_event

2016-05-18 Thread Benoit Gschwind
The "state" variable in x11_backend_deliver_button_event is basically the same as (event->response_type == XCB_BUTTON_PRESS), thus update the code to use the last one. Signed-off-by: Benoit Gschwind --- src/compositor-x11.c | 21 ++--- 1 file changed, 10

[PATCH weston v2 0/3] compositor-x11: improving handling of mouse events

2016-05-18 Thread Benoit Gschwind
v2: - fix assert to comply weston coding style. v1: - add some sanity checking, - remove redundant viarable, - use a better X11 passive grab Benoit Gschwind (3): compositor-x11: add assert to avoid misuse of x11_backend_deliver_button_event compositor-x11: remove redundant state arg

Re: [PATCH weston v1 3/3] compositor-x11: remove manual mouse button grab/ungrab

2016-05-18 Thread Benoit Gschwind
Hello Bill, You are right, thus I dug into the git history and I found that the grab is mostly to confine the cursor into the X11 window. For reference, the git commit id [1] and the related bug [2]. Since I do not want introduce a regression, I think the minor improvement is valid. Best

Re: [PATCH weston] zunitc: use platform-independent macros for integer formatting

2016-05-18 Thread Emmanuel Gil Peyrot
On Wed, May 18, 2016 at 05:18:18PM +0100, Emmanuel Gil Peyrot wrote: > From: Emmanuel Gil Peyrot > > Fixes warnings and potential issues on 32-bit platforms, tested only on > ARM but I’d expect the same issue on i686. > > Signed-off-by: Emmanuel Gil Peyrot

[PATCH weston] zunitc: use platform-independent macros for integer formatting

2016-05-18 Thread Emmanuel Gil Peyrot
From: Emmanuel Gil Peyrot Fixes warnings and potential issues on 32-bit platforms, tested only on ARM but I’d expect the same issue on i686. Signed-off-by: Emmanuel Gil Peyrot --- This patch should be fine to land during the 1.11 beta, it

[PATCH weston v2 1/1] compositor-drm: Add support for EGLDevice+EGLOutput

2016-05-18 Thread Miguel A. Vico
As previously stated, EGLDevice and EGLOutput will provide means to access native device objects and different portions of display control hardware respectively. Whenever EGL_EXT_device_drm extension is present, EGLDevice can be used to enumerate and access DRM KMS devices, and EGLOutputLayer to

[PATCH weston v2 3/3] gl-renderer: Add EGL client support for EGLStream frame presentation

2016-05-18 Thread Miguel A. Vico
By attaching a GLTexture consumer to a stream, a producer (wayland EGL client) could feed frames to a texture, which in turn can be used by a compositor to prepare the final frame to be presented. This change adds required logic to support presentation approach described above. Note that some

[PATCH weston v2 2/3] gl-renderer: Add support for EGLDevice composited frame presentation

2016-05-18 Thread Miguel A. Vico
EGLDevice provides means to enumerate native devices, and then create an EGL display connection from them. Similarly, EGLOutput will provide means to access different portions of display control hardware associated with an EGLDevice. For instance, EGLOutputLayer represents a portion of display

[PATCH weston v2 1/3] gl-renderer: Add EGLDevice enumeration support

2016-05-18 Thread Miguel A. Vico
EGLDevice provides means to enumerate native devices. In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change adds both gl_renderer_get_devices() and gl_renderer_get_drm_device_file() functions which will help to enumerate EGLDevices and match

[PATCH weston v2 1/1] gl-renderer: Refactor gl_renderer_output_window_create()

2016-05-18 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change refactors gl_renderer_output_window_create() to separate out window surface creation code from output common creation code. Bonus: Fix EGLSurface leakage upon gl_renderer_setup() failure.

[PATCH weston v2 5/5] gl-renderer: Accept non-NULL empty arrays

2016-05-18 Thread Miguel A. Vico
This change modifies egl_choose_config() to accept a non-NULL but empty array (i.e. n_ids == 0) Signed-off-by: Miguel A Vico Moya Reviewed-by: Andy Ritger Reviewed-by: James Jones --- src/gl-renderer.c | 2 +- 1 file changed, 1

[PATCH weston v2 4/5] gl-renderer: Add param to gl_renderer_display_create

2016-05-18 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change adds parameter to gl_renderer_display_create(). Signed-off-by: Miguel A Vico Moya Reviewed-by: Andy Ritger Reviewed-by: James Jones

[PATCH weston v2 3/5] gl-renderer: Rename param of gl_renderer to

2016-05-18 Thread Miguel A. Vico
In preparation for follow-on changes to support frame presentation through EGLDevice+EGLOutput, this change renames parameter of gl_renderer_display_create() and gl_renderer_output_window_create() to Signed-off-by: Miguel A Vico Moya Reviewed-by: Andy Ritger

[PATCH weston v2 2/5] gl-renderer: Rename gl_renderer::output_create to output_window_create

2016-05-18 Thread Miguel A. Vico
No functional change. This patch renames gl_renderer_output_create() to gl_renderer_output_window_create(), which is something more descriptive of what the function does. Signed-off-by: Miguel A Vico Moya Reviewed-by: Andy Ritger Reviewed-by: James

[PATCH weston v2 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Miguel A. Vico
No functional change. This patch only renames gl_renderer_create() to gl_renderer_display_create(), which is something more descriptive of what the function does. Signed-off-by: Miguel A Vico Moya Reviewed-by: James Jones --- src/compositor-drm.c |

Re: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Miguel Angel Vico
Thank you all for your clarifications. I'm about to send updated revisions of all patches. I made a rebase and fixed all indentation/alignment issues across all patches. Thanks. On Wed, 18 May 2016 15:31:32 +0100 Daniel Stone wrote: > Hi, > > On 18 May 2016 at 15:25,

Re: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Daniel Stone
Hi, On 18 May 2016 at 15:25, Derek Foreman wrote: > On 18/05/16 08:41 AM, Mike Blumenkrantz wrote: >> In fairness, we'd likely be less short on review bandwidth if the >> majority of that bandwidth was not in use to make/revise trivial >> criticisms such as whitespace

Re: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Derek Foreman
On 18/05/16 08:41 AM, Mike Blumenkrantz wrote: > > > On Wed, May 18, 2016 at 3:51 AM Pekka Paalanen > wrote: > > On Thu, 12 May 2016 17:20:49 +0200 > Miguel Angel Vico > wrote: >

Re: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Mike Blumenkrantz
On Wed, May 18, 2016 at 3:51 AM Pekka Paalanen wrote: > On Thu, 12 May 2016 17:20:49 +0200 > Miguel Angel Vico wrote: > > > Thanks Derek. > > > > Inline. > > > > On Thu, 12 May 2016 08:54:26 -0500 > > Derek Foreman wrote: > > >

RE: [PATCH] weston-launch: Handle invalid command line options

2016-05-18 Thread Tom Hochstein
Sorry, my commit message could have been clearer. The command does already print an 'unrecognized option' message. What's changed with this patch is we exit on error. Tom -Original Message- From: Jonas Ådahl [mailto:jad...@gmail.com] Sent: Tuesday, May 17, 2016 1:35 AM To: Yong Bakos

Re: [PATCH wayland-protocols v3] Add screensaver idle inhibitor protocol

2016-05-18 Thread Pekka Paalanen
On Thu, 24 Mar 2016 11:14:33 -0700 Bryce Harrington wrote: > This interface allows disabling of screensaver/screenblanking on a > per-surface basis. As long as the surface remains visible and > non-occluded it blocks the screensaver, etc. from activating on the >

[PATCH weston v2] ivi-layout: Initialize surface source rectange to 1x1

2016-05-18 Thread mateuszx . potrola
From: Mateusz Polrola If surface will be set to visible before its source rectangle will be defined it will be displayed in its orginal size. This is because initial setting of destination rectangle to 1x1 is not causing surface resize and because source rectangle is

RE: [PATCH] ivi-layout: Initialize surface source rectange to 1x1

2016-05-18 Thread Potrola, MateuszX
> > ivi-shell/ivi-layout.c | 3 +++ > > 1 file changed, 3 insertions(+) > > > > diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout.c index > > 1601787..ef7ee02 100644 > > --- a/ivi-shell/ivi-layout.c > > +++ b/ivi-shell/ivi-layout.c > > @@ -250,6 +250,9 @@ init_surface_properties(struct >

Re: [PATCH libinput 2/3] touchpad: disable cursor jump detection for Wacom tablets

2016-05-18 Thread Hans de Goede
Hi, On 18-05-16 09:02, Peter Hutterer wrote: We haven't seen jumps on Wacom tablets yet and they cause error messages in most of the tests. litest uses a scaling approach for most events, so a finger move that moves from 30% to 80% of the touchpad with can easily trigger a jump on a Wacom

Re: [PATCH libinput 3/3] test: fix a couple of touchpad tests that triggered the cursor jump warning

2016-05-18 Thread Hans de Goede
Hi, On 18-05-16 09:02, Peter Hutterer wrote: Signed-off-by: Peter Hutterer Reviewed-by: Hans de Goede Regards, Hans --- test/touchpad.c | 40 1 file changed, 20 insertions(+), 20 deletions(-)

Re: [PATCH libinput 1/3] test: skip manually setting uinput resolution if it's already set

2016-05-18 Thread Hans de Goede
Hi, On 18-05-16 09:02, Peter Hutterer wrote: If we have libevdev 1.5 or later, the resolution is already set, no need to change it again. Let's rely on libevdev to do the right thing and simply skip the rest if we have one nonzero resolution already set on the device. Signed-off-by: Peter

Re: [PATCH libinput] touchpad: only use negative pressure change check on Lenovo *50 and *60 series

2016-05-18 Thread Hans de Goede
Hi, On 18-05-16 09:00, Peter Hutterer wrote: This was introduced for bug 94379 - an X1 Carbon 3rd. Other touchpads have different pressure change ranges, causing this condition to trigger randomly and resulting in a jerky pointer motion. For now, reduce the check to the *50 and *60 series

[ANNOUNCE] weston 1.10.92

2016-05-18 Thread Bryce Harrington
Here is the beta for the upcoming 1.11 release. A brief summary of some of the main changes for 1.11 follows. == libweston == A concerted effort to push the libweston development along reworked how backends are configured to permit them to be initialized independent of Weston's main.c. This

[ANNOUNCE] wayland 1.10.92

2016-05-18 Thread Bryce Harrington
The beta for the upcoming 1.11 release is now available on Wayland's download page. Only a few things changed since the alpha. Here's a short run down of all the major changes in 1.11: Proxy wrappers were introduced, which help avoid race conditions in multi-threaded clients. A new "proxy

Re: [PATCH weston 1/5] gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

2016-05-18 Thread Pekka Paalanen
On Thu, 12 May 2016 17:20:49 +0200 Miguel Angel Vico wrote: > Thanks Derek. > > Inline. > > On Thu, 12 May 2016 08:54:26 -0500 > Derek Foreman wrote: > > > On 11/05/16 10:53 AM, Miguel Angel Vico wrote: > > > Thanks, Yong. > > > > > > Inline.

[PATCH libinput 3/3] test: fix a couple of touchpad tests that triggered the cursor jump warning

2016-05-18 Thread Peter Hutterer
Signed-off-by: Peter Hutterer --- test/touchpad.c | 40 1 file changed, 20 insertions(+), 20 deletions(-) diff --git a/test/touchpad.c b/test/touchpad.c index 2dbb346..ea719a3 100644 --- a/test/touchpad.c +++ b/test/touchpad.c

[PATCH libinput 2/3] touchpad: disable cursor jump detection for Wacom tablets

2016-05-18 Thread Peter Hutterer
We haven't seen jumps on Wacom tablets yet and they cause error messages in most of the tests. litest uses a scaling approach for most events, so a finger move that moves from 30% to 80% of the touchpad with can easily trigger a jump on a Wacom tablet due to its physical size. Rather than having

[PATCH libinput 1/3] test: skip manually setting uinput resolution if it's already set

2016-05-18 Thread Peter Hutterer
If we have libevdev 1.5 or later, the resolution is already set, no need to change it again. Let's rely on libevdev to do the right thing and simply skip the rest if we have one nonzero resolution already set on the device. Signed-off-by: Peter Hutterer ---

[PATCH libinput] touchpad: only use negative pressure change check on Lenovo *50 and *60 series

2016-05-18 Thread Peter Hutterer
This was introduced for bug 94379 - an X1 Carbon 3rd. Other touchpads have different pressure change ranges, causing this condition to trigger randomly and resulting in a jerky pointer motion. For now, reduce the check to the *50 and *60 series touchpads until we have data for more touchpads that