Title: [207413] trunk/Source/WebKit2
Revision
207413
Author
cdu...@apple.com
Date
2016-10-17 10:48:28 -0700 (Mon, 17 Oct 2016)

Log Message

[iOS] Hook up WebPlatformTouchPoint's radiusX / radiusY to _UIWebTouchPoint.majorRadiusInScreenCoordinates
https://bugs.webkit.org/show_bug.cgi?id=163547

Reviewed by Darin Adler.

Hook up WebPlatformTouchPoint's radiusX / radiusY to _UIWebTouchPoint.majorRadiusInScreenCoordinates
now that it is available in UIKit.

* Platform/spi/ios/UIKitSPI.h:
* Shared/ios/NativeWebTouchEventIOS.mm:
(WebKit::NativeWebTouchEvent::extractWebTouchPoint):

Modified Paths

Diff

Modified: trunk/Source/WebKit2/ChangeLog (207412 => 207413)


--- trunk/Source/WebKit2/ChangeLog	2016-10-17 17:32:18 UTC (rev 207412)
+++ trunk/Source/WebKit2/ChangeLog	2016-10-17 17:48:28 UTC (rev 207413)
@@ -1,3 +1,17 @@
+2016-10-17  Chris Dumez  <cdu...@apple.com>
+
+        [iOS] Hook up WebPlatformTouchPoint's radiusX / radiusY to _UIWebTouchPoint.majorRadiusInScreenCoordinates
+        https://bugs.webkit.org/show_bug.cgi?id=163547
+
+        Reviewed by Darin Adler.
+
+        Hook up WebPlatformTouchPoint's radiusX / radiusY to _UIWebTouchPoint.majorRadiusInScreenCoordinates
+        now that it is available in UIKit.
+
+        * Platform/spi/ios/UIKitSPI.h:
+        * Shared/ios/NativeWebTouchEventIOS.mm:
+        (WebKit::NativeWebTouchEvent::extractWebTouchPoint):
+
 2016-10-17  Konstantin Tokarev  <annu...@yandex.ru>
 
         Eleminate code duplication between ResourceRequest encoding/decoding implementations

Modified: trunk/Source/WebKit2/Platform/spi/ios/UIKitSPI.h (207412 => 207413)


--- trunk/Source/WebKit2/Platform/spi/ios/UIKitSPI.h	2016-10-17 17:32:18 UTC (rev 207412)
+++ trunk/Source/WebKit2/Platform/spi/ios/UIKitSPI.h	2016-10-17 17:48:28 UTC (rev 207413)
@@ -654,8 +654,7 @@
     unsigned identifier;
     UITouchPhase phase;
 #if __IPHONE_OS_VERSION_MIN_REQUIRED > 100000
-    // FIXME: Uncomment this once UIKit is updated (rdar://problem/28555313).
-    // CGFloat majorRadiusInScreenCoordinates;
+    CGFloat majorRadiusInScreenCoordinates;
     CGFloat force;
     CGFloat altitudeAngle;
     CGFloat azimuthAngle;

Modified: trunk/Source/WebKit2/Shared/ios/NativeWebTouchEventIOS.mm (207412 => 207413)


--- trunk/Source/WebKit2/Shared/ios/NativeWebTouchEventIOS.mm	2016-10-17 17:32:18 UTC (rev 207412)
+++ trunk/Source/WebKit2/Shared/ios/NativeWebTouchEventIOS.mm	2016-10-17 17:48:28 UTC (rev 207413)
@@ -103,9 +103,8 @@
         WebPlatformTouchPoint::TouchPointState phase = convertTouchPhase(touchPoint.phase);
         WebPlatformTouchPoint platformTouchPoint = WebPlatformTouchPoint(identifier, location, phase);
 #if ENABLE(IOS_TOUCH_EVENTS)
-        // FIXME: We should use touchPoint.majorRadiusInScreenCoordinates for radiusX / radiusY once it is available (rdar://problem/28555313).
-        platformTouchPoint.setRadiusX(0);
-        platformTouchPoint.setRadiusY(0);
+        platformTouchPoint.setRadiusX(touchPoint.majorRadiusInScreenCoordinates);
+        platformTouchPoint.setRadiusY(touchPoint.majorRadiusInScreenCoordinates);
         platformTouchPoint.setRotationAngle(0); // Not available in _UIWebTouchEvent yet.
         platformTouchPoint.setForce(touchPoint.force);
 #if defined UI_WEB_TOUCH_EVENT_HAS_STYLUS_DATA && UI_WEB_TOUCH_EVENT_HAS_STYLUS_DATA
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to