Title: [287147] trunk/Source/WebCore
Revision
287147
Author
bfulg...@apple.com
Date
2021-12-16 11:23:34 -0800 (Thu, 16 Dec 2021)

Log Message

Rename forEachFrameFromMainFrame to forEachFrame
https://bugs.webkit.org/show_bug.cgi?id=234396
<rdar://problem/86581926>

Reviewed by Geoffrey Garen.

Follow-up to r287110: Switch method naming to match 'forEachDocument'.

* page/Page.cpp:
(WebCore::Page::~Page):
(WebCore::Page::notifyToInjectUserScripts):
(WebCore::Page::forEachFrame):
(WebCore::Page::forEachFrameFromMainFrame): Deleted.
* page/Page.h:

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (287146 => 287147)


--- trunk/Source/WebCore/ChangeLog	2021-12-16 18:57:43 UTC (rev 287146)
+++ trunk/Source/WebCore/ChangeLog	2021-12-16 19:23:34 UTC (rev 287147)
@@ -1,3 +1,20 @@
+2021-12-16  Brent Fulgham  <bfulg...@apple.com>
+
+        Rename forEachFrameFromMainFrame to forEachFrame
+        https://bugs.webkit.org/show_bug.cgi?id=234396
+        <rdar://problem/86581926>
+
+        Reviewed by Geoffrey Garen.
+
+        Follow-up to r287110: Switch method naming to match 'forEachDocument'.
+
+        * page/Page.cpp:
+        (WebCore::Page::~Page):
+        (WebCore::Page::notifyToInjectUserScripts):
+        (WebCore::Page::forEachFrame):
+        (WebCore::Page::forEachFrameFromMainFrame): Deleted.
+        * page/Page.h:
+
 2021-12-16  John Cunningham  <johncunning...@apple.com>
 
         [GPUP] Create WebGL context with task id token

Modified: trunk/Source/WebCore/page/Page.cpp (287146 => 287147)


--- trunk/Source/WebCore/page/Page.cpp	2021-12-16 18:57:43 UTC (rev 287146)
+++ trunk/Source/WebCore/page/Page.cpp	2021-12-16 19:23:34 UTC (rev 287147)
@@ -407,7 +407,7 @@
 
     m_inspectorController->inspectedPageDestroyed();
 
-    forEachFrameFromMainFrame([] (Frame& frame) {
+    forEachFrame([] (Frame& frame) {
         frame.willDetachPage();
         frame.detachFromPage();
     });
@@ -2991,7 +2991,7 @@
 {
     m_hasBeenNotifiedToInjectUserScripts = true;
 
-    forEachFrameFromMainFrame([] (Frame& frame) {
+    forEachFrame([] (Frame& frame) {
         frame.injectUserScriptsAwaitingNotification();
     });
 }
@@ -3432,7 +3432,7 @@
 #endif
 }
 
-void Page::forEachFrameFromMainFrame(const Function<void(Frame&)>& functor)
+void Page::forEachFrame(const Function<void(Frame&)>& functor)
 {
     Vector<Ref<Frame>> frames;
     for (auto* frame = &mainFrame(); frame; frame = frame->tree().traverseNext())

Modified: trunk/Source/WebCore/page/Page.h (287146 => 287147)


--- trunk/Source/WebCore/page/Page.h	2021-12-16 18:57:43 UTC (rev 287146)
+++ trunk/Source/WebCore/page/Page.h	2021-12-16 19:23:34 UTC (rev 287147)
@@ -893,7 +893,7 @@
     WEBCORE_EXPORT void forEachDocument(const Function<void(Document&)>&) const;
     void forEachMediaElement(const Function<void(HTMLMediaElement&)>&);
     static void forEachDocumentFromMainFrame(const Frame&, const Function<void(Document&)>&);
-    void forEachFrameFromMainFrame(const Function<void(Frame&)>&);
+    void forEachFrame(const Function<void(Frame&)>&);
 
     bool shouldDisableCorsForRequestTo(const URL&) const;
 
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to