Title: [229373] trunk/Source/_javascript_Core
Revision
229373
Author
mark....@apple.com
Date
2018-03-07 13:10:57 -0800 (Wed, 07 Mar 2018)

Log Message

Rename ProtoCallFrame::arityMissMatch to hasArityMismatch.
https://bugs.webkit.org/show_bug.cgi?id=183414
<rdar://problem/38231678>

Reviewed by Michael Saboff.

* interpreter/ProtoCallFrame.cpp:
(JSC::ProtoCallFrame::init):
* interpreter/ProtoCallFrame.h:

Modified Paths

Diff

Modified: trunk/Source/_javascript_Core/ChangeLog (229372 => 229373)


--- trunk/Source/_javascript_Core/ChangeLog	2018-03-07 20:29:17 UTC (rev 229372)
+++ trunk/Source/_javascript_Core/ChangeLog	2018-03-07 21:10:57 UTC (rev 229373)
@@ -1,5 +1,17 @@
 2018-03-07  Mark Lam  <mark....@apple.com>
 
+        Rename ProtoCallFrame::arityMissMatch to hasArityMismatch.
+        https://bugs.webkit.org/show_bug.cgi?id=183414
+        <rdar://problem/38231678>
+
+        Reviewed by Michael Saboff.
+
+        * interpreter/ProtoCallFrame.cpp:
+        (JSC::ProtoCallFrame::init):
+        * interpreter/ProtoCallFrame.h:
+
+2018-03-07  Mark Lam  <mark....@apple.com>
+
         Simplify the variants of FunctionPtr constructors.
         https://bugs.webkit.org/show_bug.cgi?id=183399
         <rdar://problem/38212980>

Modified: trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.cpp (229372 => 229373)


--- trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.cpp	2018-03-07 20:29:17 UTC (rev 229372)
+++ trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.cpp	2018-03-07 21:10:57 UTC (rev 229373)
@@ -1,5 +1,5 @@
 /*
- * Copyright (C) 2013 Apple Inc. All Rights Reserved.
+ * Copyright (C) 2013-2018 Apple Inc. All Rights Reserved.
  *
  * Redistribution and use in source and binary forms, with or without
  * modification, are permitted provided that the following conditions
@@ -39,9 +39,9 @@
     this->setCallee(callee);
     this->setArgumentCountIncludingThis(argCountIncludingThis);
     if (codeBlock && argCountIncludingThis < codeBlock->numParameters())
-        this->arityMissMatch = true;
+        this->hasArityMismatch = true;
     else
-        this->arityMissMatch = false;
+        this->hasArityMismatch = false;
 
     // Round up argCountIncludingThis to keep the stack frame size aligned.
     size_t paddedArgsCount = roundArgumentCountToAlignFrame(argCountIncludingThis);

Modified: trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.h (229372 => 229373)


--- trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.h	2018-03-07 20:29:17 UTC (rev 229372)
+++ trunk/Source/_javascript_Core/interpreter/ProtoCallFrame.h	2018-03-07 21:10:57 UTC (rev 229373)
@@ -1,5 +1,5 @@
 /*
- * Copyright (C) 2013-2017 Apple Inc. All Rights Reserved.
+ * Copyright (C) 2013-2018 Apple Inc. All Rights Reserved.
  *
  * Redistribution and use in source and binary forms, with or without
  * modification, are permitted provided that the following conditions
@@ -38,7 +38,7 @@
     Register argCountAndCodeOriginValue;
     Register thisArg;
     uint32_t paddedArgCount;
-    bool arityMissMatch;
+    bool hasArityMismatch;
     JSValue *args;
 
     void init(CodeBlock*, JSObject*, JSValue, int, JSValue* otherArgs = 0);
@@ -59,7 +59,7 @@
     JSValue thisValue() const { return thisArg.Register::jsValue(); }
     void setThisValue(JSValue value) { thisArg = value; }
 
-    bool needArityCheck() { return arityMissMatch; }
+    bool needArityCheck() { return hasArityMismatch; }
 
     JSValue argument(size_t argumentIndex)
     {
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to