Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Adam Barth
On Thu, Dec 8, 2011 at 9:55 AM, Adam Barth wrote: > On Thu, Dec 8, 2011 at 9:52 AM, Pavel Feldman wrote: >> >> On Thu, Dec 8, 2011 at 9:34 AM, Adam Barth wrote: >>> >>> On Thu, Dec 8, 2011 at 9:16 AM, Pavel Feldman >>> wrote: >>> > On Thu, Dec 8, 2011 at 8:51 AM, Adam Barth wrote: >>> >> >>> >

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Adam Barth
On Thu, Dec 8, 2011 at 9:52 AM, Pavel Feldman wrote: > > On Thu, Dec 8, 2011 at 9:34 AM, Adam Barth wrote: >> >> On Thu, Dec 8, 2011 at 9:16 AM, Pavel Feldman >> wrote: >> > On Thu, Dec 8, 2011 at 8:51 AM, Adam Barth wrote: >> >> >> >> Check out InspectorValue.  It should be renamed to JSONValu

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Pavel Feldman
On Thu, Dec 8, 2011 at 9:34 AM, Adam Barth wrote: > On Thu, Dec 8, 2011 at 9:16 AM, Pavel Feldman > wrote: > > On Thu, Dec 8, 2011 at 8:51 AM, Adam Barth wrote: > >> > >> Check out InspectorValue. It should be renamed to JSONValue, but it > >> should meet your needs. > > > > InspectorValue is

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Adam Barth
On Thu, Dec 8, 2011 at 9:16 AM, Pavel Feldman wrote: > On Thu, Dec 8, 2011 at 8:51 AM, Adam Barth wrote: >> >> Check out InspectorValue.  It should be renamed to JSONValue, but it >> should meet your needs. > > InspectorValue is not intended to be used as a full fledged JSON parser. It > only cov

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Jarred Nicholls
That's precisely what I wanted to do initially. I had conflicting feelings on this, but my first intuition was to cache in the bindings the value directly parsed and state managed by the respective VM. I don't see this value being used by a different binding layer in parallel. On Thu, Dec 8, 201

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Pavel Feldman
On Thu, Dec 8, 2011 at 8:51 AM, Adam Barth wrote: > Check out InspectorValue. It should be renamed to JSONValue, but it > should meet your needs. > InspectorValue is not intended to be used as a full fledged JSON parser. It only covers subset of the standard that is sufficient for the inspector

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Oliver Hunt
It's not safe to use ScriptObject for values that are kept alive by JS objects as it leads to cycles in the collector. Also the cached value for an attribute should be in the binding classes, not the implementation classes. The easiest way to understand why is to ask yourself how a non-js (obj

Re: [webkit-dev] Internal JSON Parsing

2011-12-08 Thread Adam Barth
Check out InspectorValue. It should be renamed to JSONValue, but it should meet your needs. Adam On Dec 8, 2011 8:39 AM, "Jarred Nicholls" wrote: > Hey webkittens, > > I'm working on https://bugs.webkit.org/show_bug.cgi?id=73648 to support > the json response entity from XHR.response. Unless

[webkit-dev] Internal JSON Parsing

2011-12-08 Thread Jarred Nicholls
Hey webkittens, I'm working on https://bugs.webkit.org/show_bug.cgi?id=73648 to support the json response entity from XHR.response. Unless I'm mistaken (the purpose of this inquiry) we don't appear to have a VM-agnostic interface for internal JSON parsing, i.e., straight to the parsers. If so, w