[webkit-dev] Re: Re: A newBie question about compilation (Artem Ananiev)

2007-10-02 Thread Eva Madrazo

Thanks Artem,
that was the problem!  I launch the build from windows shell and it 
builds! :)


now I want to test it, launching run-safari, but it doesnt work :( .  
Debugging the script I see that it is trying to launch a safari.exe command.
But I have no safari.exe command in all my system. ¿Have I missed 
something?  Perphaps I have to install safari in order to debug.. I do 
not know..


Thanks in advance,
 Eva




Hi, Eva,

qmake knows nothing about cygwin path notation ('/cygdrive/d/...') so it cannot 
find the file. This problem may be easily workarounded by passing all the paths 
to qmake in the form of 'd:\...' (requires some modification to webkitdirs.pm 
script). You may use `cygpath` utility to convert paths.


Artem

Eva Madrazo wrote:
  

Hello,
I am very new in this, including C++, symbian and webkit. So, apologize for my 
questions if they are so basic...

I was trying to compile webKit in a Windows XP proffesional.
I have installed cygwin and Qt (for qmake command).
I have download source code from subversion repository.
Then, I access to Scripts directory and execute build-webkit and the result is:


$ webkit/webkittools/scripts/build-webkit --debug
Checking mod-date of WebKitSupportLibrary.zip...
Current WebKitSupportLibrary is up to date
Calling 'qmake -r OUTPUT_DIR=/cygdrive/d/webkit/WebKitBuild/Debug
CONFIG+=qt-port /cygdrive/d/webkit/WebKit.pro CONFIG-=release CO
NFIG+=debug' in /cygdrive/d/webkit/WebKitBuild/Debug ...

Cannot find file: \cygdrive\d\webkit\WebKit.pro.
Failed to setup build environment using qmake!

But indeed the file exists!!

$ ls /cygdrive/d/webkit/WebKit.pro
/cygdrive/d/webkit/WebKit.pro

¿What's the matter? ..
By the way, I have not installed Visual C++ 2005 Express because I would 
like to use Carbide C++ ... ¿Is this possible?


Thank you very much,
 Eva
  





___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Re: Re: A newBie question about compilation (Artem Ananiev)

2007-10-02 Thread Artem Ananiev
Right, you can run your own build of WebKit (WebKit.dll) using Safari. The 
script 'run-safari', as I remember, searches for Safari at the default location 
only (c:\program files\safari\safari.exe), so you need to install Safari there 
or modify the script.


Artem

Eva Madrazo wrote:

Thanks Artem,
that was the problem!  I launch the build from windows shell and it 
builds! :)


now I want to test it, launching run-safari, but it doesnt work :( .  
Debugging the script I see that it is trying to launch a safari.exe 
command.
But I have no safari.exe command in all my system. ¿Have I missed 
something?  Perphaps I have to install safari in order to debug.. I do 
not know..


Thanks in advance,
 Eva




Hi, Eva,

qmake knows nothing about cygwin path notation ('/cygdrive/d/...') so 
it cannot find the file. This problem may be easily workarounded by 
passing all the paths to qmake in the form of 'd:\...' (requires some 
modification to webkitdirs.pm script). You may use `cygpath` utility 
to convert paths.


Artem

Eva Madrazo wrote:
 

Hello,
I am very new in this, including C++, symbian and webkit. So, 
apologize for my questions if they are so basic...


I was trying to compile webKit in a Windows XP proffesional.
I have installed cygwin and Qt (for qmake command).
I have download source code from subversion repository.
Then, I access to Scripts directory and execute build-webkit and the 
result is:



$ webkit/webkittools/scripts/build-webkit --debug
Checking mod-date of WebKitSupportLibrary.zip...
Current WebKitSupportLibrary is up to date
Calling 'qmake -r OUTPUT_DIR=/cygdrive/d/webkit/WebKitBuild/Debug
CONFIG+=qt-port /cygdrive/d/webkit/WebKit.pro CONFIG-=release CO
NFIG+=debug' in /cygdrive/d/webkit/WebKitBuild/Debug ...

Cannot find file: \cygdrive\d\webkit\WebKit.pro.
Failed to setup build environment using qmake!

But indeed the file exists!!

$ ls /cygdrive/d/webkit/WebKit.pro
/cygdrive/d/webkit/WebKit.pro

¿What's the matter? ..
By the way, I have not installed Visual C++ 2005 Express because I 
would like to use Carbide C++ ... ¿Is this possible?


Thank you very much,
 Eva
 



___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] feature-branch is open for business again

2007-10-02 Thread Maciej Stachowiak


Oliver (with a bit of help from Eric and others) has gotten the  
rebased feature-branch reasonably solid. There are still some SVG  
issues, but it's all clear for other patches.


Regards,
Maciej

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Scheduled mailing list outage tomorrow

2007-10-02 Thread Mark Rowe

All,

The scheduled mailing list outage has completed.  If you run into any  
problems with the lists.webkit.org mailing lists, please let me know.


Kind regards,

Mark Rowe

On 02/10/2007, at 11:53, Mark Rowe wrote:


Hi all,

I was notified by the Mac OS Forge administrators that they are  
migrating mailing list services to new hardware. The various WebKit  
mailing lists on lists.webkit.org will be unavailable tomorrow  
morning (PDT):


Next we will be migrating the mail services. This includes the  
virtual aliases and mailing lists. We will be switching over  
tomorrow morning (10/02) around 9am PDT.  There will be a brief  
outage while the data (archives) move to the new hardware and the  
new DNS propagates. We will minimize it and let everyone know if  
there are any extended issues.


Kind regards,

Mark Rowe

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev