Re: [webkit-dev] PSA: WebKit2 and DrawingAreaImpl

2013-10-03 Thread Anders Carlsson
On Oct 2, 2013, at 10:28 AM, Brent Fulgham bfulg...@apple.com wrote: Hi Anders, On Oct 1, 2013, at 6:19 PM, Anders Carlsson ander...@apple.com wrote: I just wanted to let everyone know that we (Apple) are moving away from DrawingAreaImpl and always using our tiled drawing area. Longer

[webkit-dev] Fwd: WebGL :: Win32 = build successful and rendering assumed so = but white page

2013-10-03 Thread Hugo Machefer
Dear all. Might not the best place -here- to describe my issue [Win32], but I don't know where exactly this shall be submitted, as a novice by WebKit. To recap, I managed to compile WebKit-r156532 sources by Microsoft Visual Studio 2010 using CoreGraphics (ie without Cairo) in Debug mode. To

Re: [webkit-dev] WebGL :: Win32 = build successful and rendering assumed so = but white page

2013-10-03 Thread Tim Horton
On 2013.10.03, at 09:06, Hugo Machefer hugo.mache...@gmail.com wrote: Dear all. Might not the best place -here- to describe my issue [Win32], but I don't know where exactly this shall be submitted, as a novice by WebKit. To recap, I managed to compile WebKit-r156532 sources by Microsoft

Re: [webkit-dev] WebGL :: Win32 = build successful and rendering assumed so = but white page

2013-10-03 Thread Hugo Machefer
Thanks a lot Timothy. For some: part of my job might consist in doing this work -*for Windows*- required to actually display the result. Then, assuming WebKit-r156532 compiles and runs WebGL content succesfully *for Mac *(probably provided some settings : 'defaults write com.apple.Safari

Re: [webkit-dev] WebGL :: Win32 = build successful and rendering assumed so = but white page

2013-10-03 Thread Brent Fulgham
Hi Hugo, I think most of us in the WebKit project are aware of the missing pieces on the Apple Windows port, and have plans to rectify this. However, I don’t understand what your needs are regarding WebGL and the Apple Windows port. This port is not licensed for use outside of Apple’s own

[webkit-dev] Problem authenticating to svn

2013-10-03 Thread Gustavo Noronha Silva
Hey, I'm having trouble committing a patch. I can login to trac and to the buildbot, but svn doesn't let me in. I am using git-svn, I'm downloading the nightly tarball to try with svn itself just in case. My username is k...@webkit.org, can anyone take a peek at the server to see if there's