Re: [webkit-dev] exposing getUserMedia and RTCPeerConnection in Tech Preview?

2016-12-01 Thread Alexandre GOUAILLARD
supposedly those two? https://trac.webkit.org/browser/trunk/Source/WebCore/Modules/mediastream/NavigatorMediaDevices.idl https://trac.webkit.org/browser/trunk/Source/WebCore/Modules/mediastream/RTCPeerConnection.idl I opened a bug, https://bugs.webkit.org/show_bug.cgi?id=165251 I'm waiting for

Re: [webkit-dev] exposing getUserMedia and RTCPeerConnection in Tech Preview?

2016-12-01 Thread youenn fablet
It is good if we already have these runtime flags. Then we might just need to make the related IDLs exposed according that flag through EnabledAtRuntime keyword. y Le jeu. 1 déc. 2016 à 11:55, Alexandre GOUAILLARD a écrit : > Bonjour youenn, > > Eric avait fait ca en

Re: [webkit-dev] exposing getUserMedia and RTCPeerConnection in Tech Preview?

2016-12-01 Thread Alexandre GOUAILLARD
Bonjour youenn, Eric avait fait ca en mars cette année. Tu peux regarder les commits ci-dessous. J'ai vérifie hier, les flags de compil sont toujours a OFF, et les runtimes sont aussi gardes. Je ne sais pas pourquoi les API sont accessibles. https://bugs.webkit.org/show_bug.cgi?id=158393

Re: [webkit-dev] exposing getUserMedia and RTCPeerConnection in Tech Preview?

2016-12-01 Thread youenn fablet
Hi Philipp, Thanks for bringing that up. I think we should add runtime flags for getUserMedia and RTCPeerConnection and set them to off in Safari Tech Preview until stable enough. y Le mer. 30 nov. 2016 à 14:40, Philipp Hancke a écrit : > It has been brought to my