Re: [webkit-dev] WinLauncher Fail to launch

2012-11-24 Thread Chris Hatko
Rakesh, for win cairo the command is:
Tools/Scripts/build-webkit --wincairo

A nice guide using new compilers is here:
http://blog.ashodnakashian.com/2012/01/building-webkit-on-windows-7-with-vs2010/
(there is also a VS2008 and VS2012 post)

Chris


On Sat, Nov 24, 2012 at 5:59 AM, Rakesh Sadhu rakeshsa...@hotmail.comwrote:

  Hi ,

 ChatKo,
 I commented that part as well,  and following code fails and i get
 CFNetwork.dll not found error(as message box)

  HMODULE module = ::LoadLibraryW(exePath);

if (!module)
 return fatalError(programName, L::LoadLibraryW failed.);


 Brent,
 I am not sure that if wincairo means winwebkit and its build using
 following way

 Tools/Scripts/build-webkit --debug/release?


 And , I am using Latest Code  , I do Tools/Scripts/update-webkit before i
 start building.

 regards
 rsadhu






 --
 Date: Fri, 23 Nov 2012 13:50:08 -0500

 Subject: Re: [webkit-dev] WinLauncher Fail to launch
 From: cha...@gmail.com
 To: bfulg...@gmail.com
 CC: rakeshsa...@hotmail.com; webkit-dev@lists.webkit.org


 Depending  on how long ago he pulled (i think this was fixed in later
 revisions), you may need to do the following:


 In /Tools/win/DllLaunchermain.cpp Comment out:

 //if (!modifyPath(programName))

 // return 1;
 To not check for apple products.


 On Fri, Nov 23, 2012 at 12:16 PM, Brent Fulgham bfulg...@gmail.comwrote:

 Hi Rakesh,

 If you build the WinCairo port, you don't need iTunes or Safari to be
 installed.

 -Brent

 Sent from my iPhone

 On Nov 23, 2012, at 12:49 AM, Rakesh Sadhu rakeshsa...@hotmail.com
 wrote:

  Hi All,
 My Webkit Launches now .
 I needed Safari  and ITunes to be installed .
 I'd like to request Webkit.org  that please add these requirements as
 well.
 My Winlauncher/Minibrowser launch was failing and after debugging i
 noticed it  fails in reading registry and couldn't find certain packages ,
 and was getting CFNetwork.dll missing error as well.
 And After googling i noticed it comes along with Itunes.
 thanks

 --
 From: rakeshsa...@hotmail.com
 To: bfulg...@gmail.com
 Date: Wed, 21 Nov 2012 09:49:12 +0530
 CC: webkit-dev@lists.webkit.org
 Subject: Re: [webkit-dev] WinLauncher Fail to launch

  Hi,
 I tried using WinWinlauncher as well , i get the same error
 http://pastebin.com/jMikyxWb

 Am I missing some packages?
 regards
 rsadhu


 --
 CC: webkit-dev@lists.webkit.org
 From: bfulg...@gmail.com
 Subject: Re: [webkit-dev] WinLauncher Fail to launch
 Date: Tue, 20 Nov 2012 19:55:54 -0800
 To: rakeshsa...@hotmail.com

 Hi Rakesh,

 The WinCairo port only has a partially functional WebKit2 port.
 Consequently, MiniBrowser does not launch.

 You must run the WinLauncherLauncher target to see a working program. The
 WinLauncher project builds a DLL that holds the a trial program logic, but
 does not run as an executable.  This came about during the start if the
 WebKit2 work (WK2 runs as an external process to the main program
 executable, hence the new *LauncherLauncher projects.)

 -Brent

 Sent from my iPhone

 On Nov 20, 2012, at 7:45 PM, Rakesh Sadhu rakeshsa...@hotmail.com wrote:

  Dear  All,
 I've build  webkit@135274 on windows Xp using Visual Studio 2005 in debug
 as well release mode .
 When I try to launch WinLauncher , MiniBrowser they fail to launch.
 I tried to launch using VS2005 also , and i get following console
 Messages.:
 http://pastebin.com/mkzT0k5g

 Kindly do provide some pointers .

 regards
 rsadhu

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev


 ___ webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev


 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev




___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] WinLauncher Fail to launch

2012-11-23 Thread Chris Hatko
Depending  on how long ago he pulled (i think this was fixed in later
revisions), you may need to do the following:


In /Tools/win/DllLaunchermain.cpp Comment out:

//if (!modifyPath(programName))

// return 1;
To not check for apple products.


On Fri, Nov 23, 2012 at 12:16 PM, Brent Fulgham bfulg...@gmail.com wrote:

 Hi Rakesh,

 If you build the WinCairo port, you don't need iTunes or Safari to be
 installed.

 -Brent

 Sent from my iPhone

 On Nov 23, 2012, at 12:49 AM, Rakesh Sadhu rakeshsa...@hotmail.com
 wrote:

  Hi All,
 My Webkit Launches now .
 I needed Safari  and ITunes to be installed .
 I'd like to request Webkit.org  that please add these requirements as
 well.
 My Winlauncher/Minibrowser launch was failing and after debugging i
 noticed it  fails in reading registry and couldn't find certain packages ,
 and was getting CFNetwork.dll missing error as well.
 And After googling i noticed it comes along with Itunes.
 thanks

 --
 From: rakeshsa...@hotmail.com
 To: bfulg...@gmail.com
 Date: Wed, 21 Nov 2012 09:49:12 +0530
 CC: webkit-dev@lists.webkit.org
 Subject: Re: [webkit-dev] WinLauncher Fail to launch

  Hi,
 I tried using WinWinlauncher as well , i get the same error
 http://pastebin.com/jMikyxWb

 Am I missing some packages?
 regards
 rsadhu


 --
 CC: webkit-dev@lists.webkit.org
 From: bfulg...@gmail.com
 Subject: Re: [webkit-dev] WinLauncher Fail to launch
 Date: Tue, 20 Nov 2012 19:55:54 -0800
 To: rakeshsa...@hotmail.com

 Hi Rakesh,

 The WinCairo port only has a partially functional WebKit2 port.
 Consequently, MiniBrowser does not launch.

 You must run the WinLauncherLauncher target to see a working program. The
 WinLauncher project builds a DLL that holds the a trial program logic, but
 does not run as an executable.  This came about during the start if the
 WebKit2 work (WK2 runs as an external process to the main program
 executable, hence the new *LauncherLauncher projects.)

 -Brent

 Sent from my iPhone

 On Nov 20, 2012, at 7:45 PM, Rakesh Sadhu rakeshsa...@hotmail.com wrote:

  Dear  All,
 I've build  webkit@135274 on windows Xp using Visual Studio 2005 in debug
 as well release mode .
 When I try to launch WinLauncher , MiniBrowser they fail to launch.
 I tried to launch using VS2005 also , and i get following console
 Messages.:
 http://pastebin.com/mkzT0k5g

 Kindly do provide some pointers .

 regards
 rsadhu

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev


 ___ webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev


 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Problems to build WebKit on Windows

2010-08-31 Thread Chris Hatko
I presume this is a release build ... I ran into this problem myself.
You can switch to 64Bit OS or turn off whole program optimization
/GL and corresponding linker flag.

Chris

On Tue, Aug 31, 2010 at 5:20 PM, Diego Gonzalez
diego.gonza...@openbossa.org wrote:
 Hi,

 Thanks for the feedback!

 On Tue, Aug 31, 2010 at 12:01 PM, Ilya Tikhonovsky loi...@chromium.org
 wrote:

 It is the problem with VC project properties.
 The build script just remove all the properties
 from WebKitLibraries/win/tools/vsprops/ by mistake.
 This problem happens if you use git.
 I've created a bug about
 that. https://bugs.webkit.org/show_bug.cgi?id=44050
 The dirty hack for this is just create .svn file
 in WebKitLibraries/win/tools/vsprops/ folder and restore the files from the
 repository.

 My problem was related to git and your trick solve my build failures. Thanks
 a lot

 My problem now is to link the WebKit lib:

 11Compiling resources...
 11Performing Pre-Link Event...
 11    1 file(s) copied.
 11    1 file(s) copied.
 11Linking...
 11fatal error C1083: Cannot open compiler intermediate file:
 'C:\cygwin\home\rodribel\webkit\WebKitBuild\lib\WebKitLib.lib': Not enough
 space
 11LINK : fatal error LNK1257: code generation failed

 Do you (or anyone) knows about why this linking is exceeding the space?


 Regards,
 Diego


 Regards,
 Tim.


 On Tue, Aug 31, 2010 at 6:16 PM, Diego Gonzalez
 diego.gonza...@openbossa.org wrote:

 Hi folks,

 I have some problems to build WebKit ToT on my Window Env.
 I'm using Visual C++ express 2005.

 I've followed the steps win: http://webkit.org/building/tools.html
 After it I ran update-webkit and build-wekit script

 I got this build output: http://pastebin.com/x99zta73

 Some  build errors like:

 InspectorStorageAgent.cpp
 ..\inspector\InspectorStorageAgent.cpp(64) : error C2039:
 'sqlTransactionFailed' : is not a member of 'WebCore::InspectorFrontend'

 C:\cygwin\home\rodribel\webkit\WebKitBuild\obj\WebCore\DerivedSources\InspectorFrontend.h(17)
 : see declaration of 'WebCore::InspectorFrontend'
 ..\inspector\InspectorStorageAgent.cpp(98) : error C2039:
 'sqlTransactionSucceeded' : is not a member of 'WebCore::InspectorFrontend'

 C:\cygwin\home\rodribel\webkit\WebKitBuild\obj\WebCore\DerivedSources\InspectorFrontend.h(17)
 : see declaration of 'WebCore::InspectorFrontend'

 and

 SVGCSSStyleSelector.cpp

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2217)
 : error C2065: 'CSSValueButt' : undeclared identifier

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2231)
 : error C2051: case expression not constant

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2249)
 : error C2065: 'CSSValueMiter' : undeclared identifier

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2255)
 : error C2065: 'CSSValueBevel' : undeclared identifier

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2263)
 : error C2051: case expression not constant

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2267)
 : error C2051: case expression not constant

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2281)
 : error C2065: 'CSSValueNonzero' : undeclared identifier

 c:\cygwin\home\rodribel\webkit\webcore\css\CSSPrimitiveValueMappings.h(2284)
 : error C2065: 'CSSValueEvenodd' : undeclared identifier

 seems to be related with features disabled (e.g. database, svg) but these
 featrues were not disabled for the build. As I do not have experience
 with these Windows build tools, I wonder if someone could give me some
 directions to get this build ok.

 Thanks,
 Diego

 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev




 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


[webkit-dev] Runtime error in WebCore::ScriptExecutionContext::hasOpenDatabases()

2010-08-22 Thread Chris Hatko
Hi,

I'm running revision 65648 and building cairo-win32 release. I had to
fix several compile errors to get the build to work.

When I start winLauncher I get a runtime error: Unhandled exception at
0x00c829f1 (WebKit_debug.dll) in
WinLauncher_debug.exe: 0xC005: Access violation reading location
0x0114. Occurs in:
WebCore::ScriptExecutionContext::hasOpenDatabases() on member variable
access.

Has anyone encountered this before? Any ideas on whats wrong?

Thanks,

Chris

Trace:
WebKit_debug.dll!WebCore::ScriptExecutionContext::hasOpenDatabases()
Line 78 + 0x11 bytes  C++
   
WebKit_debug.dll!WebCore::PageCache::canCachePageContainingThisFrame(WebCore::Frame
* frame=0x04519a30)  Line 274 + 0xc9 bytes  C++
   WebKit_debug.dll!WebCore::PageCache::canCache(WebCore::Page *
page=0x04517f78)  Line 301 + 0xe bytes  C++
   WebKit_debug.dll!WebCore::FrameLoader::commitProvisionalLoad()  Line
1833 + 0x27 bytes   C++
   WebKit_debug.dll!WebCore::DocumentLoader::commitIfReady()  Line
261 C++
   WebKit_debug.dll!WebCore::DocumentLoader::finishedLoading()
Line 267   C++
   WebKit_debug.dll!WebCore::FrameLoader::init()  Line 239 C++
   WebKit_debug.dll!WebCore::Frame::init()  Line 352   C++
   WebKit_debug.dll!WebView::initWithFrame(tagRECT frame={...}, wchar_t
* frameName=0x, wchar_t * groupName=0x)  Line 2604  C++
   WinLauncher_debug.exe!wWinMain(HINSTANCE__ * hInstance=0x0040,
HINSTANCE__ * hPrevInstance=0x, wchar_t *
lpCmdLine=0x000209d8, int nCmdShow=0x0001)  Line 207 + 0x36
bytes   C++
   WinLauncher_debug.exe!__tmainCRTStartup()  Line 589 + 0x1c bytesC
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


[webkit-dev] Not enough space message when linking webkit (lots of free disk space)

2010-08-22 Thread Chris Hatko
I'm running revision 65648  and building cairo-win32 release I'm getting Not
enough space when linking WebKit project. I have 40Gig free space on
this drive and 4Gigs of ram.

Linking...
11fatal error C1083: Cannot open compiler intermediate file:
'C:\cygwin\home\HATKO\WebKit\WebKitBuild\lib\WebKitLib.lib': Not
enough space
11LINK : fatal error LNK1257: code generation failed
11Build log was saved at
file://C:\cygwin\home\HATKO\WebKit\WebKitBuild\obj\WebKit\Release_Cairo\BuildLog.htm
11WebKit - 1 error(s), 1 warning(s).

Any idea what I can try?

Thanks,

Chris
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


Re: [webkit-dev] Not enough space message when linking webkit (lots of free disk space)

2010-08-22 Thread Chris Hatko
Hi Nico,

Yes, I've got 32 bit MSVS2005. I found that turning off  /LTCG and /GL
optimization allowed me to get past this error. Do we now need more
than 4Gigs of RAM to compile webkit with release optimizations?

Chris

On Sun, Aug 22, 2010 at 4:09 PM, Nico Weber tha...@chromium.org wrote:
 Are you using a 32 bit linker? Maybe it's running out of address space.

 Nico

 On Sun, Aug 22, 2010 at 12:32 PM, Chris Hatko cha...@gmail.com wrote:
 I'm running revision 65648  and building cairo-win32 release I'm getting Not
 enough space when linking WebKit project. I have 40Gig free space on
 this drive and 4Gigs of ram.

 Linking...
 11fatal error C1083: Cannot open compiler intermediate file:
 'C:\cygwin\home\HATKO\WebKit\WebKitBuild\lib\WebKitLib.lib': Not
 enough space
 11LINK : fatal error LNK1257: code generation failed
 11Build log was saved at
 file://C:\cygwin\home\HATKO\WebKit\WebKitBuild\obj\WebKit\Release_Cairo\BuildLog.htm
 11WebKit - 1 error(s), 1 warning(s).

 Any idea what I can try?

 Thanks,

 Chris
 ___
 webkit-dev mailing list
 webkit-dev@lists.webkit.org
 http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev


___
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev