Re: [webkit-dev] Planning on Requiring Python 2.7 Soon

2014-09-11 Thread Brian Burg
IIRC, some GTK bots still run Python 2.6. (But not all of them?) Here’s a relevant workaround I landed a while ago: http://trac.webkit.org/changeset/172686 On Sep 10, 2014, at 4:31 PM, Brent Fulgham bfulg...@apple.com wrote: Hi Everyone, Now that I’ve worked through the minor issues that

Re: [webkit-dev] Planning on Requiring Python 2.7 Soon

2014-09-11 Thread Martin Robinson
On Thu, Sep 11, 2014 at 11:36 AM, Brian Burg b...@cs.washington.edu wrote: IIRC, some GTK bots still run Python 2.6. (But not all of them?) Here’s a relevant workaround I landed a while ago: http://trac.webkit.org/changeset/172686 I think (someone can correct me, if I'm wrong) that we can

Re: [webkit-dev] Planning on Requiring Python 2.7 Soon

2014-09-11 Thread Bem Jones-Bey
We broke some of the python tests yesterday and fixed them today, so it is likely what you saw. On Sep 11, 2014, at 17:54, Gyuyoung Kim gyuyoung@webkit.orgmailto:gyuyoung@webkit.org wrote: FYI, all EFL bots have worked with Python ver. 2.7.6. However, there are some failing python

[webkit-dev] Planning on Requiring Python 2.7 Soon

2014-09-10 Thread Brent Fulgham
Hi Everyone, Now that I’ve worked through the minor issues that prevented us from using Python 2.7 on our Windows bots, I’d like to move the goalposts and require Python 2.7 (or newer) for our build and test machines. Will this cause anyone any problems if this becomes the new law of the land?